1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Xcode - Kann keine Entitäten hinzufügen

Dieses Thema im Forum "OS X-Developer" wurde erstellt von Wrandy, 21.12.09.

  1. Wrandy

    Wrandy Reinette de Champagne

    Dabei seit:
    15.02.09
    Beiträge:
    420
    Hallo,

    Ich bin gerade beim Lesen von Amin Negm-Awad's Buch und sollte nun eine Entiät erstellen, doch leider stürzt bei mir Xcode komplett ab, wenn ich Add Entity wähle. Habe es auch einfach mal mit einem frischen Projekt probiert. Auch da stürzt Xcode dann sofort ab. Ich sehe nur ganz kurz irgendwas von einem Internal Error von Xcode direkt und dann schließt es sich und es kommt nur die normale Standard-Fehlerbericht-senden Möglichkeit von OSX...

    Habe Xcode 3.1.2, hier noch etwas genauer:
    Component versions
    Xcode IDE: 1149.0
    Xcode Core: 1148.0
    ToolSupport: 1102.0

    Und Snow Leopard auf dem aktuellen 13-Zoller Macbook Pro...

    Hoffe ihr könnt mir helfen...
     
  2. Amin Negm-Awad

    Amin Negm-Awad Süsser Pfaffenapfel

    Dabei seit:
    01.03.07
    Beiträge:
    665
    Nutze Xcode 3.2
     
  3. Wrandy

    Wrandy Reinette de Champagne

    Dabei seit:
    15.02.09
    Beiträge:
    420
    Erstmal danke für die Antowrt.

    Kann ich dort auch noch simple C-Programm schreiben? Hatte das nämlich mal oben und hab das dann nicht mehr gefunden bei New Project...Deshalb hab ich dann wieder von meiner Leopard DVD 3.1 raufgemacht...

    Ich brauche C noch für die Uni...
     
  4. macminiTomy

    macminiTomy Kleiner Weinapfel

    Dabei seit:
    02.10.08
    Beiträge:
    1.132
    Ja kannst du.

    Command Line Utility - Standart Tool

    oder du nutzt Codeblocks
     
  5. Amin Negm-Awad

    Amin Negm-Awad Süsser Pfaffenapfel

    Dabei seit:
    01.03.07
    Beiträge:
    665
    Hast du das in einem anderen Verzeichnis installiert oder drüber gebügelt? Das würde manches erklären.

    Ja, es geht noch. Seit neuestem ist Xcode der Ansicht, dass es sich bei CLT um Applications handelt. Wähle das links aus und dann rechts Command Line Tool. Du kannst dann darunter im Pop-Up C wählen.
     
  6. Wrandy

    Wrandy Reinette de Champagne

    Dabei seit:
    15.02.09
    Beiträge:
    420
    ah, danke. Habe es gerade installiert und auf Anhieb wieder nicht gefunden...Schon komisch, dass es eine App sein soll, aber gut.

    Danke für die Hilfe. Nun klappt das auch mit den Entities...

    Gibt es denn noch mehr solcher Änderung in 3.2? Insbesondere evtl. welche, die dann total vom Buch abweichen?
     
  7. Amin Negm-Awad

    Amin Negm-Awad Süsser Pfaffenapfel

    Dabei seit:
    01.03.07
    Beiträge:
    665
    Bei der Projekt- und Fileauswahl sieht manches anders aus – wie du ja gerade bemerkt hast. Im Prinzip ist aus den Listen einiges verschwunden und dafür im Pop-Up oder Checkboxe gelandet. Wenn du ein Problem damit hast, maile mich einfach kurz an.
     
  8. Wrandy

    Wrandy Reinette de Champagne

    Dabei seit:
    15.02.09
    Beiträge:
    420
    Ok, dankeschön...

    Habe aber gerade noch ein anderes größeres Problem... Ich kann nicht mehr kompilieren...

    Bekomme die Fehlermeldung:
    error: can't exec '/Developer/usr/bin/gcc-4.2' (No such file or directory)

    Habe mal nachgeschaut, die Datei gibt es in der Tat nicht.Lediglich eine llvm-gcc-4.2...Oder wird sie im Finder nicht angezeigt?
     
    #8 Wrandy, 21.12.09
    Zuletzt bearbeitet: 22.12.09
  9. Wrandy

    Wrandy Reinette de Champagne

    Dabei seit:
    15.02.09
    Beiträge:
    420
    Konnte das Problem selbst durch deinstallieren und neuinstallieren lösen...
     
  10. Wrandy

    Wrandy Reinette de Champagne

    Dabei seit:
    15.02.09
    Beiträge:
    420
    hmm, ich weiß nicht mehr genau, ob das jetzt immer noch an den Entitäten liegt, aber sie sind in meinem Problemobjekt mit verlinkt. Es geht um diesen Umrechner und den letzten Schritt, der Tabelle, in Kapitel 2. Leider funktioniert die bei mir nicht so richtig. Also, neue Zeilen anlegen klappt, löschen geht auch, aber ich kann den Namen nicht ändern, den Faktor nicht ändern, und wenn ich einmal in das Objekt klicke, geht nix mehr im Programm...

    Meine Analyse wäre, dass mir noch irgendeine Eigenschaft im Objektinspektor fehlt um die Werte der Zeilen zu ändern...und um zu verhindern, dass mir das Programm einfriert, sobald ich auf die Tabelle klicke...

    Was könnte ich denn falsch gemacht haben? Habe das jetzt schon zweimal nach Anleitung erstellt...Die Websiteversion wird richtig übersetzt und funktioniert auch...
     
  11. Amin Negm-Awad

    Amin Negm-Awad Süsser Pfaffenapfel

    Dabei seit:
    01.03.07
    Beiträge:
    665
    Deine Installation scheint wirklich kräftig im Arsch zu sein. Da das Model mit dem momc kompiliert wird, nicht mit dem gcc, vermute ich nicht isoliert dort das Problem.

    Wie hast du denn die alte Version deinstalliert? Hast du dazu das Deinstallationsskript verwendet? Wenn nein, mache das bitte. Ich würde danach auch noch einem komplett das Developer-Verzeichnis löschen und außerdem Xcode dann in einem anderen Verzeichnis installieren.
     
  12. Wrandy

    Wrandy Reinette de Champagne

    Dabei seit:
    15.02.09
    Beiträge:
    420
    Ja, habe die alte Version mit dem folgenden Befehl im Terminal deinstalliert:
    Code:
    sudo /Developer/Library/uninstall-devtools --mode=all
    Und wie gesagt, das Projekt von der Website wird ja korrekt compiliert und funktioniet auch so wie es soll. Von daher war ich schon der Meinung, dass ich meinem Programm irgendwas vergessen habe im Object Inspector irgendwas einzustellen...
     
  13. Wrandy

    Wrandy Reinette de Champagne

    Dabei seit:
    15.02.09
    Beiträge:
    420
    Habe meinen Fehler heut gefunden. Ich hatte im Selection Index der Table den falschen Controller Key...

    Vielen Dank für die Hilfe.
     

Diese Seite empfehlen