1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

xampp und Mediawiki

Dieses Thema im Forum "Andere Software" wurde erstellt von KayHH, 22.10.06.

  1. KayHH

    KayHH Gast

    Moin apfeltalker,

    vor ein paar Wochen habe ich mir unvorsichtiger weise mal mein Wiki zerschossen und heute soll das endlich mal repariert werden.

    Ich habe xampp 0.5 und MediaWiki 1.6.5 installiert. Damit lief alles wunderbar. Dann wollte ich MediaWiki auf Version 1.7 updaten und habe dafür einfach das Verzeichnis „/Applications/xampp/htdocs/wiki/“ durch die neue Version ersetzt. Leider lief das nicht. Halb so wild habe ich mir gedacht, ich habe ja vorher extra eine Kopie von diesem Verzeichnis gemacht. Diese also zurück gespielt.

    Leider läuft es aber trotzdem nicht. Mein Wiki-Logo wird im Browser angezeigt ansonsten kommt aber nur noch eine Fehlermeldung welche wie folgt lautet:

    „Wiki has a problem
    Sorry! This site is experiencing technical difficulties.
    Try waiting a few minutes and reloading.
    (Can't contact the database server: Can't connect to local MySQL server through socket '/Applications/xampp/xamppfiles/var/mysql/mysql.sock' (13) (localhost))“


    Ich habe auch noch ein komplettes Systembackup, welches ich mit CCC angefertigt habe, bin mir nun aber nicht sicher was ich zurückspielen muss, damit es wieder läuft. Alles zurückspielen möchte ich nicht, da sich auf dem Mac inzwischen ja noch etliche andere Dinge geändert haben.

    Hat jemand einen Tipp?


    Gruss KayHH
     
  2. Pilzbauer

    Pilzbauer Cripps Pink

    Dabei seit:
    22.10.05
    Beiträge:
    148
    Also ein Backup musst du nicht einspielen, da es sich hier auf XAMPP minimiert und nicht um dein ganzes System geht. Sicherlich könntest du den XAMPP Ordner mal aus deinem Backup holen und mit diesen deinen aktuellen überschreiben. Hat MediaWiki keine Readme oder sowas, wie man es updaten soll? Kann ich mir irgendwie nicht vorstellen.

    Wieso benutzt du XAMPP und nicht das extra fürn Mac entwickelte MAMP ?http://www.mamp.info/de/home/

    Hast du mal nachgeschaut ob MySQL überhaupt läuft? Ich hatte mit MySQL unter XAMPP immer recht große Probleme.

    Du könntest ja mal ein Backup deiner Datenbank machen. XAMPP Deinstallieren, MAMP installieren, deine Datenbank wieder in MySQL importieren und dann nochmal schauen.

    Kann mir aber wie gesagt nicht vorstellen, das MediaWiki keine Readme mitliefert
     
  3. KayHH

    KayHH Gast

    Moin Pilzbauer,

    MAMP stand auch mal zur Diskussion, aber aus irgendeinem Grund habe ich mich damals gegen MAMP entschieden. Ich glaube zu dem Zeitpunkt gab es da irgendwelche Querelen bei den Entwicklern, oder die Zukunft des Systems war ungewiss. Wie auch immer, das hilft nun alles nichts. Ich bin mit xampp ansonsten ja auch zufrieden. Das Problem liegt ja vermutlich auch beim Wiki. xampp starten und Stoppen funktioniert reibungslos.

    Werde aber dennoch mal das gesamte xampp-Verzeichnis austauschen. Evtl. bringt es das ja schon.

    Falls noch jemand eine Tipp hat, worauf die Fehlermeldung hindeutet, dann immer her damit.


    Gruss KayHH
     
  4. Terminal

    Terminal Gast

    Und wo wir schon dabei sind alles richtig zu machen ...

    Warum benutzt ihr überhaupt XAMP oder MAMP oder SAMP oder wie sie noch alle heißen? Nur um mit Apache 2 zu arbeiten?

    In MAC OSX ist Apache 1.3.33 und der bringt wirklich alles mit was man benötigt. Nur MySQL und ImageMagic muss gegebenfalls nachinstalliert werden. Und dafür gibt es ebenfalls getestete und vorgefertigte Packete.

    Wenn Apple es für richtig hält und der Apache 2 soweit einsatzfähig ist, dass er keine Gefahr mehr darstellt, wird er sicher bald in eines der neuen Systeme integriert werden. Aber solange verwendet doch bitte die Komponenten die vom System schon mitgebracht und zur Verfügung gestellt werden.

    Ihr werdet es danken und einmal weniger hier im Forum um Hilfe ersuchen.
     
  5. kauan

    kauan Stina Lohmann

    Dabei seit:
    31.12.05
    Beiträge:
    1.043
    Laut der Fehlermeldung liegt das nicht am Wiki selbst, sondern an deiner Datenbank, die nicht laeuft. Und laeuft die nicht, kann das Wiki nicht darauf verbinden.
    Schreib mal ein Test-PHP-Script und versuch, ob das funktioniert:
    Code:
    testdb.php:
    <?php
    mysql_connect('localhost', 'datenbank-user', 'datenbank-password') or die(mysql_error());
    mysql_select_db('name-der-datenbank') or die(mysql_error());
    echo 'funktioniert bestens';
    ?>
     
  6. KayHH

    KayHH Gast

    Moin kauan,

    das probier ich gleich mal aus.

    Beim Starten von xampp bekomme ich allerdings die Meldung das MySQL gestartet wurde und beim Stoppen von xampp, das MySQL gestoppt wurde, daher bin ich bis jetzt davon ausgegangen das MySQL auch läuft.

    Inzwischen habe ich das gesamte xampp-Verzeichnis zurück gespielt. Wenn ich auf die xampp-Startseite gehe, bekomme ich die folgende Meldung.

    „Warning: file_get_contents(lang.tmp): failed to open stream: Permission denied in /Applications/xampp/htdocs/xampp/index.php on line 2

    Warning: Cannot modify header information - headers already sent by (output started at /Applications/xampp/htdocs/xampp/index.php:2) in /Applications/xampp/htdocs/xampp/index.php on line 4“


    In oben genannter Datei steht folgendes drin:

    Code:
    <?
    	if(file_get_contents("lang.tmp")=="")
    	{
    		header("Location: splash.php");	
    		exit();
    	}
    ?>
    <html>
    <head>
    ...
    
    Die Rechte sehen eigentlich ganz gut, zumal ich das ganze ja auch als Admin probiert habe. „lang.tmp“ ist auch vorhanden und enthält einfach nur „de“, was auch Sinn macht.

    Ich probier jetzt erst mal Deinen Tipp aus.


    Gruss KayHH
     
  7. kauan

    kauan Stina Lohmann

    Dabei seit:
    31.12.05
    Beiträge:
    1.043
    Hallo KayHH

    Dieses 'permission denied' betrifft nicht dich, sondern der User, unter dem Apache laeuft. Und der scheint keine Rechte auf die Index.php zu haben.

    gruss
    Jonathan
     
  8. KayHH

    KayHH Gast

    Moin kauan,

    irgendwie bekomme ich das mit Deinem Test nicht hin. Es kommt immer nur ein „permission denied“.

    Inzwischen habe ich aber in einem Logfile einen Hinweis darauf gefunden, dass MySQL tatsächlich nicht läuft.

    „061022 17:03:00 mysqld started
    061022 17:03:00 [Warning] Setting lower_case_table_names=2 because file system for /Applications/xampp/xamppfiles/var/mysql/ is case insensitive
    061022 17:03:01 InnoDB: Operating system error number 13 in a file operation.
    InnoDB: The error means mysqld does not have the access rights to
    InnoDB: the directory.
    InnoDB: File name ./ibdata1
    InnoDB: File operation call: 'create'.
    InnoDB: Cannot continue operation.
    061022 17:03:01 mysqld ended“


    Warum auch immer, an den Rechten habe ich nichts geändert. Der ganze Krempel gehört meinem Adminuser, der Mitglied der Gruppe admin ist. Gestartet habe ich xampp über sudo, so wie sonst auch.

    Aber bevor ich mich um das Problem mit MySQL kümmere scheint es mir inzwischen angebracht erst mal zu klären, warum ich http://localhost/xampp/ nicht aufrufen kann. Dort gibt es IMHO auch Tools um MySQL zu checken.


    Gruss KayHH
     
  9. kauan

    kauan Stina Lohmann

    Dabei seit:
    31.12.05
    Beiträge:
    1.043
    Ich glaube ein paar deiner Probleme sollten mit folgendem geloest sein:
    sudo chown -R deinuser /Applications/xampp
    sudo find /Applications/xampp -type d -exec chmod 755 {} \;
    sudo find /Applications/xampp -type f -exec chmod 644 {} \;

    Das fixt die Berechtigungen.
    Vielleicht kann dir auch Repair Disk Permissions aus dem Disk Utility helfen...

    gruss
    Jonathan
     
    1 Person gefällt das.
  10. KayHH

    KayHH Gast

    Moin Jonathan,

    wenn ich das mache, wird das Kommando zum Starten von xampp nicht einmal mehr gefunden.


    Gruss KayHH
     
  11. kauan

    kauan Stina Lohmann

    Dabei seit:
    31.12.05
    Beiträge:
    1.043
    Argh mist. Die Dateien im bin/ Verzeichnis (oder wie das da auch immer heisst) muss natuerlich auch 755 Rechte haben..

    gruss
    Jonathan
     
  12. KayHH

    KayHH Gast

    Ich hab' jetzt erst mal die alte Version wieder zurück gespielt. Nächste Woche geht's weiter, ich muss jetzt noch ein paar andere Dinge erledigen. Danke auf jeden Fall schon mal. Gruss KayHH
     
  13. KayHH

    KayHH Gast

Diese Seite empfehlen