1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

XAMPP - MySQL - #1045 - Access denied

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von Marvin_Do, 17.11.07.

  1. Marvin_Do

    Marvin_Do Gala

    Dabei seit:
    07.06.07
    Beiträge:
    52
    Hallo allerseits,

    ich habe ein Problem mit XAMPP was ich nicht lösen kann. Ist jemand da draußen, der mir vielleicht helfen kann?

    Mein Ziel ist, dass phpMyAdmin 2.11.1 läuft. Hier halten ich aber immer die Fehlermeldung

    #1045 - Access denied for user 'root'@'localhost' (using password: NO) :-c

    Ich habe XAMPP schon einmal neu installiert und kein Kennwort angelegt, hat auch nichts geändert. In der Zeilen $cfg[‘Servers‘][$i][‘password‘] = ‘‘; habe ich der config.default.php mein Kennwort verraten, das hat aber auch nicht geholfen.

    In XAMPP steht übrigens MySQL-Datenbank DEAKTIVIERT, stimmt aber (eigentlich) nicht. Hab ich gestartet... immer und immer wieder.
     
  2. lar_zzz

    lar_zzz Bismarckapfel

    Dabei seit:
    11.08.07
    Beiträge:
    77
    Das sind meine phpmyadmin Einstellungen:

    /* Authentication type */
    $cfg['Servers'][$i]['auth_type'] = 'http';
    /* Server parameters */
    $cfg['Servers'][$i]['host'] = 'localhost';
    $cfg['Servers'][$i]['connect_type'] = 'tcp';
    $cfg['Servers'][$i]['compress'] = false;
    /* Select mysqli if your server has it */
    $cfg['Servers'][$i]['extension'] = 'mysql';

    Da werde ich dann nach meinem username + passwort gefragt. Vielleicht hilft es. Ich weis auch nicht ob es die optimale Einstellung ist. Wäre schön zu wissen welche es ist, bzw. was die beste ist.
    Ich habe übrigens die MySQL Variante direkt von MySQL und nutze den Apache der mit 10.4 mitkommt, also kein xampp oder ähnliches.
     
  3. Marvin_Do

    Marvin_Do Gala

    Dabei seit:
    07.06.07
    Beiträge:
    52
    Danke für die Rückmeldung! Ich denke mal die entscheidende Zeile ist
    $cfg['Servers'][$i]['auth_type'] = 'http';. Ich habe alles so eingestellt, leider hat sich nichts geändert. Ich werde auch nicht nach einem Kennwort gefragt :(
     
  4. Marvin_Do

    Marvin_Do Gala

    Dabei seit:
    07.06.07
    Beiträge:
    52
    Ich habe XAMPP jetzt erneut installiert und dabei kein Kennwort für MySQL vergeben. Jetzt funktioniert MySQL zwar, PHPMYADMIN geht aber leider immer noch nicht. Ich erhalte nun diese Fehlermeldung:


    Warning: session_write_close() [function.session-write-close]: open(/var/folders/Ae/Aetm5MrbF74L9gFEp1fsUk+++TM/-Tmp-//sess_ITVat-Bgor37awdPkGGgCs-Th50, O_RDWR) failed: Permission denied (13) in /Applications/xampp/xamppfiles/phpmyadmin/index.php on line 42

    Warning: session_write_close() [function.session-write-close]: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in /Applications/xampp/xamppfiles/phpmyadmin/index.php on line 42

    Warning: Cannot modify header information - headers already sent by (output started at /Applications/xampp/xamppfiles/phpmyadmin/index.php:42) in /Applications/xampp/xamppfiles/phpmyadmin/index.php on line 99

    Dem Verzeichnis /Applications/xampp/xamppfiles/phpmyadmin und allen Unterzerzeichissen habe ich die Zugriffsrechte 777 gegeben.
     

Diese Seite empfehlen