1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

X-Forwarding

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von SkyWombat, 19.05.06.

  1. SkyWombat

    SkyWombat Uelzener Rambour

    Dabei seit:
    18.10.05
    Beiträge:
    370
    Hallo Zusammen,

    leider habe ich eine Antwort auf folgende Frage noch nicht hier im Forum gefunden, aber vll könnt Ihr mir ja helfen.

    Wenn ich Apples X11 rootless laufen lasse und mich mit 'ssh -X user@domain.de' einlogge funktioniert das X-forwarding nur wenn ich mich ueber ein xterm (X11) einlogge. Genau derselbe Befehl in einem Terminal, oder auch iTerm bringt mir auf dem Remote Rechner nur ein 'can't open display'.
    Gibt es eine Möglichkeit das auch fuer Terminal und/oder iTerm hinzubekommen, oder geht das wirklich nur aus einem xterm?

    Vielen Dank für Eure Hilfe

    SkyWombat
     
  2. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Du musst im Terminal auf dem Mac vor dem ssh-Befehl die DISPLAY-Variable korrekt setzen:
    Code:
    export DISPLAY=:0
    Und ich würde bei ssh eventuell die -Y Option nehmen, mit -X kann es schon mal Probleme geben.
     
  3. TaTonka

    TaTonka Neuer Berner Rosenapfel

    Dabei seit:
    19.03.06
    Beiträge:
    1.961
    damit das aber funzt, muss auf jeden fall der x11 im hintergrund laufen...(eigtl logisch)
    tipp: wenn du die display variable in deiner bashrc einträgst, wird sie bei jedem start der bash neu eingelesen, sodass du sie net manuell nachtragen musst
     
  4. SkyWombat

    SkyWombat Uelzener Rambour

    Dabei seit:
    18.10.05
    Beiträge:
    370
    Danke für Eure Tipps. Das export DISPLAY hat geholfen. Nur komisch, dass das nicht standardmäsig eingeschaltet ist, aber egal.
     

Diese Seite empfehlen