1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

WordPress 2.6.1 mod_rewrite Regeln

Dieses Thema im Forum "CMS" wurde erstellt von 0ms0, 01.09.08.

  1. 0ms0

    0ms0 Auralia

    Dabei seit:
    02.08.08
    Beiträge:
    198
    Hallo Leute.

    Ich habe ein Problem. Und zwar ist es so, dass ich bei meinem Blog Bilder und Ähnliches hochladen will. Verständlich, und auch andere Funktionen funktionieren nicht richtig, weil ich WP nicht erlauben kann, von selbst auf den Server zuizugreifen.
    Dafür gibt es ja normalerweise auch die .htaccess Dateien. Diese muss ja von Hand als 1.htaccess erstellt und dann auf den Server gebracht werden. Dann Umbenennen und so weiter. Alles nicht das Problem.
    Das Problem liegt bei meinem Hoster, denn die .htaccess Dateien funktionieren nicht, aufgrund von nicht geschalteten mod_rewrite Regeln.
    Herausgefunden, dass die .htaccess Dateien nicht funktionieren, habe ich durch folgenden Code in der .htaccess Datei:
    Code:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule ^.*$ http://www.google.de [L]
    </IfModule>
    Dieser Code bewirkt, dass jeglicher Aufruf auf google.com umgeleitet wird. ABER: Fehlanzeige. Das hat nicht funktioniert. Somit gibt es also Probleme mit mod_rewrite.
    Es gibt auch schon Threads zu diesem Thema, aber solche sind meist von 05/06. Deshalb will ich das nochmal auffrischen.
    Ich wendete mich also frohen Mutes an meinen Support und bekam heute morgen diese Antwort:
    Ganz ehrlich, ich habe keine Ahnung!
    Was soll ich dem Support jetzt antworten? Ich persönlich kenne mich mit mod_rewrite nicht aus.
     
    #1 0ms0, 01.09.08
    Zuletzt bearbeitet: 01.09.08
  2. kauan

    kauan Stina Lohmann

    Dabei seit:
    31.12.05
    Beiträge:
    1.043
    Du sollst ihm den Inhatl mitteilen, den du in deiner htaccess haben willst. Dein Hoster will dies nicht erlauben, bietet dir aber an, manuell Einträge zur Konfiguration vorzunehmen. Wo liegt nun dein Problem?

    Ach ja, fixe mal bitte deine "color"-Tags.
     
  3. 0ms0

    0ms0 Auralia

    Dabei seit:
    02.08.08
    Beiträge:
    198
    Ja soweit so gut.
    Aber die Frage ist ja nun für mich, was alles in eine .htaccess Datei für WP reingehört, dass alles funktioniert.
    Und ja, ich habe schon bei Google recherchiert. Aber ich weiß nicht was ALLES reingehört, von einigen Teilen hab ich schon was gelesen, aber eine komplette .htaccess als Code, dass ich weiß was reinmuss, wäre sehr praktisch. Vielleicht kann die jemand posten.

    0ms0
     
  4. AgentSmith

    AgentSmith Hochzeitsapfel

    Dabei seit:
    15.07.07
    Beiträge:
    9.361
    WordPress spuckt dir unter "Einstellungen/Permalinks" den Inhalt der .htaccess aus, wenn er sie nicht selbst anlegen/schreiben kann. Mach dort deine Einstellungen, kopiere dann die Ausgabe und schicke sie dem Supporter zurück.

    Ein WordPress-Blog braucht gar keine .htaccess, um zu funktionieren. Daher kann dir auch niemand sagen, was genau in die Datei gehört, das hängt von der gewünschten Permalink-Struktur ab.

    Das Problem mit dem Upload von Bildern hat übrigens mit der .htaccess nichts zu tun, aber die Ursache für beide Probleme ist dieselbe: Du hast unzureichende Zugriffsrechte vergeben, Stichwort chmod. Frag den Supporter, ob du die Berechtigung beseitzt, chmod anzuwenden. Welchen FTP-Client verwendest du?
     
  5. 0ms0

    0ms0 Auralia

    Dabei seit:
    02.08.08
    Beiträge:
    198
    Danke für diese Hilfe.
    Okay, dann habe ich da etwas falsch verstanden, beziehungsweise verwechselt wegen den Rechten.
    Ich dachte, dass das wegen den Bildern aufgrund fehlerhafter Rechte von WP auf dem Server ist, und diese durch die .htaccess Datei diese Rechte so hochgeschraubt werden, dass WP diese selbst ändern kann.

    Mein FTP-Client ist FileZilla 3.1.2 (Intel).

    Die Mail mit dem .htaccess Datei-Inhalt habe ich jetzt an den Support geschickt. Also sollte die Permalink-Struktur dann funktionieren.

    Sorry, dass ich dachte, dass eine fertige .htaccess Datei mir helfen würde.

    Was genau muss ich da tun, dass der Bilder-Upload funktioniert? Denn die Rechte der Ordner habe ich schon geändert. Daran dürfte es nicht liegen.

    Könnte es sein, dass der Bilder-Upload dann funktioniert, wenn die mod_rewrite Sachen aktiviert sind?

    chmod sagt mir leider gar nichts. Ist das zum Ändern der Rechte? Datei ist es ja nicht, oder?

    Danke nochmal.
    0ms0
     
  6. AgentSmith

    AgentSmith Hochzeitsapfel

    Dabei seit:
    15.07.07
    Beiträge:
    9.361
    Nein.

    Wenn du die Rechte schon gesetzt hast, dann sollte der Upload auch funktionieren. "chmod" ist das Programm, mit dem man die Rechte setzen kann.

    Es ist auch möglich, dass deine PHP-Konfiguration generell keine Uploads zulässt - bei einer gesperrten .htaccess würde mich das nicht wundern. Frag auch diesbezüglich mal den Support. Welcher Hoster mit welchem Paket ist denn das?
     
  7. 0ms0

    0ms0 Auralia

    Dabei seit:
    02.08.08
    Beiträge:
    198
    Mhm. Ist natürlich ungünstig mit den Bildern. Denn ein Blog ohne Bilder ist ja eher... Unoptimal.

    Hoster: bouncer4you.de

    Paket: bouncer4you.de/v5/?c=produkt&p=29

    Ich hätte vorher auf mod_rewrite etc achten sollen... Naja, Hinterher ist man immer schlauer ;)

    0ms0
     
  8. AgentSmith

    AgentSmith Hochzeitsapfel

    Dabei seit:
    15.07.07
    Beiträge:
    9.361
    Hm, liest sich eigentlich ganz ordentlich. Und die Reaktion vom Support auf deine erste Anfrage ist vorbildlich - wie gesagt, frag die einfach auch wegen dem Upload, dann sind wir schlauer.
     

Diese Seite empfehlen