1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Wichtige Daten verstellt, bitte um Hilfe!

Dieses Thema im Forum "macOS & OS X" wurde erstellt von rocoroc, 12.02.07.

  1. rocoroc

    rocoroc Gast

    Also ich habe ein schwerwiegendes Problem, das wohl nicht ganz einfach darzulegen ist...

    Ich fange mal damit an:

    Habe seit ein paar Monaten meine ersten MAC! Bin ich sehr zufrieden damit. Dann bin ich auf dieses Superforum gestoßen wo ich mir gleich mal den Thread "Etdeckerreise durch OS X" durchgelesen habe. Auf Seite 14 dieses Threads habe ich dann die (äußerst dumme) Anweisung befolgt wie meine seinen Benutzernamen in der sogenannten NetInfo ändert. Dies habe ich dann auch gemacht, jedoch wurde eine Seite später (leider zuu spät) dargelegt, dass dies adminprobleme mit sich ziehen kann. Und genau das ist jetzt passiert, ich habe den Namen geändert in NetInfo und kann jetz keine Programme mehr installieren da ich dafür ja mein Passwort brauche. Seither habe ich auch meine Mac nicht mehr heruntergefahren, da ich sonst wohl bei der Anmeldung noch mehr Probleme hätte.

    Daher frage ich ganz verlegen, ob mir jemand aus dieser meiner ersten MacKriese helfen kann....

    Habe nen iMac, OS X - Version 10.4.8

    Der direkte Link zu dem (dämlichen) Beitrag ist HIER --ganz unten stehts--

    Hoffe man kann mir helfen, vielen Dank schon mal im Vorraus!

    bye roco
     
  2. mullzk

    mullzk Linsenhofener Sämling

    Dabei seit:
    04.01.04
    Beiträge:
    2.529
    hi roco

    erst mal mein herzliches beileid, sich den admin wegzuschiessen ist immer eine hässliche sache.
    vor dem hinweis auf die haarige methode erst noch ein anderer: allenfalls kannst du dich mit einem booten von der installations-cd-rom retten, da gibts einen menüpunkt 'passwörter zurücksetzen' oder so - vielleicht hat apple es endlich hingebracht, dabei auch die user wieder der admin-gruppe hinzuzufügen. vielleicht bringt dieser exkurs aber auch nichts...

    die andere variante ist etwas hässlicher und erfordert ein booten in den single-user-modus; wo du a) deine langjährigen unix-kenntnisse zu schätzen weisst oder aber b) höllisch aufpassen musst, weil du dir im single-user-modus alles, aber auch wirklich alles zerstören kannst...

    um in den single-user-mode zu kommen, musst du beim booten die s-taste gedrückt halten. dann musst du eingeben (achtung, z & y sind vertauscht):
    /sbin/fsck -fy
    /sbin/mount -uw /

    nun ins netinfo command line interface wechseln:
    nicl -raw /var/db/netinfo/local.nidb
    der prompt sollte sich ändern auf / >
    Zu den Gruppen wechseln:
    cd localhost
    cd groups
    append admin users [user]
    append appserveradm users [user]
    append appserverusr users [user]

    ([user] musst du natürlich mit deinem neuen kurz-usernamen ersetzen - die klammern natürlich auch weglassen)
    und dann raus und neu booten. beten auch nicht vergessen:
    exit
    reboot

    falls du dich mit unix ein wenig auskennst, können dir allenfalls auch die anderen ni-befehle helfen - ein kurzes 'apropos netinfo' im terminal listet die relevanten tools auf.

    wenn du dich nicht mit unix auskennst, noch einmal: single-user-modus kann mit vom tödlichsten sein. falls du absolut entscheidende daten auf deiner platte hast und kein backup hast, lass es bleiben und lass dir den mac von apple flicken. normalerweise geht obiger weg, aber deine maschine kann irgendwie seine eigenheiten haben, die ich von hier aus nicht sehen kann. deshalb auch: versuch es erst einmal mit booten von der install-dvd, vielleicht gehts ja...
     
  3. rocoroc

    rocoroc Gast

    erst mal danke für die schnelle antwort, würde am liebsten erst mal das booten von cdrom probieren. Problem ist aber: Wie geht das??
    Bin ja Ex-Windows nutzer, da ging das so einfach, bei mac hab ich keine ahnung. Hab schon durch andre Foren herausbekommen, dass dies mit gedrückter "c" oder "alt" beim starten gehn sollte, geht aber nich....
     
  4. _seppel_

    _seppel_ Goldparmäne

    Dabei seit:
    04.08.06
    Beiträge:
    557
    Also, du legst die CD ein und startest neu.
    Dann solltest du bem Starten sofort C gedrückt halten, alt ist auch möglich, dort wird die dann die CD und deine HDD angezeigt.
    Das mit C klappt in der Regel problemlos!
     
  5. rocoroc

    rocoroc Gast

    also ich hab jetz mein system komplett neu installiert und die dateien beibehalten. muss zwar alles neu einstellen, aber is halb so wild. trotzdem vielen dank für die antworten! cu
     
  6. rocoroc

    rocoroc Gast

    habe ja das system neu installiert, und meine vorherigen Daten sind jetz in dem Ordner --Previous Systems-- !

    kann ich den ordner einfach löschen wenn ich alle meine daten neu geordnet und in andere Ordner verlegt habe?

    mfg roc
     
  7. mullzk

    mullzk Linsenhofener Sämling

    Dabei seit:
    04.01.04
    Beiträge:
    2.529
    wenn du ganz sicher bist, dass alles so ist wie es sein soll, kannst du ihn problemlos löschen...
     
  8. rocoroc

    rocoroc Gast

    ok, hat prima geklappt, bin soweit durch. Danke für die Tipps!

    ciao
     

Diese Seite empfehlen