1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Information ausblenden

Werte in anderer Tabelle suchen mit Rückgabewert

Dieses Thema im Forum "Office:Mac" wurde erstellt von Periculum95, 10.06.16.

  1. Periculum95

    Periculum95 Erdapfel

    Dabei seit:
    10.06.16
    Beiträge:
    2
    Hallo apfeltalk Community,
    ich habe ein schier unlösbares Excel Problem.
    Es existieren zwei Register.
    Auf dem ersten Blatt sind in der ersten Spalte verschiedene Vereine und in den darauf folgenden alle Mitglieder dieser Vereine aufgelistet.
    Auf dem zweiten Blatt sind wieder in der ersten Spalte alle Vereine und in den weiteren Spalten allerdings diesmal jeweils ein Mitgliedsname. Jetzt soll geschaut werden ob der name (z.B. Horst) in dem Blatt 1 im ersten Verein (Zeile 2) auftaucht.
    Wenn ja soll ein X gesetzt werden und wenn nicht soll das Feld frei bleiben.
    Ich habe mich schon durch sämtliche Verweise und Vergleiche geschlagen, bin aber leider zu keinem Ergebniss gekommen.
    Danke im vorraus für eure Hilfe!
    Blatt 1
    1. Blatt.png

    Blatt 2
    2. Blatt.png
     
  2. double_d

    double_d Moderator Apple-Services + Software
    AT Moderation

    Dabei seit:
    08.03.12
    Beiträge:
    3.819
    Die Anordnung ist etwas unglücklich, aber ich schätze, Du magst das auch nicht ändern, oder? ;)

    Hier mal die Formel, welche Dich bei diesem Projekt weiterbringt, unter der Prämisse, dass in Tabelle 1 die Vereine in Spalte A stehen und die Mitglieder ab der Spalte B anfangen. Eben so, wie es auf Deinen Bildern zu vermuten ist.

    In Tabelle 2 in die Zelle B2, also Bei "Horst" in der Zeile "Verein1" trägst Du diese Formel ein.
    Code:
    =WENN(ZÄHLENWENN(Tabelle1!2:2;B$1)>0;"X";"")
    Tabelle1 muss natürlich genauso heißen in der Formel, wie Deine Tabelle1 heißt.

    Anschließend kopierst Du die Formel mit dem Anfasser an der Zelle nach unten bis zur letzten Vereinszeile. Danach kopierst Du sie wieder mit dem Anfasser nach rechts, bis über den letzten Namen.

    Die Formel macht folgendes. Sie zählt für jeden Namen in Tabelle 2 die Anzahl pro Zeile, also pro Verein. Ist diese Anzahl größer Null, dann wirft sie als Ergebnis ein X aus. Ist sie nicht größer Null, dann bleibt die Ergebniszelle leer.

    Viel Spaß :)

    P.S.: Das Ergebnis der Formel sieht dann so aus. Hoffe, Du hast es Dir auch so vorgestellt.

    upload_2016-6-10_10-13-6.png
     
    #2 double_d, 10.06.16
    Zuletzt bearbeitet: 10.06.16
    u0679 gefällt das.
  3. Periculum95

    Periculum95 Erdapfel

    Dabei seit:
    10.06.16
    Beiträge:
    2
    Super vielen Dank!
    Hat alles auf anhieb funktioniert.
    Da die echte Tabelle 500 Zeilen und Spalten beinhaltet wird mir das sehr viel Arbeit ersparen. :)
     

Diese Seite empfehlen