• Es gibt nach dem Softwareupdate eine Reihe von Änderungen und Neuerungen in unserem Forum. Genaueres dazu findet Ihr in dieser Ankündigung. Hinweise, Kritik, Anregungen, Lob und Tadel bitte hier diskutieren.
Apfeltalk Weihnachtsbanner

Website per ftp hochgeladen - Bilder fehlen

Virtualix

Jonagold
Mitglied seit
14.06.08
Beiträge
19
Hallo zusammen,

wahrscheinlich eine Anfängerfrage (der ich auch bin) und vielleicht eher ein html Problem, aber ich wusste nicht wo ich sonst fragen sollte:

Also, ich habe eben mal meine komplette Website per ftp-Programm auf den Strato-Server geladen.
Die von mir eingefügten Bilder werden plötzlich nicht angezeigt. Betrachte ich die Seiten aber einfach aus dem Ordner auf meiner Festplatte heraus, ist alles ok. Der gesamte Ordner enthält ja einerseits die html-Dateien und andererseits die gleichnamigen Ordner (pro Seite) mit den Files zu den Seiten. Hat jemand ne Idee woran das liegen könnte?

Danke!
 

Dr.Apfelkern

Jerseymac
Mitglied seit
18.04.07
Beiträge
454
Du kannst im HTML-Dokument die Verweise (Links) zu deinen Bildern nicht so benennen wie sie bei dir auf der Festplatte sind. Du mußt entweder deine Verweise mit der gesamten Internetadresse versehen (http://deinewebseite.de/bilder/foto.jpg), das Root-Verzeichnis nennen (/bilder/foto.jpg) oder einen relativen Pfad angeben (bilder/foto.jpg) der direkt unter dem Root-Verzeichnis (dem obersten Verzeichnis deiner Webseite) liegt.

Der Server wo du deine Seiten uploadest, erkennt ja nicht deine auf deinem Rechner interne Ordnerstruktur und kann damit gar keine Verbindung mit den Bildern herstellen. Was soll er mit den Angaben z.B. (/Users/deinName/Webseites/meineSeite/bilder/foto.jpg) anfangen?
 

Nathea

Admin
AT Administration
Mitglied seit
29.08.04
Beiträge
14.033
Wichtig ist auch, dass Du sehr genau auf die Schreibweise der Bilddatei-Namen achtest. Die Namen der Dateien und die Namen für die Bilder in der HTML-Seite müssen exakt übereinstimmen, also bitte auch die Groß- und Kleinschreibung beachten!
 

Samsas Traum

Pommerscher Krummstiel
Mitglied seit
24.04.08
Beiträge
3.025
nochmal verständlicher für anfänger:

1. Möglichkeit: Bilder im gleichen Ordner wie html Datein:

link = bildname

2. Möglichkeit: Bilder im root-ordner (1. ordner überhaupt):

link = ../bildname

3. Möglichkeit: Datei im Unterordner

link = ./bildname

4. Möglichkeit: Datei ganz wo anders

link = ../1. Ordner/2.Ordner/3.Ordner/usw./bildname
 

Virtualix

Jonagold
Mitglied seit
14.06.08
Beiträge
19
Wichtig ist auch, dass Du sehr genau auf die Schreibweise der Bilddatei-Namen achtest. Die Namen der Dateien und die Namen für die Bilder in der HTML-Seite müssen exakt übereinstimmen, also bitte auch die Groß- und Kleinschreibung beachten!
Genau, das war der Fehler - so simpel :eek:

Danke!!
 

Peter Maurer

Pommerscher Krummstiel
Mitglied seit
16.03.04
Beiträge
3.077
Das eigentliche Problem ist ja schon geloest, aber fuer's Archiv, bevor jemand darauf reinfaellt...

2. Möglichkeit: Bilder im root-ordner (1. ordner überhaupt):

link = ../bildname
Nein. "../bildname" bedeutet "im uebergeordneten Verzeichnis", oder volkstuemlicher ausgedrueckt: "eins weiter oben". Was Du meinst, ist "/bildname" (vgl. auch Deine "4. Moeglichkeit").

3. Möglichkeit: Datei im Unterordner

link = ./bildname
Nein. Der einzelne Punkt bedeutet "im aktuellen Arbeitsverzeichnis". In HTML-Dokumenten ist "./bildname" meist gleichbedeutend mit "bildname", weil als aktuelles Arbeitsverzeichnis das Verzeichnis, in dem das HTML-Dokument liegt, angenommen wird.

Mehr ueber alles...