1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

WebDav einbindung nach Neustart behalten

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Stefan, 23.07.08.

  1. Stefan

    Stefan Golden Delicious

    Dabei seit:
    23.07.08
    Beiträge:
    11
    Hallo,
    ich habe für Datenaustausch ein WebDav-Server. Funktioniert auch soweit gut. Leider muss den bei jedem Start neu mounten. Ich hätte es am liebsten so, dass er den Ordner direkt als Laufwerk anzeigt. Ich habe schon herausgefunden, das er den Ordner einfach nach /Volumes/irgendwas mountet, genau wie USB-Sticks oder so. Wenn versuche ihn über das Terminal zu mounten (mount -t webdav https://... /Volumes/irgendwas) macht er das, die Dateien zeigt er aber nicht an. Gibt es da irgendeine Lösung? Kann man das irgendwie in die fstab eintragen?
    Ich hab Mac OS X 10.5.4.

    Viele Grüße,
    Stefan
     
  2. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Startobjekt unter Systemeinstellung Benutzer würde ich sagen*…
     
  3. Stefan

    Stefan Golden Delicious

    Dabei seit:
    23.07.08
    Beiträge:
    11
    Das klappt, er verbindet dann. Es kommt bloß auch automatisch ein Fenster mit dem Inhalt auch wenn ich das Häkchen bei "Ausblenden" mache.

    Auch bleibt es unter Freigaben, wenn ich da dann mit rechts draufklicke und Original zeigen mache, dann sehe ich einen Ordner mit den Laufwerken und einem Eintrag Netzwerk. Meine WebDAV Verbindung ist da auch als Laufwerk drin (das Symbol ist ähnlich dem eines USB-Sticks). Das gibt es sonst nirgends, das muss man doch hinkriegen, dass es auch unter Geräte aufgelistet wird?

    Viele Grüße,
    Stefan
     
  4. Stefan

    Stefan Golden Delicious

    Dabei seit:
    23.07.08
    Beiträge:
    11
    Man kriegt den webdav-ornder da als Laufwerk hin, man muss es nur dahin ziehen (meinchmal ist es einfacher als man denkt). Aber es bleibt da leider nicht, nach einem Neustart ist das Laufwerk weg, auch wenn man es als Startobjekt definiert.

    Ich habe es hinbekommen mit mount_webdav das Laufwerk zu mounten, ein Eintrag in der (neu erstellten) fstab brachte bis jetzt aber keinen Erfolg.
    Der sieht bei bei mir wie folgt aus:
    Code:
    https://www.server.tld/irgendwas  /Volumes/irgendwas  webdav  noexec,nosuid,nodev
    Wie muss der Eintrag aussehen damit es klappt? Auch löscht OS X meint mount-point automatisch wieder.

    Viele Grüße,
    Stefan
     
  5. hegel394

    hegel394 Ingrid Marie

    Dabei seit:
    14.07.08
    Beiträge:
    268
    wie wäre es einfach mit einem automator script, das beim start automatisch gestartet wird?
    mache ich zumindest so und es klappt einwandfrei
     
  6. Stefan

    Stefan Golden Delicious

    Dabei seit:
    23.07.08
    Beiträge:
    11
    Gute Idee, kannst du dein Skript hier posten?

    Vielen Dank,
    Stefan
     
  7. jota

    jota Bismarckapfel

    Dabei seit:
    28.03.06
    Beiträge:
    77
    Das würde mich auch interessieren. Kannst du dein Script hier posten?
    Oder Stefan: Hast du in der Zwischenzeit ein Script erstellt?

    Ich muss momentan auch mit der Lösung leben das ich es unter Systemeinstellungen als Startobjekt gesetzt habe. Aber das empfinde ich wie Stefan als nicht optimal.
    Wenn mir jemand helfen könnte wäre das Top!
     

Diese Seite empfehlen