1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Webcam im Netz bereitstellen

Dieses Thema im Forum "macOS & OS X" wurde erstellt von michast, 26.02.06.

  1. michast

    michast Adersleber Calvill

    Dabei seit:
    13.09.04
    Beiträge:
    5.810
    Ich versuche meine Webcam ins Netz zu bekommen. Als Quicktime-Streaming bekomme ich die Kamera auf meinem Rechner abgespielt. nathea, die im gleichen Netz hängt, bekommt ihn nicht angezeigt. Ich dachte, es läge am Port 8080 und wollte den Webserver starten. Das Feld in der Systemsteuerung wird grau, Webserver wird gestartet, sagt er, aber nichts weiter passiert.

    Hab den Apache getestet:

    Last login: Sun Feb 26 11:45:43 on ttyp1
    Welcome to Darwin!
    localhost:~ micha$ sudo apachectl configtest
    Processing config directory: /private/etc/httpd/users/*.conf
    Processing config file: /private/etc/httpd/users/micha.conf
    [Sun Feb 26 11:50:14 2006] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    Syntax OK
    localhost:~ micha$

    Sieht für mich nicht wie ein Fehler aus. Internet gibt auch nichts her, bzw. ich finde nur Bezug auf OS 10.1.

    Habe mehrere Möglichkeiten probiert. Erstens den integrierten Web-Server von Evocam auf Port 8080, hielt ich für das Einfachste. Ging nicht. Dann den Apple Quicktime Broadcaster auf Unicast manuell gestellt. Dort läuft Audio auf Port 5432 und Video auf 5434. Auch mit dem Darwin Streaming Server habe ich herumexperimentiert, aber irgendwie verstehe ich ihn nicht. Er läuft auf IP 127.0.0.1, eigentlich genau da, wo auch der Personal Web Server aus der Systemsteuerung laufen würde, wenn er denn starten würde. Ich denke, die beiden beissen sich.

    Hat jemand eine Idee? Simon, Du weltbester Video-Publisher vielleicht?

    Gruß,
    Michael
     
  2. MACRASSI

    MACRASSI Gelbe Schleswiger Reinette

    Dabei seit:
    21.11.04
    Beiträge:
    1.754
    Wenns kein Stream sein soll sondern nur ne Webcam kann ich das Tool Evocam empfehlen.

    Gruß Rasmus
     
  3. michast

    michast Adersleber Calvill

    Dabei seit:
    13.09.04
    Beiträge:
    5.810
    Hi Rasmus,

    hast Du bestimmt übersehen. Evocam hab ich, wie ich schrieb. Hat auch einen eingebauten Webserver auf 8080, der auch nicht funktioniert. Wie gesagt, der Personal Web Server in der Systemsteuerung lässt sich auch nicht aktivieren und auch streaming funktioniert nur lokal, nicht im Netz.

    Gruß,
    Michael
     
  4. yjnthaar

    yjnthaar Schwabenkönig

    Dabei seit:
    07.06.04
    Beiträge:
    2.657
    Moinsen,

    Also, da muss Mensch ja mal gross ausholen um dad mal so etwas in den Griff zu bekommen. :-D

    Wie sieht Dein Netz aus? Hast Du einen Router ins Internet? Oder hängst Du direkt "drin"?

    Generell ist 127.0.0.1 immer Localhost. Egal welcher "Service" läuft.

    127.0.0.1:80 z.B. ist der Webserver (auf "localhost" port 80)
    127.0.0.1:8080 z.B. ist der Webcamservice (?) (auch auf "localhost" aber auf port 8080)

    So können durch die verschiedenen Ports zig Server nebeneinander auf "localhost" laufen.

    Um jetzt z.B. den 8080 abzurufen, musst Du in den Browser/sonstigen Client (QT ?) z.B. rtsp://michastcomputer:8080 eingeben. Oder eben http://michastcomputer (entspricht http://michastcomputer:80)

    Letzeres kuckt "automatisch" ob ein Webserver auf Port 80 läuft und Antwortet entsprechend. Ersteres ist ein Abruf mit "real time streaming protokoll" auf Port 8080.

    Soweit die Verwirrung komplett? :eek:

    Um zu streamen, brauchst Du einen Streaming Server und keinen Webserver. Webserver können nur http-anfragen bearbeiten (evocam kenn ich nicht). i.d.R. schickt der Broadcaster den Stream an einen Quick Time-/Darwin- Streaming Server. Dieser hält dann den Service auf z.B. Port 8080 bereit.

    Salute,
    Simon
     
  5. michast

    michast Adersleber Calvill

    Dabei seit:
    13.09.04
    Beiträge:
    5.810
    Danke erst einmal für die Verwirrung, aber Du wirst lachen, so verwirrt bin ich gar nicht ;).

    Also: Ich nutze den Quicktime Broadcaster und auch den Darwin Streaming Server. Dennoch bekomme ich das Teil nicht einmal im eigenen Netz gestreamt, heisst, auf meinem Rechner kann ich mit Quicktime die IP aufrufen und es folgt die Sendung. Meine Gattin neben mir bekommt die Meldung "Verbindung wird hergestellt" weiter nichts. Ich hänge hinter einem Router und NAT ist aktiviert, aber das ist ja im Moment irrelevant, soweit ich weiß, weil ich es erst einmal intern hinbekommen will. Für das spätere "nach draussen" habe ich bereits ein Konto bei DynDNS, aber ich wollte mich erst richtig verwirren lassen, bevor ich das Chaos starte ;).

    Der Webserver von EvoCam stellt einen Stream über eine "http" Verbindung auf Port 8080 bereit, aber auch das klappt nicht. Die Ports für den Streaming-Server heissen anders, die sind auch freigegeben. Port 8080 ist nicht frei (Firewall).

    Gruß,
    Michael
     
  6. yjnthaar

    yjnthaar Schwabenkönig

    Dabei seit:
    07.06.04
    Beiträge:
    2.657
    Moin,

    Mach mal die "internen" Firewalls aus. ;)

    Salute,
    Simon
     
  7. michast

    michast Adersleber Calvill

    Dabei seit:
    13.09.04
    Beiträge:
    5.810
    Ich setze mich heute abend noch einmal dran :)

    Danke erst einmal. Melde mich dann wieder. Ach je, der Streß macht mich fertig ;)

    Gruß,
    Michael
     
  8. Hallo WebcamFreacks, alle zusammen

    Mit dem gleichen Problem schlage ich mich auch schon geraume Zeit rum. Jetzt habe ich einen "Fachmann" (?) um Rat gefragt und hier seine Antwort(en):

    «Damit sich die Cam und der Mac finden, muss die Kamera die gleiche IP haben, d.h. ist die 3. Stelle eine .1. und die vierte Stelle beginnt mit einer .1-- so muss die Cam die gleiche Konfiguration haben, falls diese Stellen aber jeweils mit einer 2 belegt sind bei der Cam oder umgekehrt, so können beide sich nie finden.»

    Das glaub ich dann mal ganz einfach so, denn da ich nicht an die Cam ran komme um sie um zu konfigurieren, hat derjenige mir angeboten, das für mich zu machen, also so dass sie mit meinem Mac auf "gleicher Wellenlänge" liegt, so dass dann alles paletti wäre. Dieses werde ich dann morgen machen lassen und bis dahin bin gespannt wie 'ne alte Lederhose ob der Kerl recht hatt oder nicht!

    Sobald ich dann das Resultat meiner Bemühungen vor Augen habe, melde ich mich wieder, das wird dann wohl erst gegen morgen abend sein.

    Hoffentlich kann ich sagen: :oops: hoo, es geht ja! :-D
     
    saarmac gefällt das.
  9. AmishBit

    AmishBit Gast

    Was war denn das für ein "Fachmann"?
    Wenn zwei Rechner die gleiche IP haben, finden sie sich nie und nimmer.
     
  10. michast

    michast Adersleber Calvill

    Dabei seit:
    13.09.04
    Beiträge:
    5.810
    Ich glaub, er hat sich nur unglücklich ausgedrückt. Lass ihn mal probieren ;)

    Gruß,
    Michael
     
  11. Unglücklich ausgedrückt oder unglücklich gelesen?

    Das Ausprobieren auf jedenfall musste ich verschieben und das war absolut nicht unglücklich gewählt, da ich auf meiner "zeitlich so geplanten" Heimreise unweigerlich im Schneechaos zwischen hunderten von überaschten Heimfahrer mittendrin gewesen wäre! War doch 'ne gute Entscheidung, denn aus einer halben Stunde wären locker 3 Stunden geworden.

    Was meine Erklärung angeht, so denke ich doch dass die, allgemein gesehen, verständlich war. Ich habe ja nicht von "derselben" IP sondern von einer gleichen IP geschrieben. Wer gut hingeschaut hat wohl nicht übersehen dass ich die 4. Stelle so ".1--" geschrieben habe, also bleiben noch Möglichkeiten genug um eine IP bis auf 2 Stellen an eine andere an zu gleichen ohne dass beide genau dieselben sind!

    Ausserdem bin ich je nach dem auch mal ein bisschen schreibfaul!! :innocent:

    Ich melde mich auf jeden Fall noch, ob's mit der IP geht oder nicht. :)
     

Diese Seite empfehlen