1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

WD My Book Studio II zu langsam, trotz FW800... Why?

Dieses Thema im Forum "Festplatten, SSD und andere Speichermedien" wurde erstellt von Rhinhold, 20.06.09.

  1. Rhinhold

    Rhinhold Jerseymac

    Dabei seit:
    01.03.05
    Beiträge:
    452
    Hallo allerseits,

    korrigiert mich, wenn es schon einen Thread dazu geben sollte. Ich habe keinen gefunden. ;)

    Folgendes Problem:

    Ich habe eine WD My Book Studio II (1 TB) Platte an meinem MBP am Firewire 800-Slot hängen. Daneben gäbe es noch die Möglichkeit, FW 400 und USB 2.0 zu benutzen. Wie einige wissen, besitzt dieses Modell von WD die Möglichkeit eines Raid 1-Modus mit den zwei 500Gigalies-Platten intus. Da ich zurzeit aber Speed brauche, läuft sie im Raid 0-Modus.

    Nun ist mir aufgefallen, dass die Platte(n) trotz FW 800 nicht schnell genug streamen kann, um z.B. einen 1080-Zeilen-Trailer (also Full HD) gänzlich ohne Einbrüche darzustellen. Sobald die Stream-Bitrate - laut Statistik des VLC-Players - über ca. 23.000 kb/s steigt, verzerrt das Bild und setzt aus.

    Ich bin auf dem Gebiet Streaming und Firewire nicht wirklich bewandert, weswegen ich nicht beurteilen kann, ob FW 800 überhaupt von technischer Seite solche Bitraten unterstützen kann.

    Daher die Frage: Liegt das Ruckeln am Videomaterial (weil z.B. schlecht komprimiert) oder wirklich an der mangelnden Speed-Kapazität der Platte bzw. von Firewire? Wenn letzteres: Ist das üblich oder nur in diesem speziellen Fall so?

    Stellt der letzte Read-Wert des XBench-Tests (siehe Anhang) die Streaming-Kapazität dar? Demnach ist also immer über 21,84 MB/sec Schluss mit flüssig, sehe ich das richtig?

    --------

    Anhang:

    Platten-Benchmark am FW 800-Slot mit XBEnch:

    Code:
    Disk Test	64.49	
    		Sequential	84.69	
    			Uncached Write	101.20	62.14 MB/sec [4K blocks]
    			Uncached Write	93.50	52.90 MB/sec [256K blocks]
    			Uncached Read	50.16	14.68 MB/sec [4K blocks]
    			Uncached Read	148.83	74.80 MB/sec [256K blocks]
    		Random	52.07	
    			Uncached Write	21.33	2.26 MB/sec [4K blocks]
    			Uncached Write	171.98	55.06 MB/sec [256K blocks]
    			Uncached Read	63.95	0.45 MB/sec [4K blocks]
    			Uncached Read	117.71	21.84 MB/sec [256K blocks]
     
  2. fluidlab

    fluidlab Auralia

    Dabei seit:
    12.06.06
    Beiträge:
    199
    Sorry, da kann ich Dir leider nichts fundiertes zu sagen, aber ich habe eine artverwandte Frage und hänge mich mal mit dran:

    Ich interessiere mich auch für die WD Studio II und möchte gerne wissen, ob man RAID1 auch so konfigurieren kann, dass die Festplatten nicht ständig gespiegelt werden, sondern beispielsweise nur 1x pro Woche (damit versehentlich gelöschte Dateien nicht direkt auf beiden Laufwerken gelöscht werden).

    Danke
     
  3. Rhinhold

    Rhinhold Jerseymac

    Dabei seit:
    01.03.05
    Beiträge:
    452
    Naja, außer das es das gleiche Produkt zum Inhalt hat, ist deine Frage schon sehr differenziert von meiner zu betrachten.

    Aber ich bin ja nicht so: ;)

    Soweit ich weiß, ist das schon rein technisch nicht möglich (zumindest mit dem, was die Platte und die beiliegende Software angeht). Denn die Spiegelung darfst du nicht als Back-Up-System an sich betrachten, dass man, ähnlich wie bei TimeMachine, einfach alle paar naselang spiegeln lässt. Sondern jede Datei, die gespeichert wird, wird just in diesem Moment auch zweimal gespeichert. Somit wird auch jede Datei, die du löschst, just in diesem Moment von beiden Platten gelöscht. Es ist somit nur eine BackUp-Lösung gegen den technischen Datenverlust, nicht jedoch gegen den benutzergesteuerten. :)

    Das, was du (anscheinend) suchst, bekommst du eher, wenn du eine weitere, seperate, externe Festplatte anhängt, die dann per TimeMachine (z.B.) deinen Datenstand (zu benutzerdefinierten Zeitpunkten) spiegelt. Ob TimeMachine aber wirklich auch externe Devices sichern kann, weiß ich nicht; da fehlt mir die Erfahrung dazu.
     
  4. hmstr

    hmstr Idared

    Dabei seit:
    13.12.06
    Beiträge:
    29
    Hallo Rhingold,

    was für ein MBP hast Du denn?
    Einige Generationen haben zwar einen FW800 Port, jedoch läuft der Datenverkehr über den gleichen Controller wie der des FW400 Ports.
    Hat man nun eine FW400er Platte an "seinem" Slot und eine FW800er an "ihrem", laufen beide nur auf 400 MBit/s.

    Da du "nur" ein MBP hast und versuchst damit 1080p HD Videos zu schauen, liegt es nahe, dass der Prozessor einfach zu langsam ist um es mit VLC wiederzugeben.
    Ich kann dir plex empfehlen. Auch wenn das Programm in mancher Hinsicht übers Ziel hinausschießt, ist die Wiedergabe von Full HD damit auf meinem MBP kein Problem mehr.

    Gruß
     
    Rhinhold gefällt das.
  5. Rhinhold

    Rhinhold Jerseymac

    Dabei seit:
    01.03.05
    Beiträge:
    452
    @hmstr:

    Ich habe ein mittlerweile älteres Modell mit 15"-TFT, 2,4 GHz-DualCore und Geforce 8600m GT (gek. Juli 2007).

    Aber das FW 400 und FW 800 nicht ordnungsgemäß funktionieren, kann ich eigentlich ausschließen. Ich habe XBench auch im USB2.0- und FW400-Modus mit der Platte laufen lassen. Die Werte sind deutlich voneinander abweichend. Da beide FW-Slots an der Platte selbst sowohl FW400 als auch 800 kompatibel sind, liegt diese Differenz eindeutig an den FW-Slots am MBP; so wie es sein sollte.

    Ich habe mir indess auch mal den Plex-Player angeschaut. Und tatsächlich: Mein besagter und problematischer 1080p-Trailer läuft an den kritischen Stellen rund; wenn auch mit ganz leichten Rucklern. Die Performance ist damit deutlich besser als beim VLC. Der bricht hier den Bilderlauf für ca. 5 sek ganz ab.

    Aber woran liegt das nun? Ist VLC am Ende der Flaschenhals?

    Auf jeden Fall erstmal vielen Dank für den Tipp! ;)
     
  6. hmstr

    hmstr Idared

    Dabei seit:
    13.12.06
    Beiträge:
    29
    Hallo Rhingold,

    wir haben fast das gleiche MBP. Auch bei dir müssten damit FW400 und FW800 über den gleichen Controler laufen.
    Kleiner Test diesbezüglich:
    Alle Perepherie ab und neustarten.
    NUR FW800 Platte dran und Geschwindigkeit testen. (Sollte um die 70MB/s liegen)
    Dann die FW400 Platte mit dran hängen und nochmal messen.
    Dann siehst Du, ob du das Controllerproblem hast oder nicht.

    Grundsätzlich ist VLC der Flaschenhals, da sehr ressourcengierig und schlecht oder gar nicht auf zwei Kerne optimiert. Natürlich könnte auch das Video an sich Schuld sein, denn auf meinem MBP mit nur 2.2 GHz (4GB Ram) läuft auch 1080p einwandfrei...
     
  7. Rhinhold

    Rhinhold Jerseymac

    Dabei seit:
    01.03.05
    Beiträge:
    452
    Eben diesen Test habe ich ja in meinem letzten Post angesprochen. FW800 ist deutlich schneller im Benchmark als FW400. Von daher würde ich mal meinen, dass passt soweit. Den FW800-Benchmark kannst du übrigens schon im Anfangspost bestaunen. ;)

    Bzgl. der reinen CPU-Leistung dürften die 1080p-Vids eigentlich kein Problem darstellen. Zumindest habe ich, sobald ich die hochaufgelösten Videos lokal auf dem MBP abespielt habe, noch keine Einbrüche erlebt. Erst jetzt mit der ext. HDD am Haken tauchen die Probleme auf. Daher hatte ich anfangs VLC ganz schnell ausgeschlossen. Aber wie es scheint, habe ich mir geirrt.

    Okay, dann werde ich Plex mal weiter ausprobieren. Das scheint mir durchaus zu einem würdigen FrontRow-Konkurrenten zu avancieren. :-D
     

Diese Seite empfehlen