• Es gibt nach dem Softwareupdate eine Reihe von Änderungen und Neuerungen in unserem Forum. Genaueres dazu findet Ihr in dieser Ankündigung. Hinweise, Kritik, Anregungen, Lob und Tadel bitte hier diskutieren.
Apfeltalk Weihnachtsbanner

VPN und NAS

Schotte1

Golden Delicious
Mitglied seit
08.12.16
Beiträge
8
Kurz vor der Verzweiflung hab ich mich hier angemeldet und hoffe auf Hilfe.
Folgende Situation:
Ich habe zu Hause (Provider Wilhelm.tel) und im Büro (Provider Telekom) je ein Netzwerk mit mehreren Geräten. Beide Netze sind über je eine Fritzbox 7490 mit OS 6.6 mit dem Internet verbunden. Rechner sind zu Hause 2 Macbook pro und im Büro 2 Mac alle laufen mit OS 10.12.1. Zu Hause hängt an der Fritzbox noch ein Seagate Central NAS (C1) an LAN 3. Ebenso im Büro (Bezeichnung C2), dort aber über einen Hub verbunden, der seinerseits über LAN2 an der Fritzbox hängt. Die Fritzboxen sind mit Hilfe des Dienstes My!Fritz als "Side to Side VPN" verbunden, der Tunnel steht. Alle Geräte haben feste IP-Adressen.
Mein Problem ist jetzt, dass ich manchmal auf das entfernte NAS nicht oder nur mit erheblichen Einschränkungen zugreifen kann. So werden manche Verzeichnisse zwar geöffnet aber als leer dargestellt, obwohl ganz sicher Mengen von Dateien enthalten sind. Dies gilt sowohl für den "öffentlichen" Bereich auf der Festplatte, wie für den durch Benutzer und Password geschützten Bereich.
Kann mir jemand sagen, was ich falsch mache?
 

trexx

Oberdiecks Taubenapfel
Mitglied seit
01.04.13
Beiträge
2.716
IP Netzwerkbereiche angepasst? Welche Geschwindigkeit hat der Hub. Warum ein Hub und kein kleiner Switch? Welche Geschwindigkeit an den LAN-Ports der FritzBoxen?
 

Schotte1

Golden Delicious
Mitglied seit
08.12.16
Beiträge
8
Sorry, ist ein Switch. IP angepasst = ja, Geschwindigkeit Switch/ Fritz = 1.000.
 

Scotch

Safranapfel
Mitglied seit
02.12.08
Beiträge
6.706
So werden manche Verzeichnisse zwar geöffnet aber als leer dargestellt, obwohl ganz sicher Mengen von Dateien enthalten sind.
Hast du einfach mal gewartet? Wenn es wirklich um "Mengen an Dateien" geht, also so ein paar hundert, dann kann es beim ersten Zugriff schon mal ein paar Sekunden dauern, bis was angezeigt wird. Das kommt einem dann schon mal deutlich länger als ein "paar Sekunden" vor ;)

Wie sind die Netzwerklaufwerke denn verbunden (Protokoll (SMB oder AFP), Zugriff über IP oder FQDN ("Servername")...)?
 

mafri

Pomme Etrangle
Mitglied seit
30.08.10
Beiträge
907
Bei mir habe ich im lokalen(!) Netz durchaus auch Wartezeiten wenn viele Dateien in einem Verzeichnis liegen. Ich sehe dann aber im Finder rechts unten das drehende Zahnrad als "Hinweis". Und wenn Du jetzt auf das entfernte NAS zugreifen willst darfst Du nicht vergessen dass das dann nur mit der Uploadgeschwindigkeit des entfernten Internetanschlusses geht. Vermutlich ist wirklich nur etwas Geduld gefordert
 

Schotte1

Golden Delicious
Mitglied seit
08.12.16
Beiträge
8
Also, die Anzahl der Dateien in den Verzeichnissen liegt zwischen 20 und max. 100. Die Wartezeit dauert so lange, dass irgendwann das Fenster "Bei der Verbindung mit dem Server XY ist ein Fehler aufgetreten" kommt, aber in seltenen Fällen funktioniert es einwandfrei. Ein paar Sekunden (also vielleicht 10, 20 oder auch 30) wären ja nicht schlimm, wenn dann der Zugriff vernünftig funktionieren würde. Es kann aber dann z.B. auch passieren, dass Word die Meldung "Word konnte das Dokument nicht öffnen" ausgibt.
Das führt mich auf den Gedanken, dass grundsätzlich etwas z.B. mit Freigaben oder Rechten nicht stimmt.
Zu den Protokollen:
Wie sind die Netzwerklaufwerke denn verbunden (Protokoll (SMB oder AFP), Zugriff über IP oder FQDN ("Servername")...)?
Alles probiert, auch FTP. Immer das Gleiche.
 

Dat_T

Eifeler Rambour
Mitglied seit
18.03.09
Beiträge
599
Wie stark ist der Upload auf der NAS Seite?
Das wird mit unter einer der möglichen Flaschenhälse sein.
 

Schotte1

Golden Delicious
Mitglied seit
08.12.16
Beiträge
8
Auf der langsameren Seite: Down 16,8 Mbit/s und Up 1,7 Mbit/s
 

Dat_T

Eifeler Rambour
Mitglied seit
18.03.09
Beiträge
599
Wenn die "langsame Seite" die mit der NAS ist, dann erklärt sich dein Problem mit den 1,7 MBit/s.
Selbst bei voller Auslastung braucht die Leitung für 25 MB locker 2 Minuten und dann macht der Upload nichts anderes.

Eine weitere Möglichkeit sind die Energieeinstellungen in der NAS, eventuell sind die Platten in einem "Deep Sleep" und es dauert bis sie wieder anfahren.

Ist schwer per Fernanalyse zu diagnostizieren, am besten die Beobachtungen mal festhalten und schauen wann es schnell und wann langsam war.
 

Schotte1

Golden Delicious
Mitglied seit
08.12.16
Beiträge
8
Ich vermute den Fehler wo anders. Ein NAS ist (siehe Fragestellung) auf beiden Seiten vorhanden. Die Schnelle Seite hat 100/18 MBit/s. Die Probleme treten auf beiden Seiten, also egal von welcher Seite ich Zugriff auf das jeweils andere NAS haben möchte, auf.
 

Scotch

Safranapfel
Mitglied seit
02.12.08
Beiträge
6.706
Wenn der Tunnel steht, ist das ein Zugriff über LAN. Anstatt mich auf deine Frage zu verweisen, solltest du dazu übergehen, dir gestellte Fragen zu beantworten - die stelle ich nicht aus Langeweile, sondern wegen der - gerade von dir bestätigten - Vermutung, dass du nicht so genau weisst, was du da eigentlich tust.
 

Insulaner

Martini
Mitglied seit
06.01.12
Beiträge
652
Wenn der Tunnel steht, ist das ein Zugriff über LAN.
Das ist grob falsch!

Ein Zugriff über VPN ist zwar ein direkt durch den Tunnel addressierter Zugriff zwischen zwei IP-Netzen,
scheinbar ohne fremde Hardware dazwischen. Aber es hat in der Ausprägung der Kommunikation absolut
nichts, aber auch gar nichts, mit einer LAN-Verbindung zu tun!

Part eins: Semantik
1. LAN bedeutet Local Area Network. Bei VPN kann von Local wohl nicht die Rede sein.

Part zwei: Technik
1. Über eine VPN-Verbindung wird meistens nur geroutet (Layer-3-Abschluss). Damit wird
also kein Broadcast durchgeleitet (also z.B. auch kein Apple-Talk)
2. Die Performance der Datenverbindung durch einen VPN-Tunnel ist offensichtlich mit einer
Datenverbindung innerhalb eines LAN überhaupt nicht zu vergleichen.
3. Die möglichen Paketgrössen (Paket-Size) auf Layer 2 sind abhängig von der physikalischen
Infrastruktur zwischen den beiden VPN-Endpunkten (insbesondere von der Technologie der
Anbindung des Standortes und von der Qualität der Datenverbindungen).
Im LAN sind sogar nicht Ethernet-Standard- "Jumbo"-Size-Pakete möglich.

Hier wurde hinsichlich der möglichen Fehlerquellen schon einiges angesprochen.
Im Punkt 3 könnte auch eine Möglichkeit für ein Kommunikationsproblem angesiedelt sein.
Evtl. probierst Du mal ein Ping mit unterschiedlichen Paketgrößen und einen DF-Bit (don`t fragment).
Bis zu welcher Paketgröße gehen die Pings durch?
Evtl. setzt Du mal die MTU auf einen geringeren Wert (z.B.1350 Byte).
 

Schotte1

Golden Delicious
Mitglied seit
08.12.16
Beiträge
8
Wenn der Tunnel steht, ist das ein Zugriff über LAN. Anstatt mich auf deine Frage zu verweisen, solltest du dazu übergehen, dir gestellte Fragen zu beantworten - die stelle ich nicht aus Langeweile, sondern wegen der - gerade von dir bestätigten - Vermutung, dass du nicht so genau weisst, was du da eigentlich tust.
Lieber Scotch, ich brauche keine Belehrungen (insbesondere wenn sie falsch sind) sondern konstruktive Hilfe. Trotzdem vielen Dank, dass Du so aktiv im Thread unterwegs bist. Danke Insulaner für den Hinweis.
Hat vielleicht jemand eine Idee, was mit Portfreigaben ist. Wer hat ein gut funktionierendes "Side to Side VPN" mit Fritzboxen und NAS Laufwerken und könnte mir Hinweise zur Konfiguration geben?
 

trexx

Oberdiecks Taubenapfel
Mitglied seit
01.04.13
Beiträge
2.716
Welche Protokolle sind denn beim NAS aktiviert?
Habe hier ein paar Standorte mit LAN-LAN Kopplung. Die laufen eigentlich ganz gut, auch mit freigegebenen Ordnern. Da die FritzBox das mit dem VPN ja halbwegs automatisch macht, gibt es da nichts mit Portfreigaben. Aber hast Du mal ins Log der FB geschaut? Gibt es da Einträge bzgl. des Aufbaus des VPN bzw. unter Last?
 

Scotch

Safranapfel
Mitglied seit
02.12.08
Beiträge
6.706
Das ist grob falsch!
Nö, dass ist eine dem hermeneutischen Horizont des TE angepasste Formulierung. Die vom TE vorgenommene Kopplung zweier Subnetze ist darüber hinaus auch technisch eine LAN-LAN-Koppelung und nicht mit einer VPN-Client-Verbindung vergleichbar.

Part zwei: Technik (...)
1.) Ach... Meinst du, dass das etwas mit meiner Frage nach dem verwendeten Netzwerkprotokoll zu tun haben "könnte"?
2.) Hat mit der Frage des TE absolut nichts zu tun - was soll dieser vollkommen zusammenhangslose Kommentar?
3.) Siehe 2.)

Im Punkt 3 könnte auch eine Möglichkeit für ein Kommunikationsproblem angesiedelt sein.
Nein. OP lesen.

Evtl. probierst Du mal ein Ping mit unterschiedlichen Paketgrößen und einen DF-Bit (don`t fragment).
Bis zu welcher Paketgröße gehen die Pings durch?
Evtl. setzt Du mal die MTU auf einen geringeren Wert (z.B.1350 Byte).
Mal abgesehen davon, dass das mit dem Problem nichts zu tun hat: Erstaunlicher Tip für jemanden, der via ftp über VPN auf eine Netzwerkfreigabe zuzugreifen versucht. Eingangsbemerkung von mir nochmal lesen und "hermeneutischer Horizont" googeln.

Lieber Scotch, ich brauche keine Belehrungen (insbesondere wenn sie falsch sind) sondern konstruktive Hilfe.
Soso. Dann haben dir die "Tips" vom @Insulaner doch bestimmt weiter geholfen und deine Tunnelverbindung tut's :) Echt, Typen wie du haben "Experten" wie den @Insulaner wirklich verdient. In diesem Sinne: Viel Erfolg & Ciao.

Hat vielleicht jemand eine Idee, was mit Portfreigaben ist.
Nichts. Wenn das ein Problem wäre, würden dir die FB nicht anzeigen, dass

Wer hat ein gut funktionierendes "Side to Side VPN" mit Fritzboxen und NAS Laufwerken und könnte mir Hinweise zur Konfiguration geben?
Ich, sogar mit mehreren LAN-LAN-Koppelungen gleichzeitig, aber da du dermassen renitent bist, hab' ich jetzt keine Lust mehr. Lass' dir von den "Experten" helfen. Tip: Lass' dir einfach mal deren LAN-LAN-VPN-Konfigurationsdateien zeigen, dann kannst du die mit deinen vergleichen ;)

Und jetzt bin ich wirklich weg.

Welche Protokolle sind denn beim NAS aktiviert?
Vergiss' es, das war meine erste Frage und ich versuche das erfolglos seit #4 beantwortet zu bekommen.
 

trexx

Oberdiecks Taubenapfel
Mitglied seit
01.04.13
Beiträge
2.716
Nö, d
Ich, sogar mit mehreren LAN-LAN-Koppelungen gleichzeitig, aber da du dermassen renitent bist, hab' ich jetzt keine Lust mehr. Lass' dir von den "Experten" helfen. Tip: Lass' dir einfach mal deren LAN-LAN-VPN-Konfigurationsdateien zeigen, dann kannst du die mit deinen vergleichen ;)

Und jetzt bin ich wirklich weg.

Vergiss' es, das war meine erste Frage und ich versuche das erfolglos seit #4 beantwortet zu bekommen.
Nee. Mit mangelnden Infos kann ich leider auch nicht helfend unterstützen. Da teile ich Deine Meinung.
 

Schotte1

Golden Delicious
Mitglied seit
08.12.16
Beiträge
8
Welche Protokolle sind denn beim NAS aktiviert?
Habe hier ein paar Standorte mit LAN-LAN Kopplung. Die laufen eigentlich ganz gut, auch mit freigegebenen Ordnern. Da die FritzBox das mit dem VPN ja halbwegs automatisch macht, gibt es da nichts mit Portfreigaben. Aber hast Du mal ins Log der FB geschaut? Gibt es da Einträge bzgl. des Aufbaus des VPN bzw. unter Last?
Es gibt bei beiden FB keine Einträge, außer den normalen zu Zwangstrennung und Verbindung sowie An- und Abmeldungen.
Bei der Seagate Central kann ich meines Wissens keine Protokolle aktivieren resp. deaktivieren. Auf der Benutzeroberfläche habe ich lediglich die Möglichkeit neue Benutzer anzulegen und IP-Adresse und DNS-Server festzulegen. Weitere Einstellungen kann ich nicht vornehmen. Was Scotch unter #4 fragt, haben ich unter #6 beantwortet. Ich habe SMB und AFP und auch FTP (ob es jetzt gefällt oder nicht und ob man das so macht oder nicht) versucht. Da die SC für Mac geeignet ist, bin ich davon ausgegangen, dass sie SMB unterstützt. Die bisher einzigen halbwegs brauchbaren Ergebnisse hatte ich mit ftp, da konnte ich mindestens einige Dateien kopieren. Ich gehe immer noch davon aus, dass mit der gesamten Konfiguration etwas nicht in Ordnung ist. Eigenartiger Weise funktioniert Ping klaglos in beide Richtungen und von beiden Seiten.