1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

VPN & Airport

Dieses Thema im Forum "macOS & OS X Server" wurde erstellt von Sputnik, 11.09.06.

  1. Sputnik

    Sputnik Zwiebelapfel

    Dabei seit:
    15.10.04
    Beiträge:
    1.284
    Hallo Zusammen,

    ich brauche mal wieder euer geballtes Wissen.
    Ich habe auf meinem OS X Server (10.4.7) nun den VPN-Server aktiviert. Die direkte Verbindung zu Hause klappt auch wunderbar, jedoch komme ich von Aussen nicht an die Systeme ran.

    Habe auf der Airport Base Station folgende Ports fürs Forwarding aktiviert

    500
    4500
    1701
    1723

    Was mache ich falsch? Kann die Airport Base Station (Software 5.7) das nicht? Welche Router nutzt Ihr dazu? Möchte den Server ungern direkt ins Netz hängen.

    Schöne Grüße

    Andre
     
  2. Appleboy

    Appleboy Neuer Berner Rosenapfel

    Dabei seit:
    04.12.05
    Beiträge:
    1.976
    Hallo Sputnik,

    zu deinem Problem mit der Airport Base Station kann ich dir leider nicht helfen, da ich diese nicht habe.

    Ist der Server mit WLan verbunden oder mit einem Ethernetkabel.
    Hast du statische öffentliche IP-Adressen oder einen DynDNS Account?
    Hast du in der Firewall von Mac OS X Server die Ports auch fürs externe Netzwerk freigegeben?

    Ich nutze den Draytek Vigor 2900 als Router.

    Viele Grüße

    appleboy
     
  3. Sputnik

    Sputnik Zwiebelapfel

    Dabei seit:
    15.10.04
    Beiträge:
    1.284
    Hallo,

    der Server ist natürlich via Ethernet im Netz.
    Die Adresse selbst ist dynamisch, also DynDNS.
    Die Firewall ist im moment gar nicht aktiv um solche fehle ausschließen zu können.
    Befürchte schon es liegt an der APEXBS, das diese keine vernünftige weiterleitung macht.

    Schöne Grüße

    Andre
     
  4. Appleboy

    Appleboy Neuer Berner Rosenapfel

    Dabei seit:
    04.12.05
    Beiträge:
    1.976
    Hallo,

    also wenn die Firewall ausgeschaltet ist und der Server mit Ethernet angeschlossen ist, denke ich auch, dass es am Router liegt. Ich würde Dir empfehlen, einen anderen Router auszuprobieren.

    Viele Grüße

    appleboy
     
  5. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Über eine AirPort Station sollte man eigentlich per VPN drüberkommen. Wenn der Firewall am Mac OS X Server ausgeschaltet ist, dann kann der momentan auch nicht dazwischenfunken.

    Port 1723 brauchst Du nur wenn Du PPTP VPN verwenden willst.
    1701, 500 und 4500 (alle udp) sind für L2TP notwendig.

    Die Protokolle GRE (für PPTP) und ESP (für L2TP) kann man auf der AirPort Station nicht einstellen, sie sind aber zugelassen. (Am Server Firewall nicht darauf vergessen!)

    Was sagt denn das vpn Log wenn Du Dich von extern verbinden willst? Ich meine wirklich von extern, nicht von intern mit der externen IP Nummer.
    Gruß Pepi
     
  6. Sputnik

    Sputnik Zwiebelapfel

    Dabei seit:
    15.10.04
    Beiträge:
    1.284
    @Herzlichen Glückwunsch zum 1000. Beitrag! :D

    Also, beim Versuch ein Verbindung über L2TP herzustellen schreibt er ins ppp.log folgende Zeilen:
    Code:
    Mon Sep 11 17:01:17 2006 : L2TP connecting to server 'xxx.dyndns.org' (000.000.000.000)...
    Mon Sep 11 17:02:17 2006 : L2TP cannot connect to the server
    
    Bei PTPP kommt folgendes:
    Code:
    Mon Sep 11 17:04:17 2006 : PPTP connecting to server 'xxx.dyndns.org' (000.000.000.000)...
    Mon Sep 11 17:04:21 2006 : PPTP connection established.
    Mon Sep 11 17:04:21 2006 : Using interface ppp0
    Mon Sep 11 17:04:21 2006 : Connect: ppp0 <--> socket[34:17]
    Mon Sep 11 17:04:48 2006 : PPTP hangup
    Mon Sep 11 17:04:48 2006 : Connection terminated.
    Mon Sep 11 17:04:48 2006 : PPTP disconnecting...
    Mon Sep 11 17:04:48 2006 : PPTP disconnected
    
    Ich habe ehrlich gesagt keine Ahnung was da nicht funktioniert. Muss man bei freischalten der Ports etwas beachten? Muss man irgendein spezielles Knöpfchen drücken? Habe die Station ganz normal mit dem Admin konfiguriert. Einzige besonderheit, die Station macht kein DHCP, dass übernimmt der Server.

    Schöne Grüße

    Andre
     
  7. U.U. stimmt da was mit der dyndns Namensauflösung nicht. Statt (000.000.000.000) sollte die IP des Servers stehen. Test doch mal mit
    Code:
    host xxx.dyndns.org
    in Terminal.app ob das geht oder teste die VPN Verbindung mit der IP des Servers. Weitere Tests imo auf L2TP/IPsec beschränken, mit PPTP rennt man noch schneller in NAPT Probleme.

    -Ralph
     
  8. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    @slowfranklin,
    da wollte doch nur jemand seine IP nicht disclosen... :)

    @Sputnik
    Danke, ich feiere wie sich das für einen Techniker gehört erst beim 1.024. Posting!

    Ok, L2TP am Client sagt nicht viel, stell mal das Logging auf Verbose bitte, vielleicht gibts da mehr zu sehen. Was sagt das VPN Log am Server zum selben Zeitpunkt?

    Beim PPTP VPN schau Dir mal die Encryption an! Findest Du in den erweiterten Einstellungen im Internet Verbindung.
    Gruß Pepi
     
  9. Sputnik

    Sputnik Zwiebelapfel

    Dabei seit:
    15.10.04
    Beiträge:
    1.284
    @slowfranklin: pepi hat recht, bevor ich meine aktuelle IP bzw. meinen DNS-Namen im Netz bekanntgebe muss mir noch einer ganz oft auf den Kopf hauen. :-D :p

    @pepi: Na dann... denke nicht das die lange auf sich warten lassen. ;)

    Also der Server, hmmm, L2TP scheint gar nicht durchgegangen zu sein. PTPP ist aber zumindest etwas geschwätziger:
    Code:
    2006-09-11 17:04:18 CEST	Incoming call... Address given to client = 192.168.xxx.xxx
    Mon Sep 11 17:04:18 2006 : Directory Services Authentication plugin initialized
    Mon Sep 11 17:04:18 2006 : Directory Services Authorization plugin initialized
    Mon Sep 11 17:04:18 2006 : PPTP incoming call in progress from 'xxx.xxx.xxx.xxx'...
    Mon Sep 11 17:04:19 2006 : PPTP connection established.
    Mon Sep 11 17:04:19 2006 : using link 0
    Mon Sep 11 17:04:19 2006 : Using interface ppp0
    Mon Sep 11 17:04:19 2006 : Connect: ppp0 <--> socket[34:17]
    Mon Sep 11 17:04:19 2006 : sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0x24df65d9> <pcomp> <accomp>]
    Mon Sep 11 17:04:22 2006 : sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0x24df65d9> <pcomp> <accomp>]
    Mon Sep 11 17:04:25 2006 : sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0x24df65d9> <pcomp> <accomp>]
    Mon Sep 11 17:04:28 2006 : sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0x24df65d9> <pcomp> <accomp>]
    Mon Sep 11 17:04:31 2006 : sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0x24df65d9> <pcomp> <accomp>]
    Mon Sep 11 17:04:34 2006 : sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0x24df65d9> <pcomp> <accomp>]
    Mon Sep 11 17:04:37 2006 : sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0x24df65d9> <pcomp> <accomp>]
    Mon Sep 11 17:04:40 2006 : sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0x24df65d9> <pcomp> <accomp>]
    Mon Sep 11 17:04:43 2006 : sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0x24df65d9> <pcomp> <accomp>]
    Mon Sep 11 17:04:46 2006 : sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0x24df65d9> <pcomp> <accomp>]
    Mon Sep 11 17:04:49 2006 : LCP: timeout sending Config-Requests
    Mon Sep 11 17:04:49 2006 : Connection terminated.
    Mon Sep 11 17:04:49 2006 : PPTP disconnecting...
    Mon Sep 11 17:04:49 2006 : PPTP disconnected
    2006-09-11 17:04:49 CEST	   --> Client with address = 192.168.xxx.xxx has hungup
    
    L2TP scheint also echt nicht durch die AP Station durchgegangen zu sein. PPTP allerdings schon. Leider kenne ich mich nur mit Cisco VPNs aus.... habe ehrlich gesagt keine Ahnung was mir der Server damit sagen möchte.

    Schöne Grüße

    Andre
     

Diese Seite empfehlen