1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Vom Mac aus per SMB auf Gast-PC (MS VirtualPC) zugreifen

Dieses Thema im Forum "Linux auf dem Mac" wurde erstellt von sk_dakota, 05.05.06.

  1. sk_dakota

    sk_dakota Morgenduft

    Dabei seit:
    16.10.05
    Beiträge:
    165
    Hallo,
    ich weiß das ist nicht haarfein das richtige Forum, aber ich hoffe vielleicht kann mir ja jemand hier helfen.
    Ich möchte vom Mac (iMac G5, 20", 2nd Gen) aus per SMB auf einen Gast-PC zugreifen, der unter MS Virtual PC läuft.
    Unabhängig vomn eingesetzten Betriebssystem auf dem Gast PC (Linux SuSE 9.3 oder Windows XP) gelingt dies immer nur "fast".
    Bsp. SuSE: Bei "mit Sever verbinden" smb://192.168.1.60 seh ich nachfolgend die Freigaben des Samba-Servers, kann aber keine Verbindung erzeugen.. der Maci rödelt ewig, das Mount-Icon erscheint auf dem Desktop aber dann die Meldung:

    Server-Verbindung wurde unterbrochen:
    192.168.1.60-1 [Trennen]

    alternativ auch

    Der Vorgang konnte nicht abgeschlossen werden, da
    eines oder mehrere benötigte Objekte nicht gefunden
    wurden.
    (Fehler -43) [Erneut versuch] [Abbrechen]

    Ein Zugriff per ssh funktioniert, aber das ist vergleichsweise low level, ja SMB-User sind eingerichtet, nein die SuSE-Firewall läuft nicht, ja ich kann per smb auf einen anderen (realen) PC zugreifen (egal ob win oder tux)

    Bei Windows als Gast-System genau das gleiche Fehlerbild....

    Den Effekt hat ein Bekannter von mir ebenfalls auf seinem Mac

    UND: es ist für mich zwingend erforderlich, vom Mac auf den Gast-PC zuzugreifen und nicht umgekehrt... (was ohne Probs geht)

    Ich hoffe es weiß jemand von Euch Rat...
    Danke schon mal im voraus....

    Gruss
     
    #1 sk_dakota, 05.05.06
    Zuletzt bearbeitet: 05.05.06
  2. wlanboy

    wlanboy Cripps Pink

    Dabei seit:
    13.05.05
    Beiträge:
    150
    der Gastpc bekommt wohl eine IP zugewiesen, also wird es wohl nicht an den Netzwerkeinstellungen von Virtual PC liegen.

    Spontan würden mir 2 Fehlerquellen einfallen.
    Firewall von OSX. Wenn dort der SMB Port gesperrt ist (bei OS X ist ja auch ein Samba dabei) kann die Verbindung nicht klappen.

    Das selbe auch unter deinem Gastsystem. Windows XP SP2 hat unter Systemsteuerung -> Windowsfirewall auch eine Firewall laufen. Die gleich ganz abschalten, oder eben Datei- und Druckerfreigabe zulassen.
     
  3. sk_dakota

    sk_dakota Morgenduft

    Dabei seit:
    16.10.05
    Beiträge:
    165

    Danke, aber dass die Systeme ggf. durch Firewall geschützt sind ist mir natürlich bewußt. Bei XP ist SMB aber per default offen. Außerdem hilft auch kein abschalten der Firewalls (weder Tux noch Windows, noch auf dem Mac).
    Außerdem schrieb ich ja, dass initial noch eine Verbindung stattfindet (dass nmb funktioniert ja) denn ich sehe die shares des Windows-Gasts bzw. des samba-Servers. Erst dass Mounten sselbst scheitert.
     
  4. wlanboy

    wlanboy Cripps Pink

    Dabei seit:
    13.05.05
    Beiträge:
    150
    ist dein Virtual PC auf dem aktuellsten Stand?
    denke ich könnte mich erinnern, dass es zu einer ähnlichen Thematik einen Patch von MS gab...
     
  5. mod_che

    mod_che Morgenduft

    Dabei seit:
    06.03.07
    Beiträge:
    164
    Was ist denn in die 3 Felder nach dem Verbindungsaufbau einzugeben?
    Arbeitsgruppe, Benutzer, Passwort? Welchen Benuternamen denn? Und muss man in der gleichen Workgroup sein?
     

Diese Seite empfehlen