1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

VMware Fusion & Bootcamp bereiten Probleme

Dieses Thema im Forum "Windows auf dem Mac" wurde erstellt von Rehner, 13.09.09.

  1. Rehner

    Rehner Alkmene

    Dabei seit:
    16.11.08
    Beiträge:
    35
    Hallo zusammen,

    ich hoffe es tummeln sich ein paar Fusion/Bootcamp-Experten im Board, den diese beiden bereiten mir momentan Probleme die ich nicht allein gelöst bekomme.

    Folgende Situation:

    Auf meinem MBP mit OSX 10.6.1 habe ich VMware Fusion 2.0.5 laufen. Damit möchte ich auf meine Bootcamp-Partition mit XP Pro SP3 zugreifen. Seit ich jedoch für SnowLeo das System neu aufgesetzt habe, will mir das nicht mehr gelingen.

    Ich bin folgendermaßen vorgegangen Platte formatiert-->SL installiert-->Bootcamp eingerichtet (XP stammt von einem Image der vorherigen Installation)-->Fusion installiert. Jetzt gelingt es mir nicht, unter Fusion die Bootcamp-Partition als virtuelle Festplatte einzurichten. Der Assistent bricht ohne spezifische Fehlermeldung ab.

    Ich denke, dass Fusion an der Bootcamp-Partition etwas verändert/installiert und deswegen das "neue" XP vom Image nicht aktzepiert wird, da es ja bereits als VM gedient hat. Die Frage ist jetzt was wird verändert/installiert und kann man es rückgängig machen?

    Hoffe jemand weiß Rat!

    Viele Grüße und schönen Sonntag wünscht Nic
     
  2. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.905
    Mit dem Assistenten?
    Und das fand seinen Weg ... wie genau? ...auf die BC Partition?
     
  3. Rehner

    Rehner Alkmene

    Dabei seit:
    16.11.08
    Beiträge:
    35
    Ja, die Einrichtung erfolgte mit dem BC-Assistenten. Das Image wurde via Imaging-SW (R-Drive Image) Boot-CD wieder aufgespielt.

    Ich gehe davon aus, dass das Image noch Teile/Informationen der vorherigen Bootcamp-VM enthält und deswegen keine neue VM eingerichtet werden kann. Ist das möglich?

    Gruß Nic
     
  4. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.905
    Die VMware-Tools dürften kaum das Problem sein.
    Lässt sich diese Installation denn "nativ" korrekt starten?

    Wenn die Imaging-Software deine Partitionstabellen beschädigt hat, hast du Gefrickel vor dir.
    Merke: Solche Tools aus dem Lager der BIOS-PCs sind auf Macs (und anderen EFI-Rechnern) grundsätzlich tabu.
     
  5. Rehner

    Rehner Alkmene

    Dabei seit:
    16.11.08
    Beiträge:
    35
    Dann habe ich ja wohl nochmal Glück im Unglück gehabt. Nativ läuft die Installation einwandfrei! Nur Fusion schafft es nicht daraus eine virtuelle Disk zu erstellen. Ich dachte auch nicht an die VMware-Tools, sondern z.B. Dateisystem & Partitions Informationen. Irgendetwas dass Fusion "sagt" das die Partition schon eine VM ist !?

    Btw. gibt es denn eine OSX Alternative, mit der sich ein Abbild der Bootcamp-Partition erstellen lässt?
     
  6. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.905
    Klar doch. Winclone

    Mit der Integration von BC hat VMware manchmal etwas "merkwürdige" Probleme.
    Lass doch mal den Output folgender Terminalsequenz sehen (Admin-Stoff):
    Code:
    [SIZE="-1"]sudo bash -c "gpt -r show /dev/disk0; fdisk /dev/disk0; pdisk -l /dev/disk0;"[/SIZE]
    Du hast schon bedacht dass du ein Admin sein musst um die BC Partition nutzen zu dürfen?
     
  7. Rehner

    Rehner Alkmene

    Dabei seit:
    16.11.08
    Beiträge:
    35
    So, hier das Ergebnis des Terminal-Befehls:

    Ich bin als Standard-Nutzer (bei der Installation angelegt) angemeldet und gebe für alle systemkritischen Vorgänge mein Kennwort ein. Bisher hat das auch immer für BC gereicht.
     
  8. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.905
    Du musst deine Partitionstabellen reparieren. Offensichtlich hat die Klonsoft hier gefährlich gepfuscht. Betrachte das Softwareprodukt als Fall für die "Rundablage Rattan".

    Falls du rEFIt installiert hast, kannst du das darin enthaltene Synchronisierungstool dafür benutzen (Im Bootscreen unter den Tools sichtbar). Falls nicht, melde dich einfach noch mal.
     
  9. Rehner

    Rehner Alkmene

    Dabei seit:
    16.11.08
    Beiträge:
    35
    So, ich würde sagen, klassischer Fall von "kaputt Repariert" ;)

    Habe das rEFIt-Synchronisierungstool benutzt, das im Zuge der Synchronisation den MBR der NTFS-Partition neu geschrieben hat. Die Ausgabe des Terminal-Befehls von oben sieht jetzt so aus:

    Das Ergebnis des ganzen ist, dass sich Windows jetzt weder nativ noch als VM starten lässt.

    Kann ich noch etwas frickeln, oder komme ich um eine komplette, "saubere" Neuinstallation nicht herum? Mein vorhandenes Image werde ich mit dem Imaging-Tool zusammen "in die Tonne treten" können, oder?

    Das ist echt ärgerlich, denn der Windows-Installationsaufwand inkl. aller nötigen Anwendungen nimmt gerne mal einige Stunden in Anspruch! :-c
     
  10. Cheops

    Cheops Carola

    Dabei seit:
    27.08.07
    Beiträge:
    114
    Hast du den SL komplett neu installiert? Hast du irgendwelche Altdaten übernommen?

    Ich frage, weil Fusion im Library Verzeichnis des Users ein Verzeichnis mit den Bootcamp Informationen anlegt. Wenn dieses Verzeichnis nicht genau zur Bootcamp Partition passt, lässt sie sich in Fusion nicht mehr starten.

    Schau mal ob du das Bootcamp Verzeichnis von Fusion findest (AppCleaner hat mir da geholfen) und verschiebe es in den Papierkorb. Danach startet du Fusion und es sollte dir automatisch deine aktuelle Bootcamp Partition anbieten (wenn sie mal wieder läuft ;)).

    Spiel doch einfach mal das Image von Windows zurück. Schau ob du Windows booten kannst. Danach versuche wie oben beschrieben die Partition in Fusion neu bekannt zu machen.

    Sag Bescheid ob's klappt.
     
  11. Rehner

    Rehner Alkmene

    Dabei seit:
    16.11.08
    Beiträge:
    35
    Danke für den Tipp, wobei ich nicht glaube das es hilft. Für SL hatte ich das MBP komplett platt gemacht, und auch keine großartigen Backups wieder eingespielt (nur einzelne Daten manuell). Von daher dürfen eigentlich keine "Spuren" der vorherigen Installation mehr da sein.

    Es bringt mir auch nichts Fusion komplett (mit Hilfsprogrammen oder manuell) zu entfernen. Er mag meine BC-Partition dann immer noch nicht! :-c

    Je länger ich überlege, umso "verlockender" erscheint mir ein komplett Re-Setup von OSX und Win, um endlich mal wieder ein sauberes System zu haben und diesen Status dann als Image festhalten zu können. Wobei, wenn ich an die kostbare Zeit denke ....
     
  12. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.905
    So könnte man es nennen, aber der Fehler liegt in der Imaging-Software.
    Die Reparatur *muss* sein.

    Ja.
    Zunächst benutzt du das Böse-Programm nochmal, um die Win-Partition zurückzuspielen.
    (Ein letztes mal.)
    Wichtig ist dass du dieses Windows danach NICHT startest.
    Stattdessen öffnest du Winclone und lässt das Dateisystem darin "shrinken" (auf seine Minimalgrösse zusammenpacken).
    Dann benutzt du die Synchronisation, um die P-Tabellen wieder zu reparieren.
    (Der Zustand sollte dann genau dem jetzigen entsprechen.)
    Anschliessend nochmal Winclone, um das Windows-Dateisystem wieder (korrekt) zu expandieren.
    Dann sollte alles paletti sein - und dein Windows funktionsfähig.
     
  13. Rehner

    Rehner Alkmene

    Dabei seit:
    16.11.08
    Beiträge:
    35
    Muss ich das geshrinkte OS irgendwo wegsichern? Oder sagt mir das Winclone dann schon?
     
  14. Rehner

    Rehner Alkmene

    Dabei seit:
    16.11.08
    Beiträge:
    35
    So scheint das aber leider auch nicht zu klappen. Winclone gibt mir beim shrinken den angehängten Error aus. :(
     

    Anhänge:

  15. Rehner

    Rehner Alkmene

    Dabei seit:
    16.11.08
    Beiträge:
    35
    Habe bezüglich des Errors mal das Netz bemüht und hier einen Lösungsansatz gefunden. Da ich Windows ja nicht starten sollte, habe ich chkdsk kurzerhand von der Win-CD gestartet. Es hat auch (angeblich) einen oder mehrere Fehler gefunden und behoben.
    Winclone bricht jedoch nach wie vor mit der oben angehängten Fehlermeldung ab.

    Hat noch jemand eine Idee woran es liegen könnte, oder wie ich weiterkomme?
     
  16. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.905
    Die genaue Bedeutung des Fehlercodes kenne ich leider nicht, aber das naheliegendste wäre, dass dein Win-Volume schon vor der Erstellung des Images nicht in konsistentem Zustand war - sprich: Einer Reparatur mit Windows 'chkdsk' bedurft hätte.
    Du kannst das (vor der Verkleinerung mit Winclone) noch nachholen.
    Dazu brauchst du die "Wiederherstellungskonsole" von der XP Installations-CD.
    CD booten und dorthin wechseln. Je nach CD-Distribution geht das entweder direkt über die Dialogseiten des Setup-Programms (gleich zu Beginn) oder durch das booten mit gedrückter F10-Taste (glaub ich, so eine hab ich nicht).
    Dort musst du dich dann unter Angabe des "Administrator"-Kennworts bei deiner Winstallation anmelden und mit
    Code:
    chkdsk c: /p
    eine erzwungene Reparatur des Dateisystems durchführen. Evtl mehrfach durchlaufen lassen, bis kein Fehler mehr berichtet wird.
    Dann sollte sich das Volume wie erwartet shrinken lassen.
    (Boote es aber nicht, bevor die Prozedur vollständig beendet ist)
     
  17. Rehner

    Rehner Alkmene

    Dabei seit:
    16.11.08
    Beiträge:
    35
    Das bringt leider auch nichts. Nachdem ich ja vorher bereits chkdsk mit Parameter "r" hab laufen lassen, haben auch 2 Versuche mit Parameter "P", bei denen keine Fehler gefunden wurden, keine Besserung gebracht. Winclone weigert sich immer noch zu shrinken.
     
  18. Rehner

    Rehner Alkmene

    Dabei seit:
    16.11.08
    Beiträge:
    35
    So, hier der Abschluss dieses Themas.

    Nachdem alle Versuche die Bootcamp-Partition als VM zu nutzen fehlgeschlagen sind, habe ich mich entschlossen sowohl OSX als auch Win komplett neu aufzusetzen. Diesen Status sichere ich jetzt erstmal mit TM und Winclone, um für künftige Unwägbarkeiten besser gerüstet zu sein. ;)

    Ein dickes Dankeschön hier noch einmal an Rastafari, der mich aufopferungsvoll unterstützt hat!

    Viele Grüße Nic
     

Diese Seite empfehlen