1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Virtual PC feste IP (kein DHCP) vs. elmeg T444

Dieses Thema im Forum "Windows auf dem Mac" wurde erstellt von obstbauer, 31.08.09.

  1. obstbauer

    obstbauer Weisser Rosenapfel

    Dabei seit:
    09.09.04
    Beiträge:
    792
    guten abend,

    habe hier ein etwas garstige telefonanlage (funkwerk elmeg t444) diese will nur über ein externes PC-tool konfiguriert werden welches natürlich auf dem mac nur über virtual pc, paralles und co. läuft. soweit sogut, leider hängt virtual PC in eine DHCP und bezieht eine ganz andere IP als der mac host. somit kann sich die software nicht über 2 routings mit der anlage verbinden...

    die t444 fungiert als DHCP der dem PC ein fest zugewiesene IP vergibt. es gibt noch funktionen für VOIP aber das ist erstmal unwichtig. es ist auch nicht nötig dass der router im weiteren netzwerk hängt, es geht erstmal nur um die konfiguration der ISDN komponenten.

    geht das überhaupt?

    danke für tipps :)
     
  2. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.902
    VPC setzt sich per default als ganz normales Anwendungsprogramm huckepack auf die IP deines Mac.
    Sprich: Eine einzige IP für beide Systeme. Kann man aber auch anders einstellen.
    Ergo ---> Programmeinstellungen überprüfen.
     
  3. obstbauer

    obstbauer Weisser Rosenapfel

    Dabei seit:
    09.09.04
    Beiträge:
    792
    danke für die antwort :)

    also wie schon erwähnt setzt der DHCP der t444 den mac auf 192.168.1.50. der t444 hat somit als gateway 192.168.1.250.

    VPC setzt sich aber 192.168.131.66 als host ip und 192.168.131.254 als gateway (welcher dann vermutlich auf 192.168.1.50 geroutet wird) kein ahnung wie ich da vorgehen soll... wäre ja als "normale anwendung" eigentlch üblich dass VPC sich vom mac ein IP über DHCP holt und auch seinen gateway benutzt, oder?
     
  4. gKar

    gKar Maunzenapfel

    Dabei seit:
    25.06.08
    Beiträge:
    5.362
    Dein VPC dürfte auf NAT (DHCP ist hier nicht der Übeltäter) konfiguriert sein. Das sollte man aber auch umschalten können. Bei VMWare gibt's jedenfalls zu NAT noch zwei Alternativen, insbesondere einen „Bridged“-Modus, in dem die VM im Netzwerk wie ein zweiter Computer neben Deinem Mac erscheint und direkt vom Router per DHCP eine eigene IP beziehen kann, was dann kein Problem mehr darstellen sollte.
    Ob das auch bei VPC geht, solltest Du den VM-Einstellungen oder der Hilfe entnehmen.
     
  5. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.902
    Das ist der NAT Modus (gemeinsame IP, intern umgelenkt auf ein zweites "Pseudo" Subnetz)
    Du solltest keine Probleme mehr haben, wenn du umstellst auf... (wie nennt sich das gleich wieder bei VPC ???) Naja, das mit der Verwendung einer separaten IP ist in der VPC-Hilfe beschrieben.
    Damit das gelingt, muss eines der beiden Betriebssysteme auf die Verwendung einer statischen (manuell vergebenen) IP fest eingestellt sein. (Nur eines kann DHCP nutzen)
     
  6. obstbauer

    obstbauer Weisser Rosenapfel

    Dabei seit:
    09.09.04
    Beiträge:
    792
    danke für eure antworten, werde gleich mal eine demo von vmware versuchen!

    @rastafari: ich glaube was du meinst ist folgendes

    [​IMG]
    [​IMG]

    dann kommt allerdings beim start von VPC
    [​IMG]

    irgendwas ist da noch falsch, liegt das an den "beiden" kollidierenden DHCP's?
     
  7. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.902
    Wohl eher nicht, dürfte eher eine Inkompatibilität mit der OS-Version sein.
    Kann ich dir aber nichts näheres dazu sagen (als Connectix von Microsoft übernommen wurde hat das Prog meine HD auf Nimmerwiedersehen verlassen). Mit der Version 6.x gings jedenfalls problemlos.
    Auf welchem Rechner läuft das ganze denn?
     
  8. obstbauer

    obstbauer Weisser Rosenapfel

    Dabei seit:
    09.09.04
    Beiträge:
    792
    moin,

    also ich habe die ganze geschichte auf mehreren rechnern getestet.

    aber es wäre schon erforderlich dass die ganze chose auf meinem PB G4, 1.67 läuft da ich am installationsort der t444 keinen anderen rechner zur verfügung habe, aber mit VPC haut das ja irgendwie nicht hin.

    auf den tipp von gKar hin habe ich mal auf meinem macpro vmware mit windows XP pro installiert (netzwerkeinstellung auf bridge!)
    DAS ging sofort ohne probleme, so wie ich mir das zuvor bei VPC vorgestellt habe...

    leider gibts aber keine VMWARE version mehr für ppc, nur für intel soweit ich das ergooglen konnte... o_O

    VPC ist auch von den einstellungen her eher beschränkt, VMWARE hat es da wohl echt mehr raus (der VPC herausgeber hat da mal wieder ordentlich gepunktet bei mir)

    parallels hab ich auch mal kurz versucht auf dem macpro aber das war fast die selbe nummer wie bei VPC... ohne erfolg bisher.

    1:0 für den macpro mit vmware

    EDIT: ist VPC 7.0
     
    #8 obstbauer, 01.09.09
    Zuletzt bearbeitet: 01.09.09
  9. gKar

    gKar Maunzenapfel

    Dabei seit:
    25.06.08
    Beiträge:
    5.362
    Gab's noch nie. Virtual PC emuliert einen Intel-Prozessor auf einer anderen Plattform (ist deshalb auch sehr langsam), während Parallels, VMWare und VirtualBox sog. Virtualisierer sind, die eine Intel-CPU nicht nachbilden, sondern voraussetzen.
     

Diese Seite empfehlen