1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Virtual Hosts unter MAMP und Typo3 Probleme

Dieses Thema im Forum "PHP & Co." wurde erstellt von JEdgar, 05.06.09.

  1. JEdgar

    JEdgar Idared

    Dabei seit:
    09.10.07
    Beiträge:
    24
    Hallo miteinander,

    Ich habe heute einen Apache-Server, in Verbindung mit Typo3, von http://www.in-genia.de/t3dmg.0.html runtergeladen. Die Installation gestalltete sich problemlos. Auch das Typo3-Backend und Typo3-Frontend kann einwandfrei genutzt werden. Soweit so gut!
    Als nächstes wollte ich VIRTUAL HOSTS einrichten, damit ich im Browser eine Adresse eingeben kann und mich der Apache-Server auf meine lokale Workarea (z.B.: /Users/JEdgar/Sites/Website/) weiterleitet. Also hab ich der "httpd.conf"-Datei folgende Zeilen hinzugefügt:
    Code:
    NameVirtualHost *:80
    
    # ------------- Workarea Homepage Blabla --------------
    <VirtualHost *:80>
        ServerAdmin webmaster@blabla.bla
        DocumentRoot /Users/JEdgar/Sites/Website
        ServerName blabla.bla
        ErrorLog logs/blabla-error_log
        TransferLog logs/blabla-access_log
    </VirtualHost>
    
    Diese Änderung zeigte aber keine Wirkung (auch nach einem Neustart nicht). Irgendwann habe ich herausgefunden, wenn ich das Port, an dem der Server "hört", auf 80 stelle funktionieren 2 meiner 3 virtuellen Hosts. Auf das Typo3-Backend bzw. Frontend kann dann auch nicht mehr zugegriffen werden. Stellt man das Port wieder auf 8888 (Grundeinstellung des Servers), funktioniert Typo3 wieder und meine 3 Websites sind wieder unerreichbar.
    Dies ist meine Leidensgeschichte!!!

    Und hier meine Fragen:
    Wie kann ich die Virtuellen Hosts einstellen, damit alle meine Websites erreichbar sind? Ich möchte meine Workarea's aber nicht in den htdocs-Ordner des Servers kopieren!!!
    Kann ich die Installation von Typo3 in einen anderen Ordner verschieben?
    Wie kann ich den Apache-Server, beim Hochfahren meines MB, starten?

    grüße...
     
  2. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Dein Server hört auf Port 8888? Welche OSX Version hast du?
    Bei mir (Ich benutze immer den OSX eigenen Server) horcht der Apache imer auf Port 80. Ich muss bei MAMP passen. Ich weis nicht, ob da ein eigener Server mit installiert wird. Ich denke da kommt was durcheinander.
    Du kannst auch ein Alias definieren. Dann kannst du damit z.B. localhost/test zugreifen.

    Der Apache startet bei mir direkt mit, wenn ich das Web-Sharing in den Systemeinstellungen aktiviert habe.
     
  3. JEdgar

    JEdgar Idared

    Dabei seit:
    09.10.07
    Beiträge:
    24
    Die Einstellung die ich in der httpd.conf geändert habe, ist folgende:
    Code:
    #
    # Listen: Allows you to bind Apache to specific IP addresses and/or
    # ports, instead of the default. See also the <VirtualHost>
    # directive.
    #
    # Change this to Listen on specific IP addresses as shown below to 
    # prevent Apache from glomming onto all bound IP addresses (0.0.0.0)
    #
    #Listen 12.34.56.78:80
    
    Listen 8888
    
    und dieses Port habe ich dann auf 80 geändert. Aber wie gesagt, dann konnte ich nur auf 2 meiner 3 virtuellen Hosts zugreifen. Warum? Keine Ahnung!

    Mein Betriebssystem ist MAC OSX 10.5.6
     
  4. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Tjo, MAMP installiert einen Weiteren Apache wenn ich das richtig sehe. In welchen Dateien fügst du denn die Änderungen durch?
     
  5. JEdgar

    JEdgar Idared

    Dabei seit:
    09.10.07
    Beiträge:
    24
    nur in der httpd.conf.
     
  6. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    In welcher? MAMP bringt auch einen Apache mit. Du solltest schauen wo welche Datei liegt.
    Ich muss aber auch weiter passen. Ich setze den Apache vom System ein.
     
  7. JEdgar

    JEdgar Idared

    Dabei seit:
    09.10.07
    Beiträge:
    24
    Es gibt ja nur eine httpd.conf Datei, die im Ordner /Applications/MAMP/conf/ liegt. Zumindest hab ich nur eine gefunden.
     
  8. JEdgar

    JEdgar Idared

    Dabei seit:
    09.10.07
    Beiträge:
    24
    Kann mir kein Apache-Spezialist helfen?
     
  9. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Hast du Web Sharing in den Systemeinstellungen aktiviert?
    Man bräuchte deine Apache Config um den Fehler zu finden. Normalerweise sind Home Dirs mit eingerichtet, d.h. Das ein http://localhost/~username in dem Verzeichnis Website des Users landet.
    Was hast du denn als Eintrag für die VirtualDomain genommen? Wie versuchst du darauf zuzugreifen? Nicht das die DNS Auflösung Probleme macht.
    Das einfachste ist über ein Alias in der Apache Config.
     
  10. JEdgar

    JEdgar Idared

    Dabei seit:
    09.10.07
    Beiträge:
    24
    Ich habe nun das Web-Sharing aktiviert, dies ändert aber nichts an meiner Situation.
    Zugreifen möchte ich über die virtuellen Hosts die ich dann in der Adressleiste meines Browsers eingebe.
    VirtualDomain? Habe ich nirgends gefunden...

    Meine Konfigurationsdatei habe ich im Anhang hinzugefügt.
    Ich hoffe dies bringt ein bischen Licht ins Dunkel!
     

    Anhänge:

  11. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Aeh, MAMP wird nicht über das Web-Sharing einschalten. Web-Sharing schaltet den Leo eigenen Apache an.
    ich meine die Server Alias mit Virtual Domain. Mein Fehler.
    Hast du denn einen DNS Eintrag für den ServerAlias? Du solltest das Web-Sharing abschalten. Danach schauen ob du einen Host Eintrag in der /etc/hosts vornimmst oder ob du die VirtualHost rausschmeist und mit Alias und Directory Direktive arbeitest. Mit dem Alias kannst du halt auch bestimmten wo die Dateien liegen.
    Alternativ kannst du auch UserDirs aktivieren.
     
  12. JEdgar

    JEdgar Idared

    Dabei seit:
    09.10.07
    Beiträge:
    24
    So, ich habe nun das Web-Sharing deaktiviert. Wenn ich nun im Browser "localhost" oder einen der virtual Hosts eintrage, bekomme ich...
    1. Die Meldung "Es klappt! Der Apache-Webserver ist auf dieser Website installiert!"
    und 2. das Bedürfnis mit meinem Baseballschläger den Laptop vom Balkon auf die Straße zu schießen und anschließend runter zu gehen und meine Notdurft darauf zu verrichten!

    Je mehr du mich fragst desto weniger weiß ich und desto verwirrter werd ich. :)
    Wo kann ich die DNS Einträge überprüfen?
    Und /etc/hosts finde ich in meinem MAMP-Ordner auch nicht (ich beginne schon an mir zu zweifeln!).
     
  13. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Mache es über die Alias Option *KLICK* Darüber kannst du die Verzeichnisse festlegen. Du kannst auch (wie schon erwähnt) das UserDir Module in der Config freischalten.
    Die Datei hosts findest du im Verzeichnis /etc. Daran kommst du über das Terminal. Ich glaube nicht das du einen DNS Eintrag hast. Deswegen kannst du sowas zum testen in der /etc/hosts eintragen.
     
  14. til...

    til... Golden Delicious

    Dabei seit:
    20.10.07
    Beiträge:
    8
    MAMP Apache Virtual Hosts 10.5

    same, same bei mir. :mad:

    in etc/hosts steht 127.0.0.1 VH-Name
    in etc/apache steht:
    <VirtualHost *> <Directory "/Applications/MAMP/htdocs/vh-name/">
    in mamp/config/apache steht:
    <VirtualHost *:8888> <Directory "/Applications/MAMP/htdocs/vh-name/">

    trotz den zwei Varianten wird stets "Es klappt! Der Apache-Webserver ist auf dieser Website installiert!" geladen, wenn http://VH-Name eingetragen wird.
    Wird http://VH-Name:8888 eingetragen, dann erscheint das Verzeichnis
    "/Applications/MAMP/"
    anstatt
    "/Applications/MAMP/htdocs/"

    In mamp/config/apache folgendes einzutragen:
    <VirtualHost *:80> <Directory "/Applications/MAMP/htdocs/vh-name/">
    hilft auch nicht weiter.

    Hat jemand einen Tip, wie ich durch "http://vh-name" die gewünschte Seite des Verzeichnisses herzaubern kann?

    danke vielmals!
     
  15. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Aeh warum fuschst du in der /etc/apac... herum wenn du MAMP installiert hast? Warum hast du da ein Virtual Host drin und warum änderst du nicht einfach das DocumentRoot für den Virtuellen Server?
    Es ist klar, das :8888 auf MAMP zeigt, weil MAMP das so voreinstellt.
    Bis auf ein paar Ausnahmefälle frage ich mich eh, warum man nicht (irgendwo hier im Forum gibt es dazu auch eine Anleitung) einfach den lokalen Apache aktiviert und einfach nur mysql zusätzlich installiert. Ok, MAMP scheint sehr komfortabel geworden zu sein, aber spezifische Anpassungen bringen wohl Leute zur Verzweifelung.
     
  16. til...

    til... Golden Delicious

    Dabei seit:
    20.10.07
    Beiträge:
    8
    in etc/ hab ich erstmal die hosts - konfig anpassen müssen, da ich die in MAMP nicht gefunden habe. Dass rumfummeln an der htconfig des OSX-Apache nichts bringt weiß ich jetzt auch.

    Ich hab irgendwo mal eine Info gelesen, wie man MAMP auf Port 80 trimmen kann, so dass man eben nicht mehr http:/vh-name:8888 eingeben muss, leiderleider find ich die Info nicht mehr. Weißt du da aus dem Handgelenk eine Lösung?

    Der nächste Teil der mir komisch scheint ist, dass bei http://vh-name:8888 stets das MAMP/htdocs/ Verzeichnis geöffnet wird, nicht aber, wie in der htconfig (in MAMP ;)) <Directory "/Applications/MAMP/htdocs/vh-name/web">

    danke für Input!
     
  17. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Tjo, dann musst du in der config von MAMP auch sagen, dass der Apache auf Port 80 hören soll. Ach eine Suche (wenn du die Config schon auf hast) nach 8888 hätte dir die Option ServerPort geezeigt. Man sollte aber das Websharing vom Leo dekativieren.
    Weiterhin gibt es die Option DocumentRoot (steht auch in der Doku mit drin). Das sieht man auch in der Standard Config der Apache (nicht MAMP) beim Leo. Statt vh--- kann man auch einfach localhost nehmen.
     
  18. til...

    til... Golden Delicious

    Dabei seit:
    20.10.07
    Beiträge:
    8
    mamp, whatever.
    habs jetzt doch wieder runter geworfen und konfigurier grad die Hausmittel.

    Danke jedenfalls für deine Tipps, haben mir weitergeholfen!
     
  19. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Seit Leo das einzig sinnige (auch schon untre Tiger) wenn man etwas vom normalen abweichende Sachen lokal testen will.
     

Diese Seite empfehlen