1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Virtual Box / VMWARE altes XP System integrieren

Dieses Thema im Forum "Windows auf dem Mac" wurde erstellt von cyprus, 14.08.08.

  1. cyprus

    cyprus Gala

    Dabei seit:
    17.04.08
    Beiträge:
    51
    Hallo,
    mein Schritt zu Mac war unter der Prämisse erfolgt das ich XP mitnehmen kann. Jetzt hab ich mich ein wenig im System umgeschaut und finds auch ganz schön aber ich brauche dennoch XP.
    Ich hab VirualBox installiert und recht einfach Windows drauf installiert. Das läuft auch prima. Allerdings ist es ein Blankosystem. Nun würde ich sehr gerne mein Windows System vom alten Notebook rüberziehen denn das würde mir ne menge Arbeit ersparen.
    NUR WIE. Ich hab in den Anleiteunge nix gefunden. Hat hier jemand ne Idee. ICh würd auch wenn ihr mir das empfehlt auf VMWARE Fusion wechseln. Da dort die anscheinend die Integration in OSX besser gelöst wurde. Windows mit allen Progs neu aufsetzen würde geschätzte 2 Wochen dauern und dafür hab ich grad nicht die Zeit.

    Deshalb bitte ich hier um Hilfe.

    Liebe Grüße

    Cyprus
     
  2. tharwan

    tharwan Englischer Kantapfel

    Dabei seit:
    01.09.07
    Beiträge:
    1.085
    Also erstmal gibt es in Windows irgend einen Assistenten der Behauptet er kann so was, was wohl nicht ganz der Wahrheit entspricht.
    Ansonsten gibt es bei Parallels einen Parallels Transporter der dir dein System in eine VM wandelt und bei VMware heißt das ding VMware Converter

    könnte mir auch gut vorstellen das es so was bei Virtual Box auch gibt.
     
  3. cyprus

    cyprus Gala

    Dabei seit:
    17.04.08
    Beiträge:
    51
    Danke über den Koverter war ich schon gestolpert aber ich hab keine Vorstellung dazu. Was die Windows Bordmittel betrifft bin ich deiner Meinung diese sind oft mit Vorsicht zu genießen.
    Sollte es hier jemanden mit praktischen Erfahrungen geben so würde ich mich über eine Meldung freuen.

    Lieben Dank im vorraus

    Cyprus
     
  4. pcpanik

    pcpanik Celler Dickstiel

    Dabei seit:
    27.01.08
    Beiträge:
    803
    Was möchtest Du wissen?
    Wie Du mit dem VMware Converter arbeitest?

    Du kannst ihn auf dem Quellsystem installieren, starten und dann entscheiden, was für einen Typ VM Du aus dem System machen möchtest.
    Deine Wahl sollte "other" und danach eine typische VMware Server/Workstation/Player Maschine sein.
    Du kannst eine wachsende oder bereits in voller Größe angelegte virtuelle HDD erstellen.
    Die dabei generierten VMDK Dateien kannst Du in 2GB Stücke teilen lassen (Praktisch für den Transport auf DVDs/USB Sticks etc)
    Als Speicherort Ort musst Du entweder eine andere Partition des Systems selbst oder als Empfehlung eine externe HDD wählen. (Willst Du eine andere Partition nehmen, musst Du über den Netzwerkpfad arbeiten, Bsp.. D:\freigabe)
    Wenn es einen Haken gibt, der "Install VMware tools" heißt, setze ihn, hiermit werden die notwendigen Treiber installiert.
    Dieser Schritt kann auch später in VMware Fusion nachgeholt werden, ist aber dringend notwendig.


    Als Ergebnis erhältst Du dann ein Verzeichnis mit VMDK Dateien und einer vmx Datei.
    Diese kopierst Du dann auf den Mac in das gewünschte Verzeichnis.
    Mit VMware Fusion und auch Parallels kannst Du sie nun benutzen.
    Ob Virtual Box damit umgehen kann vermag ich nicht so adhok zu sagen.
     
  5. waschbär123

    waschbär123 Echter Boikenapfel

    Dabei seit:
    26.04.08
    Beiträge:
    2.353
    virtualbox arbeitet mit vdi datein, von daher wird das nicht funktionieren.
     
  6. pcpanik

    pcpanik Celler Dickstiel

    Dabei seit:
    27.01.08
    Beiträge:
    803
    Habe mal das Manual quer gelesen, Seite 66:

    Sollte also gehen. ;)
     
  7. cyprus

    cyprus Gala

    Dabei seit:
    17.04.08
    Beiträge:
    51
    Ja das hatte ich in dem VirtualBox Maunal auch gelesen. Angeblich soll man auch den Fenster Modus abstellen können damit man quasi das System im System hat und nicht ständig wechseln muß. Nun denn ich danke erst mal ich denke ich hab die wichtigsten Sachen kapiert und da meine FP groß genug ist werd ich´s mal mit beidem Testen.
    Ich sag dann wies gelaufen ist. Heute mach ich erstmal Datensicherungen bevor ich noch irgend was verbocke und dann dumm gucke.

    Lieben Dank für eure Hilfe.

    Cyprus
     
  8. cyprus

    cyprus Gala

    Dabei seit:
    17.04.08
    Beiträge:
    51
    Also mal ein Zwischenbericht Ich hab mir den Converter auf dem Win System installiert. Mit der Einstellung "other" wollte er eine Quelldatei haben welche ich beim besten Willen nicht gefunden habe weil ich es einfach nicht verstanden habe. Ich hab dann eine Workstation erstellt. Leider gabs keinen Haken für die VMware Tools. Ne VMDK Datei zu erstellen war recht einfach. ich habe als Speicherort ne externe HDD angegeben. Und nach ca. 1,5 h war das erledigt. Dann hab ich die Datei rüber auf den Mac kopiert. VMware Fusion gestartet und auch hier leitet der Bildschirm einen zügig durch die Einbindung. Dann kam der 1. Start. Fehlermeldung die ATI Treiber wurden nicht gefunden.
    Win fährt runter und rauf Fehlermeldung. Ich hab dann versucht über die Befehlsleiste die VMWARE Tools nachzuinstallieren. Leider funzt das nicht.
    Das System fährt ständig rauf und runter. Die Hilfe ist nicht hilfreich. Schade
    Test2 mit Virtualbox verläuft ähnlich. Leicht einzubinden aber das System fährt erst gar nicht rauf.

    Kleine Vorabfrage, vielleicht weiß das jemand könnte eins meiner Probleme darin begründet sein das mein altes System im NTFS Format vorliegt?

    Wenn sonst noch jemand ne Idee hat her damit.

    Lieben Dank und frohes Schaffen

    Cyprus
     
  9. pcpanik

    pcpanik Celler Dickstiel

    Dabei seit:
    27.01.08
    Beiträge:
    803
    Mit NTFS hat das nichts zu tun. Fährt es wieder herunter und schaltet sich ab, oder macht es einen unerwarteten, oder einen sauberen Neustart?
    Starte das XP mal im abgesicherten Modus (beim Start F8 drücken, dann "Abgesichert starten" auswählen).
    Was passiert hier? Wenn Du angemeldet bleibst, deinstalliere den ATI Treiber.
    Frage am Rande: Was für eine Lizenz verwendest Du? Home oder Prfoessional? OEM bzw. Systembuilder oder eine Retail (Boxed) Version?

    Meine Vermutung geht dahin, dass XP den "Umzug" mitbekommen hat und Dich sofort wieder abmeldet, oder aber einfach "abschmiert" und neu bootet.
    Aber wie gesagt, dass ist nur eine Vermutung.
     
  10. cyprus

    cyprus Gala

    Dabei seit:
    17.04.08
    Beiträge:
    51
    Okay ich seh schon es gibt viele Möglichkeiten warum es nicht funktionieren kann. Hier mal die Daten.:
    Win XP PRO SP 2 OEM
    Acer Notebook Travelmate 600

    Das Host System MacBook Pro 10.5.2

    Das Windows System startet mit folgender Fehlermeldung vor dem eigentlichem Booten:
    Sie verwenden das Gastbetriebssystem Windows XP und verfügen über mindestens ein virtuelles SCSI-Gerät in der virtuellen Maschine.
    Dazu wird eine Seite genannt mit einem Treiber leider gibs da nix.

    Dann startet Windows und gibt nachdem das System zu sehen ist ein Meldung über einen mangelnden ATI Treiber raus und das das System jetzt wieder runtergefahren wird und so geht in einer Tour.

    Ich hab jetzt nochmal den Converter laufen lassen. Es gab doch einen Haken für die Tools den hab ich angeschaltet. Und die neue VMDK datei wurde eingebunden im Host gleiches Problem.

    Ich hab versucht in den abgesicherten Modus zu kommen aber ich krieg über die F8 Taste nur die Spaces aufgerufen. Obwohl ich in der Systemsteuerung von OSX bereits umgestellt habe auf Funktionstasten.

    @ pcpanik: Lieben Dank das du mich so fundiert unterstützt. Die Dokumentation von VMWare Fusion ist echter Schrott.

    Lieben Gruß

    Cyprus
     
  11. pcpanik

    pcpanik Celler Dickstiel

    Dabei seit:
    27.01.08
    Beiträge:
    803
    Du musst mit der Maus in das Fenster vom Fuison klicken, wenn Du die XP VM gestartet hast, um den Focus von Maus und Tatstatur dort zu haben ;)
    Ansonsten reagiert natürlich das OS X auf Deine Eingaben.

    Ein anderer Weg wäre doch mal den ATI treiber zu deinstallieren, bevor Du eine VM daraus mit dem Converter kreierst.
     
  12. cyprus

    cyprus Gala

    Dabei seit:
    17.04.08
    Beiträge:
    51
    Also nachdem ich Spaces deaktiviert habe und schnell genug ins Fenster geklickt habe hätte nun eigentlich die F8 Taste funktionieren müssen. doch leider komm ich nicht in den abgesicherten Modus.
    Was Vorschlag nr2 betrifft so möchte ich das nicht tun da System derzeit stabil läuft und im Moment noch sehr wichtig ist.
    Gibt es noch eine andere Möglichkeit? :-c
     
  13. pcpanik

    pcpanik Celler Dickstiel

    Dabei seit:
    27.01.08
    Beiträge:
    803
    Systemeinstellung "Tatstaur und Maus" öffnen und mal nachschauen, ob Du die Funktionstasten oder die Hardwaresteuerung aktiviert hast fiele mir jetzt noch ein.
     
  14. cyprus

    cyprus Gala

    Dabei seit:
    17.04.08
    Beiträge:
    51
    Ok ich habs geschaft. In den Systemsteuerung ist in der Tastaturbelegung F8 nochmal mit Spaces verbunden. Haken weg und dann ging auch der abgesicherte Modus. So nun kommt das nächste Problem.
    A) wie werd ich den ATI Treiber los und
    B) wo krieg ich nen passenden her

    anscheinend kann ich auf die VMWare Tools nicht bauen. Deren Download wird angeblich jedesmal gestartet. Aber das führt zu nix.
    Wenn ich das hier doch noch mal schaffen sollte mach ich ne Tut drauß ohne Hilfe ist das echt nicht zu bewältigen.

    Lieben Gruß

    Cyprus
     
  15. pcpanik

    pcpanik Celler Dickstiel

    Dabei seit:
    27.01.08
    Beiträge:
    803
    Wenn Du abgesichert gestartet hast über den normalen Weg die ATI Treiber deinsatllieren (idR. über Software -> ATI Deinstallationsassistent)

    Du musst die VMware Tools installieren, daran führt kein Weg vorbei.
    Es ist auch eigentlich ganz einfach: In der Programmleiste unter "VM" den Eintrag "VMware Tools installieren" wählen.
    Nun wird im Gastsystem in das virtuelle CD ROM eine CD eingelegt und die Setup.exe gestartet.
    Geschieht dies nicht automatisch begib Dich im Windows Explorer zu CD und starte die Setup.exe selbst.
     
  16. cyprus

    cyprus Gala

    Dabei seit:
    17.04.08
    Beiträge:
    51
    Okay der ATI Treiber ist deinstalliert. War nicht so einfach da sich noch Reste in der Regestry befanden.
    Jetzt startet der Rechner ohne Fehlermeldung. Und stürzt nun später ab. Das nenn ich doch mal einen Erfolg.

    Während das System an ist bin ich in den VMWare Reiter gegangen. Da wurde der Befehl VMWARE Tool installation abbrechen angezeigt. Anscheinend bleibt das System nicht lange genug oben um die Tools zu laden. Gibs da auch einen Zufuß Weg?

    So langsam glaube ich an das Gelingen. pcpanik du hast dir echt nen Freibier verdient. ;)

    Lieben Dank

    Cyprus
     
  17. pcpanik

    pcpanik Celler Dickstiel

    Dabei seit:
    27.01.08
    Beiträge:
    803
    Da ich Bier verabscheue tuts auch ein Karma Punkt ;)

    Normaler weise ist das mit dem Erstellen einer VMware kein so großes Problem und die Kisten laufen sehr zuverlässig.
    Ich schlage vor, Du startest noch einmal abgesichert und schaust in das Ereignisprotokoll, warum das XP Abstürzt.
    (Rechtsklick auf Arbeitsplatz -> Verwalten -> Ereignisanzeige > System

    Dann rate ich Dir dazu unnötige Software die für das Notebook gebraucht wird (z.B Touchpad, Shock Sensor, PowerSaving Utilites etc.) zu deinstallieren.

    Das SP3 schadet sicher auch nicht.
     
  18. cyprus

    cyprus Gala

    Dabei seit:
    17.04.08
    Beiträge:
    51
    Geht mir genauso aber ich wollte nicht uncool sein :cool:
    Karma Punkt ist schon beantragt.

    Anscheinend bin ich mal wieder das eine Prozentchen wos´nicht geht. Nun denn Schicksal.

    Keine Einträge!

    Alles weg!

    Haben sich jetzt tatsächlich einmal angefangen zu installieren. Abbruch wg Abgesichertem Modus!

    Bitte legen Sie eine CD ein.

    Ich krieg zu beginn immer noch die Meldung wegen eines nicht unterstütztem SCSI Treiber. Kann man auf nem Mac eigentlich nen Screenshot machen. Das ist unter Win so simpel aber die MacHilfe schweiget dazu. Dann könnte ich dir mal die Meldung zeigen.

    Liebe Grüße

    Cyprus
     
  19. pcpanik

    pcpanik Celler Dickstiel

    Dabei seit:
    27.01.08
    Beiträge:
    803
    Drücke cmd+shift+3 für einen Screenshot der direkt auf dem Schreibtisch landet oder cmd+shift+4 für einen Ausschnitt Screenshot ;)

    Vielleicht sollten wir mal von gaaanz vorn mit der Erstellung der VM beginnen, damit Du alle Optionen richtig setzt.

    Bei Zeit und Lust kann ich Dir ja mal per team viewer helfen. hat Dein Notebook Internet Zugang?
     
  20. cyprus

    cyprus Gala

    Dabei seit:
    17.04.08
    Beiträge:
    51
    Das würdest du tun? Ich bin ganz baff!
    Beide NB´s haben nen Netzzugang. Wann hast du Zeit?
    Äh ich bin noch irgendwie geplätted. Nicht das ich das nicht schon für andere getan hätte aber mir ist das noch nie passiert. Du arbeitest wirklich an deinem Karma.

    Lieben Gruß

    Cyprus
     

Diese Seite empfehlen