1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Valid CSS / XHTML - ist unsere Seite ein Misthaufen?

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von Von Bremen, 10.12.08.

  1. Von Bremen

    Von Bremen Doppelter Prinzenapfel

    Dabei seit:
    02.10.04
    Beiträge:
    438
    Hilfe. Ich habe gerade unsere Webseite http://blog.freaks.tv/ versucht zu validieren, und brach relativ schnell in Gelächter aus, als http://validator.w3.org/ mir sowohl für CSS als auch für XHTML derbe viele (ich denke so um die 180) Fehler ausspuckte. Da ich nicht im Traum die Zeit und die Lust dazu habe, die zu korrigieren stellt sich mir nun folgende Frage: Ist diese Einstellung dämlich (weil zum Beispiel kein Mensch die Seite gescheit angezeigt bekommmt) oder folgerichtig (mir und den meisten mir bekannten Menschen wird die Seite ja richtig angezeigt).

    Und Bonus-Frage: Gibt es nicht irgendeine Webseite, die den (falschen) Code einliest
    und nach wenigen Sekunden den (richtigen) Code wieder ausspuckt? Danke.
     
  2. duffman

    duffman Galloway Pepping

    Dabei seit:
    29.11.07
    Beiträge:
    1.361
    Die meisten Fehler treten ja nur durch die Javascript-Aufrufe auf. Am Design besteht also so gesehen kein Problem, das sollte soweit in allen Browsern funktionieren.

    Viele Fehler sind beispielsweise ein vergessener / etc. also etwas wirklich gravierendes sehe ich persönlich auf die Schnelle nicht. Allerdings bin ich nun auch nicht so der Profi. Du kannst allerdings mit dem Validation Output sehr gut und schnell die Fehler beheben. Eine Seite, welche den verbesserten Quelltext ausgibt, gibt es glaube ich nicht, beziehungsweise keine Seite, welchen Fehlerfreien Code generiert. Meist ist das Ergebnis dann eher schlecht als Recht (siehe Dreamweaver & Co.)
     
  3. Von Bremen

    Von Bremen Doppelter Prinzenapfel

    Dabei seit:
    02.10.04
    Beiträge:
    438
    Vielen Dank für deine Einschätzung!
     
  4. AKubi

    AKubi Alkmene

    Dabei seit:
    08.12.08
    Beiträge:
    30
    Mal ein kleiner Tipp, im body kein CSS via <style ... und schaut mal das Ihr in Tags keine Grossen Buchstaben verwendet.

    Wegen Javascript schaut euch mal CDATA an, alles in allem ist das sicherlich in den Griff zu bekommen.
     
  5. Von Bremen

    Von Bremen Doppelter Prinzenapfel

    Dabei seit:
    02.10.04
    Beiträge:
    438
    Danke. Habe es jetzt geschafft, von ca. 180 Fehler auf 2 zu reduzieren :-D, diese bekomme ich aber einfach nicht in den Griff. Es hat was mit dem von AKubi bereits genannten "im Body kein CSS (<style>)" zu tun: Hier ansehen

    Und dann wären da noch die 5 CSS-Fehler: Hier ansehen...

    Ich wäre euch wirklich dankbar für jede Hilfe...
     
  6. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Schau Dir mal das Gallery-Plugin an - das scheint dafür verantwortlich zu sein.

    <edit>Hilfreich fürs Debuggen in Safari:

    • Eingeschalteter Developer-Mode (Einstellungen -> Erweitert -> Develop einschalten) In dem Menü ist insbesondere der Eintrag »Webinformationen einblenden« sowie das Kontextmenü »Elementinformationen anzeigen« sehr hilfreich
    • PlugIn SafariTidy installieren - gibt in der eingeschalteten Statusleiste schon Hinweise auf die Validität des Codes
    • PlugIn SafariSource installieren - färbt die Quelltextanzeige (⌥⌘-U) nach Vorgabe ein, liest sich einfach hübscher.
    </edit>
     
    #6 stk, 11.12.08
    Zuletzt bearbeitet: 11.12.08
  7. Von Bremen

    Von Bremen Doppelter Prinzenapfel

    Dabei seit:
    02.10.04
    Beiträge:
    438
    So, die .CSS-Fehler sind nun auch weg. Was die beiden Fehler im XHTML angeht, bin ich jedoch noch immer nicht weiter. Es scheint -wie stk vermutet hat- das "Gallery"-Plugin zu sein, aber wie zum Geier kann ich es ändern? Wenn ich "nur" den vom Validator als fehlerhaft markierten Code:
    Code:
    <style type='text/css'>
    (dürfte im "media.php" im "wp-includes"-Ordner liegen) rausnehme, zerhackt es mir die Seite, ...

    Noch jemand?
     
  8. mscsnoopy

    mscsnoopy Becks Apfel (Emstaler Champagner)

    Dabei seit:
    12.11.07
    Beiträge:
    338
    Den kompletten Style-Tag einfach in den Header schreiben klappt nicht?
     
  9. Von Bremen

    Von Bremen Doppelter Prinzenapfel

    Dabei seit:
    02.10.04
    Beiträge:
    438
    Habe ich gerade versucht, aber entweder habe ich es falsch gemacht, oder es geht nicht... Es ist zum Verzweifeln (Ich habe das Gefühl ich bekomme auf-Teufel-komm-raus keine valide Seite hin...!)
     
  10. Von Bremen

    Von Bremen Doppelter Prinzenapfel

    Dabei seit:
    02.10.04
    Beiträge:
    438
    YESYESYOAH!! Ich habe mich geirrt, DU hattest Recht! Ich habe bei meinem letzten Copy-Paste-Versuch eine Zeile übersehen (ich Idiot), und diese jetzt wieder richtig eingefügt - ES GEHT!

    VIELEN DANK EUCH ALLEN! Und jetzt das Siegel ;)
     
  11. mscsnoopy

    mscsnoopy Becks Apfel (Emstaler Champagner)

    Dabei seit:
    12.11.07
    Beiträge:
    338
    Prima! :) Glückwunsch ;)
     
  12. mscsnoopy

    mscsnoopy Becks Apfel (Emstaler Champagner)

    Dabei seit:
    12.11.07
    Beiträge:
    338
    ... und jetzt die Meister-Disziplin: von xHTML 1.0 Transitional zu xHTML 1.0 strict ;)
     
  13. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    SafariTidy motzt noch ;)
     

    Anhänge:

  14. Von Bremen

    Von Bremen Doppelter Prinzenapfel

    Dabei seit:
    02.10.04
    Beiträge:
    438
    Immer noch? Bitte check es jetzt noch einmal - ich konnte mir das Plugin irgendwie nicht installieren... MIST!
     
  15. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    nur 2 - die beiden leeren Elemente:
    Code:
    				<div id="headerimg">
    					<h1><a href="http://blog.freaks.tv"><font color="#333333" style="text-decoration: none">Freakbasis München</font></a>
    					</h1>
    					<div class="description">[COLOR="DarkOrange"]<font color="#07293C"></font>[/COLOR]</div>
    				</div>
    			</div>
    			<hr />        <div id="content" class="narrowcolumn">
    
    
    und
    Code:
    
    [COLOR="DarkOrange"]<p></p>[/COLOR]
    
    </body>
    
     
  16. Von Bremen

    Von Bremen Doppelter Prinzenapfel

    Dabei seit:
    02.10.04
    Beiträge:
    438
    Vielen Dank, stk. Das erste Element habe ich "vernichtet", es war, da es keine "Description", Beschreibung, Untertitel gibt, bzw. dieser im Image eingebunden ist, ohnehin sinnlos. Bei dem <p></p> -Element im Footer ist das schwieriger, da die Seite sonst dem untern "Browserrand" aufliegt, sprich, ich brauche einen Abstandhalter. Hast du einen Tipp?
     
  17. mscsnoopy

    mscsnoopy Becks Apfel (Emstaler Champagner)

    Dabei seit:
    12.11.07
    Beiträge:
    338
    ein <br /> ? Solang das br in einem <div> drin steht, sollte es klappen :)
     
  18. Von Bremen

    Von Bremen Doppelter Prinzenapfel

    Dabei seit:
    02.10.04
    Beiträge:
    438
    Seas mscsnoopy, also <br /> klappt auch, hat den gleiche Effekt wie <p></p>, nur dass ich es definitiv nicht ins <div> setzen kann... weil sonst zerhackt es wieder die "Blog-Grenze"... Wenn das <br /> allerdings auch ausserhalb stehen kann, ohne das es einen Fehler gibt, hast du gerade zum 2. Mal die Lösung gefunden!
     
  19. mscsnoopy

    mscsnoopy Becks Apfel (Emstaler Champagner)

    Dabei seit:
    12.11.07
    Beiträge:
    338
    oder schreib in das <p> ein <br />, weiß nur grad nicht, ob das valid ist o_O

    <br /> muss innerhalb irgendwas stehen... also nicht nur im body, glaub nicht mal nur ein div reicht aus o_O Vielleicht klappt es ja mit <p><br /></p>


    EDIT: jetzt ist es doch grad valid?
     
  20. Von Bremen

    Von Bremen Doppelter Prinzenapfel

    Dabei seit:
    02.10.04
    Beiträge:
    438
    Stimmt, nur das war es vorher (laut w3.org) auch, bis dann stk meinte, bei seinem "SafariTidy" würde das <p></p> als nicht valid eingestuft. Daher habe ich jetzt das von dir vorgeschlagene <br /> gelassen und warte auf deine Rückmeldung ;) Danke übrigens für die Anfrage, gerne!
     

Diese Seite empfehlen