1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

Umlaute & Smultron

Dieses Thema im Forum "WYSIWYG-Editoren" wurde erstellt von wapplegraph, 27.05.08.

  1. wapplegraph

    wapplegraph Normande

    Dabei seit:
    12.04.06
    Beiträge:
    571
    Hallo

    Ich habe bis jetzt immer Text aus Word-Dokumenten via Dreamweaver in eine Webseite eingebaut und er hat mir alle Zeichen ohne Probleme dargestellt.

    Nun habe ich begonnen mit Smultron zu programmieren und als ich jetzt wieder Text von einem Word-Dokument einfügen musste, werden alle "Nichtstandart-Zeichen" falsch dargestellt.

    Ich bin frustriert.

    Meine php Seite ist mit ISO-8859-1 formatiert. Ändere ich es auf utf-8, so kommt das neue gut und das alte schlecht!

    Hillfe!!! Hier noch die Seite, Das neue wäre hier.

    wapplegraph
     
  2. Hairy

    Hairy Sonnenwirtsapfel

    Dabei seit:
    07.08.07
    Beiträge:
    2.397
    Vermutlich speichert Smultron standardmäßig mit UTF-8 (was auch gut so ist).
    Einfache Lösung: Dies auf ISO-8859-1 umstellen.
    Bessere Lösung: Die alten Dateien ebenfalls mit UTF-8 speichern. Plädoyer für UTF-8 | UTF-8 Umstieg
     
  3. wapplegraph

    wapplegraph Normande

    Dabei seit:
    12.04.06
    Beiträge:
    571
    Merci

    Jetzt klappt es. Musste zuerst suchen, wo man die Textkodierung unter Smultron ändert (Text => Textkodierung)

    wapplegraph
     
  4. wapplegraph

    wapplegraph Normande

    Dabei seit:
    12.04.06
    Beiträge:
    571
    Hallo

    Ich habe nun noch ein Problem: unter dem sch... IE zeigt er mir gewisse Leerzeichen als Quadrate an. Schaue ich im Quelltext nach, so liegt an dieser Stelle ein komisches Leerzeichen vor, welches 2x gelöscht werden muss, damit es verschwindet, aber nicht einfach ein doppeltes.

    Wie kann ich dies beheben?!?!?!?


    Merci wapplegraph
     
  5. Bajuware

    Bajuware Oberösterreichischer Brünerling

    Dabei seit:
    23.04.08
    Beiträge:
    707
    gewisse Leerzeichen heißt was ? Geschützte ?   ?
     
  6. wapplegraph

    wapplegraph Normande

    Dabei seit:
    12.04.06
    Beiträge:
    571
    Ja das weiss ich auch nicht, ich sehe nichts. Muss einfach zweimal auf die Delete-Taste drücken, damit es verschwindet.
     
  7. wapplegraph

    wapplegraph Normande

    Dabei seit:
    12.04.06
    Beiträge:
    571
    Hallo

    Kann mir niemand helfen? Kommen min. zwei Leerzeichen vor, so zeigt der IE irgend ein komisches Zeichen an.
     
  8. Bajuware

    Bajuware Oberösterreichischer Brünerling

    Dabei seit:
    23.04.08
    Beiträge:
    707
    Ja wo hab ich denn meine Glaskugel :-x
    Gib uns doch mal nen Link, da du selbst nicht beschreiben kannst weshalb, dann können wir das möglicherweise ... sogar sicher.
     
  9. wapplegraph

    wapplegraph Normande

    Dabei seit:
    12.04.06
    Beiträge:
    571
    Hallo

    Unter diesem Link, findet ihr die Fehler.

    Bei mir sind an den fehlerhaften Stellen einfach mehrere Lehrzeichen oder Zeilenumbrüche.
     
  10. Hairy

    Hairy Sonnenwirtsapfel

    Dabei seit:
    07.08.07
    Beiträge:
    2.397
    Ein Tabellenlayout :eek:
    Lange her dass ich sowas gesehen habe :-D

    Ich vermute dass hier der Hund begraben liegt.
     
  11. wapplegraph

    wapplegraph Normande

    Dabei seit:
    12.04.06
    Beiträge:
    571
    Mhm wo siehst du bitte hier ein Tabellenlayout? Auf der Home Site hat es eine Tabelle aber es ist kein Tabellenlayout!!!!!!!!!!

    Wie sieht es mit meinem Problem aus?
     
  12. Bajuware

    Bajuware Oberösterreichischer Brünerling

    Dabei seit:
    23.04.08
    Beiträge:
    707
    Joah, wiso machst du denn 3mal ein Leerzeichen um nen Abstand zu definieren ? Hier liegt der Hund begraben. Wenn schon, dann mach ein "sicheres Leerzeichen", also den "Space-Raum" raus und ein   rein.

    Besser wäre allerdings, den Wörtern eine klasse zu geben und mit padding-left einrücken.

    Nachtrag:
    Einen Block-Text selbst mit Leerzeichen gestalten ist unnötig. Dafür gibt es :
    text-align: justify;
     
  13. wapplegraph

    wapplegraph Normande

    Dabei seit:
    12.04.06
    Beiträge:
    571
    Ja das habe ich nicht so gemacht, mein "Kunde" gibt mir die Texte und ich kopiere sie nur herein, und dann hat es halt einmal 2 Leerzeichen. Ich definiere Blocksatz sicher nicht mit Leerzeichen.

    Wie bringe ich jetzt diese vielen Leerzeichen raus? Jeden Text durchzulesen kann Jahre dauern. Gibt es keine Methode?
     
  14. Bajuware

    Bajuware Oberösterreichischer Brünerling

    Dabei seit:
    23.04.08
    Beiträge:
    707
    Ja sorry, aber wenn das dein "Kunde" ist, dann solltest du in der Lage sein auch solche Probleme zu
    lösen. Wie find ich denn das o_O Mal ganz ehrlich aber das zählt ja noch nicht mal zum 1x1 des Webdesign.
     
  15. wapplegraph

    wapplegraph Normande

    Dabei seit:
    12.04.06
    Beiträge:
    571
    Was zählt nicht zum 1x1 des Webdesigns?

    Gibt es keine Möglichkeit mit der Textkodierung, dass er mir zu viele Whitespaces ignoriert?
     
  16. nilsk

    nilsk Granny Smith

    Dabei seit:
    06.08.08
    Beiträge:
    15
    Smultron will Textcodierung nicht ändern ... warum nicht?

    Liebe Apfel-Experten,

    ich erstelle gerade mein erstes PHP-Dokument für ein Email Formular.
    Arbeite mit "Smultron".

    Dabei habe ich den Code von einem Freund variiert und habe jetzt die "Head"-Daten
    ausgetauscht, damit meine CSS aus dem Joomla greifen können, das ich verwende.

    Allerdings kann ich diese PHP-Datei nun in Smultron nicht mehr speichern!

    Fehlermeldung:
    "Das Dokument kann nicht mehr in der ursprünglichen Codierung „Westeuropäisch (DOS Latin 1)“ gesichert werden.
    Bitte wählen Sie eine andere Codierung (z. B. UTF-8).
    "

    Die Texcodierung steht auf "Westeuropäisch (ISO Latin 1)" ... und das ist leider auch die
    einzige Option, die im Smultron sichtbar ist.


    Kann mir jemand sagen, wo der Fehler liegt?! ... Oder braucht ihr einen Code? ...

    Wäre klasse, wenn jemand helfen kann.

    Grüße
    Nils
     

Diese Seite empfehlen