1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Umlaute im Terminal

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von juancarlos, 05.12.06.

  1. juancarlos

    juancarlos Golden Delicious

    Dabei seit:
    27.02.06
    Beiträge:
    6
    Hi,

    das Terminal-Programm ist in der Standardeinstellung nicht in der Lage Umlaute auch als solche darzustellen. Ich habe in verschiedenen Foren verschiedene Aussagen zu diesem Thema gelesen, manches funktionierte halb anderes gar nicht. Ich habe hier für euch mal eine funktionierende Lösung zusammengetragen.

    Also,für die, die es interessiert, hier die Anleitung. Ich habe sie getestet, und soweit funktioniert sie auch.

    1) Eine Datei mit dem Namen ".inputrc" im Home-Verzeichnis erstellen.
    2) Folgenden Inhalt in die Datei schreiben:
    set input-meta on
    set output-meta on
    3) Datei abspeichern
    4) Folgenden Inhalt in die .bash_profile oder .profile eintragen:
    export LANG="de_DE.UTF-8"
    5) Darauf achten, dass folgende Einstellung im Terminal gesetzt sind:
    a) In Fenstereinstellungen/Emulation ist das Häkchen bei "Nicht-ASCII-Zeichen in Escape-Sequenz umwandeln" gesetzt
    b) In Fenstereinstellungen/Darstellung ist Unicode (UTF-8) als Zeichensatz-Codierung gesetzt

    Soweit so gut. Wenn man nun z.B. "mkdir Änderung" aufruft, wird nach dem Befehl "ls" leider A??nderung ausgegeben. Der Grund dafür besteht darin, dass ls in den Standardeinstellungen nicht druckbare Zeichen, als die die Umlaute gelten, mit mehreren Fragezeichen versieht. Mit der Option "-w" kann dies geändert werden. Also fehlt noch folgender alias unter ".bash_profile" oder ".profile"
    6) alias ll="ls -law"

    Viel Spass
     
  2. zeno

    zeno Lane's Prinz Albert

    Dabei seit:
    05.11.05
    Beiträge:
    4.898
    thx, den Trick mit der .inputrc kannte ich noch nicht - perfekt :D
    Nur is mir gerade beim testen noch was aufgefallen..
    Wenn ich ein paar Umlaute eingeben und die wieder lösche, kann ich wohl durch die Umwandlung in die Escape Sequenzen, in den Prompt selbst reinlöschen. Weißte dafür noch nen Workaround? Okay is nicht so wichtig, is ja nur n Schönheitsfehler, aber wenns einen gäbe - perfekt.
     
  3. pascalC

    pascalC Gast

    Schönheitsoperation: Umlaute in der Console

    Der Workaround (der auch auf Linuxen klappt) :
    $ export LC_ALL=en_GB.UTF-8
    Hab übrigens gehört, dass Leopard (MacOS 10.5) standardmäßig mit Umlauten klarkommt :)
     

Diese Seite empfehlen