1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

Triple Boot: OS X und WinXP laufen, Linux Xubuntu macht Probleme

Dieses Thema im Forum "Linux auf dem Mac" wurde erstellt von ElronBonquist, 12.01.10.

  1. ElronBonquist

    ElronBonquist Jonagold

    Dabei seit:
    17.01.08
    Beiträge:
    18
    Hallo Leute,

    habe mir vor ein paar Tagen ein Triple Boot nach diesem How-to eingerichtet. Mac OS X und Windows laufen ohne Probleme, Linux Xubuntu wird ordnungsgemäß gebootet, macht jedoch folgende Schwierigkeiten:

    1. Im Festplattendienstprogramm wird die Linunx-Partition gar nicht erkannt, es erscheit nur die Host-Partition und die Windows-Partition. Frage: ist das normal?

    2. Mein laienhafter Blick sagt mir, dass Xubuntu nicht hinreichend konfiguriert ist: Wlan funktioniert nicht, die Oberfläche ist halb auf Deutsch, halb auf Englisch usw. Frage: wo bekommt man die ganzen Treiber her und wie kann ich das System am besten einrichten (bin ein Linux-Greenhorn)?

    Freu mich auf Eure Antworten...

    Elron
     
  2. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.893
    Nein, du hast die Partitionierung verhunzt.
    Folgen: unabsehbar, hohe Gefahr für Datenverlust.
     
  3. benMac

    benMac Goldparmäne

    Dabei seit:
    07.01.10
    Beiträge:
    563
    1. nein das ist nicht normal
    2. das einzelne kompotneten wie wlan nicht funktionieren ist "normal". an meinem alten notebook einem toshiba sattelite hat unter linux nie der Audioeingang/-ausgang funktioniert. Wenn du dich mit linux nicht auskennst und es nur mal ausprobieren wolltest hätte ich es auf einer virtuellen maschine laufen lassen. da ist die gefahr eines fehlers wesentlich geringer.
     
  4. ElronBonquist

    ElronBonquist Jonagold

    Dabei seit:
    17.01.08
    Beiträge:
    18
    okay, das sind ja keine guten neuigkeiten!
    ein betriebsystem über eine virtuelle maschine laufen lassen kommt für mich nicht in frage! schon ausprobiert->läuft beschissen->kann nichts mit anfangen...
    @rastafari: wie kann ich das maleur beheben? ist es überhaupt möglich das problem zu beheben?
     
  5. ElronBonquist

    ElronBonquist Jonagold

    Dabei seit:
    17.01.08
    Beiträge:
    18
    die frage richtet sich natürlich nicht nur an rastafari...

    hier die ausgabe des Partition Inspector:

    *** Report for internal hard disk ***

    Current GPT partition table:
    # Start LBA End LBA Type
    1 40 409639 EFI System (FAT)
    2 409640 624041735 Mac OS X HFS+
    3 624303880 853469895 EFI System (FAT)
    4 853469896 976773127 Basic Data

    Current MBR partition table:
    # A Start LBA End LBA Type
    1 1 409639 ee EFI Protective
    2 409640 624041735 af Mac OS X HFS+
    3 * 624303880 853469895 83 Linux
    4 853469896 976773127 07 NTFS/HPFS

    MBR contents:
    Boot Code: Unknown, but bootable

    Partition at LBA 40:
    Boot Code: None (Non-system disk message)
    File System: FAT32
    Listed in GPT as partition 1, type EFI System (FAT)

    Partition at LBA 409640:
    Boot Code: None
    File System: HFS Extended (HFS+)
    Listed in GPT as partition 2, type Mac OS X HFS+
    Listed in MBR as partition 2, type af Mac OS X HFS+

    Partition at LBA 624303880:
    Boot Code: GRUB
    File System: ext3
    Listed in GPT as partition 3, type EFI System (FAT)
    Listed in MBR as partition 3, type 83 Linux, active

    Partition at LBA 853469896:
    Boot Code: Windows NTLDR
    File System: NTFS
    Listed in GPT as partition 4, type Basic Data
    Listed in MBR as partition 4, type 07 NTFS/HPFS
     
  6. solarix

    solarix Alkmene

    Dabei seit:
    27.10.09
    Beiträge:
    31
    Das halte ich fuer ein Geruecht das eine virtuelle Maschine beschissen läuft.

    Kommt natuerlich auf die Hardware an. Aber bei mir läuft das auf meinem Macbook mit 4 GB RAM recht ordentlich. Mit 2GB RAM kann man auch flüssig arbeiten wenn man eine VM am Rennen hat.

    Linux läuft in den VMs eigentlich sowieso locker flockig.

    Vielleicht solltest Du der Option Virtuelle Maschine doch noch eine Gelegenheit geben.

    Verwende selbst Virtual Box um Solaris Test instanzen zu fahren.

    Ein Multiboot Environment ist aus meiner heutigen Sicht die klar schlechtere Lösung. Außerdem haben die Virtualisierungsprodukte sehr zugelegt in den letzten 24 Monaten.
     
  7. ElronBonquist

    ElronBonquist Jonagold

    Dabei seit:
    17.01.08
    Beiträge:
    18
    Ich denke, dass dieses Thema in einem anderen Thread diskutiert werden sollte, trotzdem, danke für die Info...
    Ich bleibe beim Triple Boot und würde gerne zurück zu meiner Frage kommen: Ist mein Problem mit der verhunzten Partitionierung zu lösen?
     
    #7 ElronBonquist, 12.01.10
    Zuletzt bearbeitet: 12.01.10
  8. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.893
    Bist scheinbar noch mal glimpflich weggekommen.
    Boote von der OS X System-DVD und öffne dort ein Terminal:
    Code:
    [SIZE="-1"]d="/dev/disk0";
    alias u="diskutil unmountDisk $d";
    u && gpt remove -i 3 $d;
    u && gpt add -i 3 -b 624303880 -t linux $d;
    u && gpt label -i 1 -l "EFI System Partition" $d;
    u && gpt label -i 2 -l "Mac OS X   HFS+J   /" $d;
    u && gpt label -i 3 -l "GNU/Linux   ext3   /" $d;
    u && gpt label -i 4 -l "Windows NT   NTFS   \\\\.\\C:\\" $d;
     
    # Terminal beenden, Neustart
    [/SIZE]
    (Sollte es da irgendwo zu einer Meldung i.e. "...unmount failed..." kommen, so ist diese entsprechende Zeile bis zum Erfolg zu wiederholen.)

    Der rEFIt Partition Inspector sollte danach die gleiche Ausgabe wie vorher liefern, nur sollte der dritte Eintrag jetzt bei beiden Tabellen auf "Linux" lauten. Damit wird die Partition unter OS X zwar immer noch nicht ladbar sein, aber sie wird wenigstens als unbekannte Partition angezeigt und damit vor unbeabsichtigter Entfernung durch das Festplatten-Dienstprogramm geschützt.
    (Um sie unter OS X auch mounten zu können, brauchst du zB das hier.)
     
  9. ElronBonquist

    ElronBonquist Jonagold

    Dabei seit:
    17.01.08
    Beiträge:
    18
    @Rastafari: danke erstmal für deine mühe, hab alles genauso gemacht, wie du es geschrieben hast... hier die ausgabe vom PI:

    *** Report for internal hard disk ***

    Current GPT partition table:
    # Start LBA End LBA Type
    1 40 409639 EFI System (FAT)
    2 409640 624041735 Mac OS X HFS+
    4 853469896 976773127 Basic Data

    Current MBR partition table:
    # A Start LBA End LBA Type
    1 1 409639 ee EFI Protective
    2 409640 624041735 af Mac OS X HFS+
    3 * 624303880 853469895 83 Linux
    4 853469896 976773127 07 NTFS/HPFS

    MBR contents:
    Boot Code: Unknown, but bootable

    Partition at LBA 40:
    Boot Code: None (Non-system disk message)
    File System: FAT32
    Listed in GPT as partition 1, type EFI System (FAT)

    Partition at LBA 409640:
    Boot Code: None
    File System: HFS Extended (HFS+)
    Listed in GPT as partition 2, type Mac OS X HFS+
    Listed in MBR as partition 2, type af Mac OS X HFS+

    Partition at LBA 853469896:
    Boot Code: Windows NTLDR
    File System: NTFS
    Listed in GPT as partition 3, type Basic Data
    Listed in MBR as partition 4, type 07 NTFS/HPFS

    Partition at LBA 624303880:
    Boot Code: GRUB
    File System: ext3
    Listed in MBR as partition 3, type 83 Linux, active


    ich bin mir nicht sicher, aber ich glaube, es hat sich wenig verändert, oder!?
    verändert hat sich etwas im rEFIt menü: der Linux-Icon ist verschwunden und windows startet auch nicht mehr...
    wie soll ich weiter vorgehen?
     
    #9 ElronBonquist, 12.01.10
    Zuletzt bearbeitet: 12.01.10
  10. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.893
    Du scheinst mir schlicht und ergreifend die 4. Zeile (...gpt add...) verbummelt zu haben.
    Wiederhole die ganze Prozedur, nur ohne die jetzt überflüssige dritte Zeile (...gpt remove...).
    Fehlermeldungen??? Da dürften keine kommen.
     
  11. Bonestruca

    Bonestruca Empire

    Dabei seit:
    17.01.06
    Beiträge:
    88
    was das wlan anbelangt:
    zieh dir erstmal alle verfügbaren updates und versuch dann entsprechende proprietäre treiber (system->hardware oder so) zu aktivieren. so ging es auch auf meinem mb pro 5,1.

    zu der virtuellen maschine kann ich nur sagen, dass ich dort auch performance probleme hatte, weswegen ich mich dann schlussends entschieden hatte es richtig zu installieren. jetzt läufts 1a.
     
  12. ElronBonquist

    ElronBonquist Jonagold

    Dabei seit:
    17.01.08
    Beiträge:
    18
    @Bonestruca: okay, danke, das versuch ich gleich nachdem die partitionsprobleme beseitigt sind...

    @Rastafari: bin jetzt deinen anweisungen gefolgt: 3. zeile (remove) ausgelassen, nach der 4. zeile spuckt mir das terminal folgendes heraus:

    Unmount of all volumes on disk0 was successfull
    gpt add: /dev/disk0: Suspicious MBR at sector 0
    gpt add: /dev/disk0: error: no space available on device

    ... nach der 5-ten...

    Unmount of all volumes on disk0 was successfull
    usage: gpt label -a <-l label | -f file> device ...
    gpt label [-b lba] [-i index] [-s lba] [-t uuid] <-l label | -f file> device ...

    ... nach der 6-ten...

    Unmount of all volumes on disk0 was successfull
    gpt: illegal option -- 1
    usage: gpt label -a <-l label | -f file> device ...
    gpt label [-b lba] [-i index] [-s lba] [-t uuid] <-l label | -f file> device ...

    und dasselbe, wie nach der 6-ten Zeile auch nach folgenden eingaben/zeilen...

    Leider spreche ich diese sprache nicht, kann aber aus einigen englischen begriffen folgern, dass nicht alles glatt gelaufen ist...
    Nach all den aktionen hat sich im rEFIt menü nichts getan, sprich linux fehlt und windows startet nicht...
    was sagst du dazu? was mach ich falsch?

    gruß elron
     
  13. ElronBonquist

    ElronBonquist Jonagold

    Dabei seit:
    17.01.08
    Beiträge:
    18
    @Bonestruca: wie hast du das gelöst? haste 3 betriebssysteme zum laufen gebracht? falls ja, kannste mir da ne gute anleitung empfehlen?
    im netz findet man nichts adäquates...

    braucht man überhaupt rEFIt bootloader? ich glaube, dass alles an diesem booter scheitert, wie läuft das mit dem nativen booter von mac (NTLDR)?
     
  14. Bonestruca

    Bonestruca Empire

    Dabei seit:
    17.01.06
    Beiträge:
    88
    ich hatte es zunächst auch mit refit versucht und das anscheinend beliebte und häufig vorkommende partitionsfiasko erlebt. danach komplette festplatte neu formatiert, dabei eine teil extra für linux angelegt. mit der linux cd gebootet, ubuntu installiert. fertig. booten klappt einfach mit der alt-taste. ohne refit, ohne bootcamp-assistent.

    bzgl. triple boot ist es nach meinen erfahrungen am einfachsten zunächst ganz normal windows über bootcamp zu installieren und dann, in windows linux zu per wubi zu installieren. ohne refit !
     
  15. ElronBonquist

    ElronBonquist Jonagold

    Dabei seit:
    17.01.08
    Beiträge:
    18
    ... siehste, dass der dualboot mit OS X und Linux problemlos ohne rEFIt verläuft habe ich auch schon öfter gehört, ich brauche LEIDER noch in den nächsten 6 monden Windows und komme somit um ein triple boot nicht herum... wenn der spuck vorbei ist, mach ich es auch so wie du...

    aha! das klingt interessant!hab gerade nach wubi gegooglelt...
    es betreibt linux auf einer virtuellen festplatte in der windows umgebung... haste das schon mal ausprobiert? wie ist die performance? ist es auch so ein ressourcenfresser, wie virtual box & co.?
     
    #15 ElronBonquist, 13.01.10
    Zuletzt bearbeitet: 13.01.10
  16. Bonestruca

    Bonestruca Empire

    Dabei seit:
    17.01.06
    Beiträge:
    88
    Habe es selbst noch nicht ausprobiert, kann mir aber vorstellen, dass dort kein Performance verloren geht.
     
  17. an apple a day

    an apple a day Roter Delicious

    Dabei seit:
    05.06.09
    Beiträge:
    92
    Deinstallier doch einfach Linux, erstelle eine neue Partition und installiere es neu. Wenn es dann nicht funktioniert... keine Ahnung

    aaad
     
  18. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.893
    Da in den betreffenden Zeilen überhaupt keine "1" vorkommt, scheinst du mir ein wenig im Krieg mit den Tasten zu stehen. Was solls, dann eben anders. Sauge dir dieses Zip, entpacke es und lege die Datei auf deinen Schreibtisch.
    Dann starte von der DVD und öffne das Terminal.
    Navigiere zu diesem Schreibtischordner (wie der Pfad bei dir genau lautet, weisst nur du selbst):
    Code:
    [SIZE="-1"]cd "/Volumes/[COLOR="Blue"]Macintosh HD[/COLOR]/Users/[COLOR="Blue"]example[/COLOR]/Desktop";[/SIZE]
    Wenn du die Datei mittels einem einfachen...
    Code:
    [SIZE="-1"]ls[/SIZE]
    ... sehen kannst, bist du richtig.
    Dann brauchst du sie nur noch durch ein...
    Code:
    [SIZE="-1"]source rastafix.sh[/SIZE]
    ... zu starten und der Rest geht automatisch, da gibts überhaupt nichts mehr falsch zu machen.

    Warnung an alle Mitleser:
    Das ist kein allgemeines Tool, sondern ein sehr spezieller Patch.
    Funktioniert bei anderen Festplatten definitiv NICHT!
     

    Anhänge:

  19. ElronBonquist

    ElronBonquist Jonagold

    Dabei seit:
    17.01.08
    Beiträge:
    18
    ich installiere jetzt OS X neu und versuche es mit der möglichkeit, die Bonestruca vorgeschlagen hat (OS X -> Boot Camp -> Windows -> Wubi -> Linux)...

    ich danke allen beteiligten für die hilfe!

    mein persönliches fazit: wer sich mit dem partitionieren von festplatten und booten nicht auskennt, sollte von rEFIt die finger lassen!
     
  20. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.893
    Und meins: Wer sich mit dem partitionieren von Festplatten nicht auskennt, sollte von rEFIt jeglichem TripleBoot Gemurkse die Finger lassen!
     

Diese Seite empfehlen