1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Tonspur aus avi entfernen

Dieses Thema im Forum "Videoproduktion" wurde erstellt von addictedtorock, 20.12.09.

  1. addictedtorock

    addictedtorock Granny Smith

    Dabei seit:
    11.12.09
    Beiträge:
    15
    Hi!

    Ich suche vergebens ein App um aus einer avi Datei eine Tonspur zu entfernen ohne neu encoden zu müssen.
    Ein Freund hat mit von VirtualDub erzählt und auch erklärt wie es mit dem Programm funktioniert, aber leider gibts das fürn Apfel nicht.
    Hab auch schon einige Apps (ffmpegX, mpegstream clip, d-vision 3) ausprobiert, aber irgendwie hab ich es da nicht hinbekommen.

    Kann mir bitte jemand weiterhelfen? Besten Dank im Voraus!

    fg
     
  2. walnussbaer

    walnussbaer Roter Stettiner

    Dabei seit:
    04.05.09
    Beiträge:
    960
    Also OHNE neu zu encoden wird die Sache meines Wissens nach nicht funktionieren.
     
  3. addictedtorock

    addictedtorock Granny Smith

    Dabei seit:
    11.12.09
    Beiträge:
    15
    naja unter Windows funktionierts, da wird es doch für OSX auch ein Programm geben?
     
  4. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.905
    MPEG Streamclip (neueste Beta laden)
    Das dazu unter "Extras" angebotene "Save as AVI" Plugin auch installieren.
    Lässt sich der Film mit dem Prog korrekt öffnen?
     
  5. addictedtorock

    addictedtorock Granny Smith

    Dabei seit:
    11.12.09
    Beiträge:
    15
    Ja öffnen funktioniert...so weit so gut.
    Und wie gehts jetzt weiter?
     
  6. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.905
    Gewünschte Audiospur auswählen und "Audiospur löschen".
    Ggf. wiederholen bis nur noch übrig ist was drinbleiben soll.
    "Save as..." und dort Format AVI einstellen. That's it.
     
  7. addictedtorock

    addictedtorock Granny Smith

    Dabei seit:
    11.12.09
    Beiträge:
    15
    hmm...ich kann bei Audiospur nichts auswählen, nur 0?
    Wenn ich mir die Stream Informationen anzeigen lassen will, sehe ich aber beide Tonspuren.
     
  8. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.905
    Malaise.
    Liegt am Spurformat. (Nicht-offizielle Codecs lassen sich nicht ganz so einfach bearbeiten wie normal.)

    Alternative: Hast du QuickTime 7 Pro?
    Dann öffne den Film mit dem Quicktime Player 7.
    Öffne die Filmeigenschaften, markiere die überflüssige Spur, klicke "löschen".
    Speichere den Film als neuen eigenständigen Film (als *.mov)...
    ODER ...exportiere ihn mit dem Preset "Film -> Save as AVI".
     
  9. addictedtorock

    addictedtorock Granny Smith

    Dabei seit:
    11.12.09
    Beiträge:
    15
    Kann ma die Codecs nicht nachinstallieren???

    Nein Quicktime Pro hab ich nicht...glaub ich zumindest, da es ja nicht automatisch bei Snow Leopard dabei ist?
     
  10. neothehacker

    neothehacker Jonathan

    Dabei seit:
    14.03.08
    Beiträge:
    83
    Gleiches Problem hier, hab kein QT 7 Pro. Irgendeiner eine Lösung?
     

Diese Seite empfehlen