1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Texmaker keine Umlaute trotz UTF-8

Dieses Thema im Forum "Officeanwendungen" wurde erstellt von danielsd, 25.03.08.

  1. danielsd

    danielsd Gast

    Hallo liebe Mac User,

    nachdem ich nun vor einigen Monaten von win auf mac umgestiegen bin möchte ich nun auch noch den letzten Schritt wagen und mich mit latex anfreunden. Habe mir hierzu Texmaker runtergeladen und mit Hilfe von Freunden auch eingerichtet bekommen. Nun stehe ich vor dem Problem dass meine Umlaute nicht erkannt werden obwohl die Folgenden Zeilen nicht fehlen:

    \usepackage[utf8]{inputenc}
    \usepackage[ngerman]{babel}

    und auch unter Einstellungen Editor etc. in der 3. Zeile UTF-8 eingestellt

    trotzdem werden ständig beim erneuten öffnen meines Dokuments die Umlaute durch:

    z.B. ÔøΩ oder andere lustige Zeichen ersetzt

    Angezeigt werden sie meist aber gar nicht. Auch Beispieldokumente von Freunden die bei Ihnen (auch mac auch texmaker) liefen, zeigen bei mir beim öffnen die Umlaute 1. gar nicht erst an. 2. kompilieren hinzugefügte Umlaute nicht....

    Nachdem ich nun 2 Tage gegoogelt habe alle Forenbeiträge die ich gefunden habe gelesen und mich zuhauf über arrogante Antworten die letztlich auch nur Unkenntnis ausdrücken geärgert habe, hoffe ich nun vielleicht doch noch jemanden zu finden der mir helfen kann...

    beste Grüße, herzlichen Dank, Daniel
     
  2. Stefan_K

    Stefan_K Morgenduft

    Dabei seit:
    18.05.07
    Beiträge:
    168
    Hallo Daniel,

    für mich sieht das richtig aus, wie Du es gemacht hast. Magst Du vielleicht mal einen weiteren Test machen und meine angehängte Datei öffnen? Sie ist utf8-codiert. Sind die Umlaute erkennbar?
    Weiterhin, kannst Du solch eine Datei hier als Anhang posten, die utf8 sein sollte, jedoch bei Dir nicht korrekt angezeigt wird? Als Gegentest, damit wir uns hier ein Bild machen können und helfen können, die Ursache des Problems einzukreisen.

    Viele Grüße,

    Stefan
     

    Anhänge:

  3. danielsd

    danielsd Gast

    vielen Dank

    zunächst einmal vielen Danke für die Bemühung!!!

    beim öffnen der angehängten Datei mit irgendeinem txt-Editor zeigte sich lustigerweise bei mir als erstes mal folgendes:

    Glück, Spaß, Schönheit.

    Dann eingefügt in Texmaker und korrigiert folgende Fehlermeldung:

    ...lässt sich nicht kopieren... jedenfalls fehlt ihm babel

    dann:

    \documentclass[a4paper,10pt]{scrartcl}
    \usepackage[ngerman]{babel}
    \usepackage[utf8]{inputenc}

    \begin{document}

    Glück, Spaß, Schönheit.

    \end{document}

    FUNKTIONIERT!!!! ;)

    Den Beginn meines alten Dokuments angeschaut.... einige % eingefügt und nun funktioniert es dort auch endlich!!!

    \documentclass[a4paper,11pt]{book}
    %\usepackage[T1]{fontenc}
    %\usepackage{ngerman}
    \usepackage[utf8]{inputenc}
    \usepackage{textcomp,latexsym}
    %\usepackage{amsmath,amsfonts,amssymb}
    \usepackage[ngerman]{babel}
    \usepackage{graphicx}
    \usepackage{amsmath}
    \usepackage{xcolor}
    \setlength{\textwidth}{15cm}
    \setlength{\textheight}{21.5cm}
    \setlength{\hoffset}{0.46cm}
    \setlength{\voffset}{0cm}
    \setlength{\topmargin}{0cm}
    \setlength{\footskip}{2cm}
    \setlength{\oddsidemargin}{0cm}
    \setlength{\evensidemargin}{0cm}
    \renewcommand{\vec}[1]{\text{\boldmath{$ #1 $}}}
    \renewcommand{\Im}[0]{\text{Im}}
    \renewcommand{\Re}[0]{\text{Re}}
    \linespread{1.5}

    => vielen herzlichen Dank, wem diese Beschreibung nun leider keine Hilfe war ist herzlich eingeladen mich noch einmal persönlich anzuschreiben, dann erklär ich es noch einmal ausführlicher und wahrscheinlich auch logischer... bin halt gerade nur am Ende eine Nachtdienstes und daher etwas durcheinander...

    besten Dank, liebe Grüße, Daniel
     
  4. OrangUtanKlaus

    OrangUtanKlaus Jonagold

    Dabei seit:
    05.10.06
    Beiträge:
    19
    Schon viel probiert.... texmaker und Umlaute?

    Liebe Leute,
    ich bin von TeXshop umgestiegen, und nun zeigt mir der Gute die Umlaute, die ich schreibe, einfach nicht an. Aus Glück, Spaß, Schönheit wird

    Glck, Spa, Schnheit

    wenn ich den Header :

    \documentclass[a4paper,10pt]{scrartcl}
    \usepackage[ngerman]{babel}
    \usepackage[utf8]{inputenc}

    \begin{document}

    Glück, Spaß, Schönheit.

    \end{document}

    benutze.
    Ich fliech gleich ausse Kurve... mit applemac und ansinew sieht es nämlich genauso aus, auch mit latin1....
    Bin euch furchtbar dankbar, schreib grade meine BA-Arbeit.
    Liebe Grüsse in die Sommernacht
    von
    Borris
     
  5. OrangUtanKlaus

    OrangUtanKlaus Jonagold

    Dabei seit:
    05.10.06
    Beiträge:
    19
    Freibier für alle!

    So, ick habs doch noch rausgekriegt.
    UTF8 hat mein Rechner (G4 mit 10.3.9) offensichtlich nicht parat, aber wenn ich unter

    'preferences' -> 'editor' -> 'editor font encoding' einfach 'apple roman'

    einstelle, und dann das

    usepackage[applemac]{inputenc}

    lade..... JA DANN GEHTS, sogar sehr gut.
    Ich hoffe, es hilft noch jemandem!
    Na dann Prost. Wer sichs abholt, kriegt wirklich eins!
     
  6. OrangUtanKlaus

    OrangUtanKlaus Jonagold

    Dabei seit:
    05.10.06
    Beiträge:
    19
    Gut, wenn mans mal gewusst hat, und das Internet...

    ... es nicht vergessen hat!
    Nach Neuinstallation des ganzen Systems und auch von TEXMAKER ging das mit den Umlauten wieder nicht... google hat mich zu meinem Beitrag aus der Vergangenheit gebracht, der mir dann auch noch geholfen hat. AT als externer BackUpSpeicher sozusagen. DANKE !
     
  7. feulni

    feulni Erdapfel

    Dabei seit:
    30.06.08
    Beiträge:
    4
    doppelpost :p
     

Diese Seite empfehlen