1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Terminal

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Dragon_Eye, 13.05.07.

  1. Dragon_Eye

    Dragon_Eye Boskoop

    Dabei seit:
    26.04.07
    Beiträge:
    40
    Hi Leute, hab ne Frage. Und zwar, wenn ich mir oder verschiedenen Gruppen, bei meiner Externen HDD Rechte zuweisen will, hab ich kein wirklichen Plan wie das gehen soll. Ich habs so versucht wie ich das normalerweise unter Suse machen würde, also mit CHMOD aber funzt irgendwie nicht. Kann mir einer mal bitte den Befehl posten. Währe nett.

    Wenn ich das gar nicht über das Terminal machen brauche, wäre das natürlich auch gut, wenn mir dann einer sagen würde ich ich das ansonsten machen könnte.
    Also thx.
     
  2. SkyWombat

    SkyWombat Uelzener Rambour

    Dabei seit:
    18.10.05
    Beiträge:
    370
    Rechte setzen geht auch im Finder. Das Info Fenster zum entsprechenden Ordner aufmachen und du siehst unten etwas was sich Ownership & Permission nennt (im Deutschen vll Besitzer & Rechte). dort kannst du diese ganz gemuetlich graphisch verwalten und setzen.
     
  3. Dragon_Eye

    Dragon_Eye Boskoop

    Dabei seit:
    26.04.07
    Beiträge:
    40
    Hi, also erstmal danke. Ich habe noch nicht all zu lange einen MAC, wahrscheinlich liegt das daran, dass ich dar nix finde... könntest du mir vllt eine art howto schreiben ?? wäre geil. Danke
     
  4. SkyWombat

    SkyWombat Uelzener Rambour

    Dabei seit:
    18.10.05
    Beiträge:
    370
    Das meiste ist wirklich sehr intuitiv. Und wenn du schon Linux Erfahrung hast, duerftest du ja auch nicht davor zurueckschrecken ein paar Dinge einfach zu probieren. Immerhin kennst du dich ja mit einer Shell aus.
    Warum willst du eigentlich Rechte auf deiner externen Festplatte setzen? Du als Benutzer hast vollen Zugriff auf die Platte die du einsteckst. Und Rechte fuer Dateien auf der externen Platte setzen geht ja sowieso nur wenn sie mit HFS formatiert ist. Wobei ich mir nicht sicher bin ob OS X auch ReiserFS, ext3, ... lesen und schreiben kann. Falls ja sollte es dort natuerlich auch Rechte setzen koennen. Auf einer FAT32 formatierten Platte geht das alles natuerlich nicht.
     
  5. SkyWombat

    SkyWombat Uelzener Rambour

    Dabei seit:
    18.10.05
    Beiträge:
    370
    Achso, im Terminal geht das natuerlich schon auch. Du lagst auch richtig mit chmod, wahrscheinlich hast du aber das "sudo" vergessen, falls du eine Rechte auf etwas setzen wolltes das dir nicht als User gehoert.
     
  6. Dragon_Eye

    Dragon_Eye Boskoop

    Dabei seit:
    26.04.07
    Beiträge:
    40
    Also das Ding ist, das ich shcona usprobiert habe aber einfach keinen nerv mehr habe. ^^ Ich dachte auch das ich alle rechte habe, aber das die externe auch von einem PC benutzt wird ist sie ntfs formatiert. ^^-> Hatte sie schon bevor ich den mac hatte. Aber du hast natürlich recht, man muss sowas selbst probieren um es zu verstehen udn um es zu lernen. Also vielen dank trotzdem.
     
  7. SkyWombat

    SkyWombat Uelzener Rambour

    Dabei seit:
    18.10.05
    Beiträge:
    370
    Auf einer NTFS formatierten Platte kannst du mit Bordmitteln von 10.4 meines Wissens nach ueberhaupt keine Rechte setzen und soweit ich weiss auch nicht schreiben.
     
  8. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.896
    ...musst du erst mal dafür sorgen, das die Verwaltung von Eigentümern dort überhaupt aktiv ist.
    Bei HFS+ Volumes lässt sich die Verwendung der Eigentümernamen komplett ausschalten, und bei allen externen ("mobilen") Datenträgern ist das die Voreinstellung.
    (Um Zugriffsproblemen beim Transport einer Platte von Rechner zu Rechner vorzubeugen. It's a feature, not a bug...)

    In den Finder-Informationen des Volumes findest du bei den Rechteeinstellungen ganz unten eine Checkbox, deren Beschriftung dir die Äuglein leuchten lassen wird.
    Damit die Änderungen dort sauber aktiviert werden, musst du das Volume trennen und neu mounten.

    Warnung:
    Solange die "Ignorieren"-Funktion eingeschaltet ist, sind sämtliche sichtbaren Angaben zu Eigentümern und Gruppen nur Schall und Rauch, eine pure Fata Morgana.
    Dort wirst immer du selbst angezeigt werden, egal wer du auch bist. Tatsächlich aber wird alles unter dem Login "unknown" angelegt (UID 99). Nur root sieht das wahre Ego, für alle anderen Benutzer wird der "magische" Benutzer "unknown" immer auf den eigenen Namen gemappt.

    Um zu verhindern, dass du dich evtl beim Aktivieren der Eigentümer selbst aussperrst solltest du die Rechte der Wurzel des Volumes vorher unbedingt auf 777 setzen.
    Sonst wirst du dich in der Situation wiederfinden, dass das Volume gar nicht mehr auf dem Desktop sichtbar wird. Jedenfalls nicht für dich... eine doofe Situation. Unbedingt vermeiden.

    (Nicht verwirren lassen: Die Zugriffsrechte funktionieren immer, nur die Eigentümer und Gruppen sind abschaltbar.)

    Wenn du die Prozedur durchgezogen hast, solltest du dir die vorhandenen Rechtezuweisungen mal mit "ls -la" ganz genau ansehen. Und zwar ein mal von einem beliebigen Benutzerkonto aus, ein weiteres mal von einem anderen Benutzerkonto aus (da wirst du vermutlich noch stutzen) und dann schliesslich aus einer root-Shell heraus. Da dürfte dann der Groschen langsam fallen, wie dieser Mummenschanz funktioniert...

    EDIT:
    Das stimmt: NTFS geht nur im Read-only Modus. Da kannst du überhaupt nichts verändern...
     
  9. Dragon_Eye

    Dragon_Eye Boskoop

    Dabei seit:
    26.04.07
    Beiträge:
    40
    Zu Rastafari, also das war ne fette Erläuterung, danke. Nur kann ich jetzt erstmal nicht viel mitanfangen da ich ja NTFS habe und auch noch brauche, leider. Werde mir wohl eine neue externe holen müssen die ich dann gleich richtug formatiere. Also vielen Dank @all die mir geholen haben. -> das hier ist ein super Forum
     

Diese Seite empfehlen