1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Terminal und "M"

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von commander, 16.08.07.

  1. commander

    commander Baldwins roter Pepping

    Dabei seit:
    25.02.04
    Beiträge:
    3.210
    Hi Leuts,

    ich hab seit 2 Wochen oder so ein seltsames Problem: meine Mac OS X Console (aka Terminal) akzeptiert kein 'M' mehr! Auch 'a' und 'o' muss ich mehrmals drücken, bis sie erscheinen.

    Ich hab ja so mit Tastaturlayouts rumgespielt und dachte, es liegt daran.

    Aber heute hab ich von einem Arbeitskollegen erfahren, dass es bei ihm (ohne Layouts) genauso ist.

    Liegt es evtl an iTerm? Das haben wir beide dazuinstalliert.

    Kann das Problem von jemanden nachvollzogen werden?

    Gruß,

    .commander
     
  2. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Brösel erstmal die letzten Kornweckerln aus der Tastatur! :)
    Und dann schau mal in den Tastatureinstellungen wie die Wiederholrate bzw. Ansprechverzögerung eingestellt ist. (Schuß ins sehr blaue)
    Bei mir spinnt momentan das kleine Ef ein wenig. Das liegt aber definitiv an mir. Passiert das in anderen Applikationen auch, oder nur im Terminal.app?
    Gruß Pepi
     
  3. commander

    commander Baldwins roter Pepping

    Dabei seit:
    25.02.04
    Beiträge:
    3.210
    Nur und ausschliesslich im Terminal/iTerm. Absoluter Entlastungszeuge ist copy&paste: 'Module' wird im Terminal zu 'dule'.....
     
  4. commander

    commander Baldwins roter Pepping

    Dabei seit:
    25.02.04
    Beiträge:
    3.210
    Könnte mal ein geneigter Mitapfeltalker mal probieren, ob sich sein Terminal genauso verhält?

    Ich wäre sehr zu Dank verpflichtet!

    Gruß,

    .commander
     
  5. Hobbes_

    Hobbes_ Gast

    Also bei mir verhält sich das Terminal wie immer völlig unspektakulär. Kein kreativer Umgang mit Buchstaben zu vermelden. Ich habe bei mir jedoch auch keine Zusatzsoftware wie von Dir beschrieben installiert.

    Mir ist im Moment nicht klar, weshalb das nur im Terminal auftreten sollte. Du hast erwähnt, dass Du ein paar Dinge an den Tastaturlayouts verändert hast. Was hast Du genau verändert? Und daneben: Hast Du auch in den Profile/Konfigurationsdateien bezüglich Login ins UNIX etwas verändert oder Einstellungen im Terminal-Programm gemacht?

    Mmh, Sherlock Holmes, bitte übernehmen Sie...
     
  6. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Öhm, eine hinige Schrift, oder eine völlig abstuse Textkodierung ausgewählt, oder irgendwelcher böser Müll in der .inputrc. Passiert das in X11.app auch? (Weil dort die Shell ein bissl anders initialisiert wird.) Ansonsten probier mal in Terminal.app ein neues Terminal mit ⌥N zu öffnen (Factory Defaults) und sag' uns was dann passiert. Wenns dann weg ist, liegts an irgendwelchen init Files.
    Gruß Pepi
     
  7. commander

    commander Baldwins roter Pepping

    Dabei seit:
    25.02.04
    Beiträge:
    3.210
    Aha, nein, das XTerm verhält sich nicht so... da geht alles.

    Ich hab zwar die .inputrc übersachrieben (damit die bash-history Suche auf den Cursortasten liegt), aber wenn ich .inputrc umbenennne und das Terminal neu starte ist das Verhalten genauso falsch wie vorher....

    So schaut meine inputrc aus:

    Code:
    # .inputrc
    # keypad mode
    "\M-OA": history-search-backward
    "\M-OB": history-search-forward
    
    # ansi mode
    "\M-[A": history-search-backward
    "\M-[B": history-search-forward
    
    #8-bit keypad:
    "\M-\C-OA" history-search-backward
    "\M-\C-OB" history-search-forward
    
    # 8-bit ansi:
    "\M-\C-[A": history-search-backward
    "\M-\C-[B": history-search-forward
    
    set completion-ignore-case on
    set page-completions off
    set show-all-if-ambiguous on
    set meta-flag on
    set convert-meta off
    set output-meta on
    
    
     
  8. Hobbes_

    Hobbes_ Gast

    Probier es mal aus, wenn Du die folgenden Teile wieder aus .inputrc entfernst und dann nochmals ein neues Terminal öffnest. Wenigstens bei mir ist die history standarmässig auf den Pfeiltasten, so dass diese zusätzlichen Einstellungen nicht notwendig sind. Gegebenenfalls verursachen sie jedoch das Problem mit dem M.

     
  9. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Das könnte auch ein Problem mit dem Character Encoding sein. Ich habe in meiner ~/.inputrc folgendes drinnen stehen.

    Code:
    # don't strip characters to 7 bits when reading
    set input-meta on
    
    # This is a synonym for input-meta, some terminals prefer this.
    set meta-flag on
    
    # display characters with the eighth bit set directly
    # rather than as meta-prefixed characters
    set output-meta on
    
    # allow iso-latin1 characters to be inserted rather
    # than converted to prefix-meta sequences
    set convert-meta off
    
    Hilft es eigentlich mal prinzipiell wenn Du eine Factory Default Shell im Terminal öffnest?
    Womit initialisierst Du Deine shell (bash?)?
    Gruß Pepi
     

Diese Seite empfehlen