1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

Terminal Login

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von mbpm, 03.06.07.

  1. mbpm

    mbpm Braeburn

    Dabei seit:
    17.04.06
    Beiträge:
    43
    Hi,

    Kann mir jemand erklären, wie ich das wieder in den "Originalzustand" bekomme?

    Last login: Sun Jun 3 15:35:35 on ttyp1
    Welcome to Darwin!
    dslb-084-062-164-... : ~ Name$

    Dieses dslb und die ziffern... das war vorher nicht so. Kenn mich da null aus. Benutze das Terminal für g95 compiler.
     
  2. Dr.Apfelkern

    Dr.Apfelkern Jerseymac

    Dabei seit:
    18.04.07
    Beiträge:
    454
    1x Reboot sollte das wieder beheben wenn der HOSTNAME nicht in einer Einstellungsdatei oder in den Systemeinstellungen > Sharing > Gerätename so dauerhaft gespeichert wurde.
     
  3. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Letzteres (der Bonjour-Gerätename) hat mit dem im Terminal-Prompt angezeigten (DNS-) Hostnamen nichts zu tun. Siehe auch hier:
    http://www.apfeltalk.de/forum/seltsamer-name-terminal-t19954.html
    http://www.apfeltalk.de/forum/terminal-airport-t82396.html
     
  4. thrillseeker

    thrillseeker Lord Grosvenor

    Dabei seit:
    06.10.04
    Beiträge:
    3.497
    Der Hostname ändert sich automatisch, wenn Du online gehst. Bei mir wird dann z.B. aus

    Code:
    pantheon:~ thrillseeker$
    der Hostname

    Code:
    ip-90-187-***-***:~ thrillseeker$
    Beim nächsten Neustart ist alles wieder normal.
     
  5. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Das ist normal und gehört so und ist auch gut so, daß es angezeigt wird.
    Gruß Pepi
     
  6. mbpm

    mbpm Braeburn

    Dabei seit:
    17.04.06
    Beiträge:
    43
    Vielen Dank
     
  7. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.708
    Ändere die /etc/hostconfig. Ändere darin hostname zu: "HOSTNAME=DeinWunschname". Wahrscheinlich steht dort "HOSTNAME=-AUTOMATIC-" im Moment.

    Nachtrag: Reboot ist nötig für den Effekt dann.
     
  8. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Kann es sein, dass "HOSTNAME=-AUTOMATIC-" seit OS X Tiger gar nicht mehr in der /etc/hostconfig drinsteht?
     
  9. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.708
    Sieht so aus. In dem Fall halt nur den Wunschnamen setzen ;)
     
  10. Dr.Apfelkern

    Dr.Apfelkern Jerseymac

    Dabei seit:
    18.04.07
    Beiträge:
    454
    Und warum erscheint bei mir beim Aufruf des Terminal stets standardmässig und ohne Zutun immer der Gerätename? (Systemeinstellungen > Sharing > Gerätename)
     
  11. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Der Gerätename hat nicht in allen Fällen einen Effekt auf HOSTNAME, ist ggf. routerabhängig. Genau aufgedröselt kann ein Mac im Netz 3 verschiedene Namen haben:
    • Systemeinstellungen->Sharing->Gerätename: AppleTalk-Name, "aktueller Computername" im Apple-Jargon
    • Systemeinstellungen->Sharing->Gerätename, Bearbeiten: Bonjour-Name (mDNS), "lokaler Hostname"
    • HOSTNAME wird entweder in /etc/hostconfig gesetzt oder vom nächstgelegenen DNS-Server automatisch vergeben (falls kein DNS-Server benutzt wird, dann vom AppleTalk-Namen abgeleitet), "Netzwerk-Adresse"
    Guckstu hier: http://docs.info.apple.com/article.html?path=Mac/10.4/de/mh632.html

    Ich nehme mal an, dass Du per DSL mit Router surfst, oder? Dann dürfte sich z.B. bei einer Änderung des Gerätenamens der HOSTNAME im Terminal immer erst dann ändern, wenn Du auch eine neue IP-Nummer per DHCP anforderst. Ist bei mir zumindest so.
     
    #11 quarx, 04.06.07
    Zuletzt bearbeitet: 04.06.07
  12. tjp

    tjp Baldwins roter Pepping

    Dabei seit:
    07.07.04
    Beiträge:
    3.246
    Nimm den "Netinfo Manager und lege für die Rechner im Netz, Host Einträge an, dann erschient auch im Terminal zukünftig deren Hostname und kein Müll mehr.
     
    #12 tjp, 09.06.07
    Zuletzt bearbeitet: 26.02.08
  13. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.896
    Das Verhalten ist ziemlich klar dokumentiert.
    Das Installationshandbuch sagt:

    ...
    The host name, computer name, and local hostname are set. You can specify the computer name and local hostname, but the Assistant automatically sets the host name to AUTOMATIC in /etc/hostconfig.
    This setting causes the host name to be the first name that’s true in this list:

    - The name provided by the DHCP or BootP server for the primary IP address

    - The first name returned by a reverse DNS (address-to-name) query for the primary IP address

    - The local hostname

    - The name “localhost”
    ...

    Du beziehst deine Bezeichnung also entweder von einem DHCP oder einem DNS-Server, vermutlich ein Server in deinem LAN, oder aber auch auf deinem Rechner selbst.
    Woher mögen wir wissen, was du alles installiert oder am laufen hast? ;)
     
  14. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Warum änderst Du nicht einfach Dein Prompt ($PS1) und läßt Dir keinen Hostnamen mehr anzeigen wenns Dich partout so stört?
    Gruß Pepi
     
  15. TaTonka

    TaTonka Neuer Berner Rosenapfel

    Dabei seit:
    19.03.06
    Beiträge:
    1.961
    ich hätt da mal ne andere frage...passt auch zum terminal-login, deswegen hier. mein wunderbares terminal sagt mir zur begrüssung folgendes:
    "last login blabla
    Welcome to Darwin!
    You have new mail!"

    jetzt frage ich mich, warum der mir erzählen will, dass ich neue mail habe. mit mail.app hats wohl nichts zu tun. /etc/motd ist auch normal. /etc/issues existiert nicht. irgendwelche konsolen-mail-proggys habe ich nicht. jetzt frag ich mich nur, woher das kommt, und wie ich das wieder weg kriegen kann.
     
  16. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Das ist schon korrekt wenn Du mail hast. Und ja, Du hast ein /usr/bin/mail mit dem Du diese Mails auch lesen kannst. man mail erklärt Dir wie man es bedient. (So schwer isses nicht.) Wahrscheinlich hat Dir ein cron Job oder ein anderer Prozess etwas mitgeteilt.
    Gruß Pepi
     

Diese Seite empfehlen