1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

SUN über SSH mit X11

Dieses Thema im Forum "macOS & OS X" wurde erstellt von fad.ass, 21.02.06.

  1. fad.ass

    fad.ass Rheinischer Krummstiel

    Dabei seit:
    05.08.04
    Beiträge:
    377
    Hallo ATler,

    ich sitze gerade hier in der Uni, und habe mein iBook ans Netzwerk des Institutes angeschlossen.
    Also normalerweise arbeite ich hier an einem Windows Rechner, der sich dann über ssh mit einem SUN verbindet und dann mit X-Win32 die Programme darstellt.

    Eigentlich müßte der ganze Spass ja auch mit meinem iBook laufen. Also ich kann mich mit der SUN Maschine über SSH einloggen. Kriege dann aber keine Fenster auf, wenn ich ein Programm ausführe. (mit X11 natürlich)

    ich habe zum einloggen.

    ssh -X -l user computername

    und in der SUN

    export DISPLAY="MeineIP:0"

    Bei Windows funktioniert das dann immer, wie geht das denn mit X11?

    Gruß
     
  2. DukeNuke2

    DukeNuke2 Wagnerapfel

    Dabei seit:
    17.01.06
    Beiträge:
    1.559
    wenn du ssh nutzt, musst du das display doch nicht noch zusätzlich angeben?!?! ich mach das hier jedenfalls ohne die display angabe und bekomme dann den x output trotzdem auf meiner (linux)maschine dargestellt.
     
    fad.ass gefällt das.
  3. kauan

    kauan Stina Lohmann

    Dabei seit:
    31.12.05
    Beiträge:
    1.043
    Richtig. Das sollte nicht noetig sein.
    Das -X kannst du dir uebrigens ersparen, wenn du deine ~/.ssh/config bearbeitest.
     
    fad.ass gefällt das.
  4. fad.ass

    fad.ass Rheinischer Krummstiel

    Dabei seit:
    05.08.04
    Beiträge:
    377
    also ohne export DISPLAY="" krieg ich ne Fehlermeldung, dass er das DISPLAY nicht ansteueren kann.

    Wenn ich mich einlogge bekomme ich das:

    Code:
    Sun Microsystems Inc.   SunOS 5.8       Generic February 2000
    No mail.
    -------------------------------------------------------------------------------
    
             lfpt.rwth-aachen.de 
    
            - The operating system is  Solaris 8 .
    
            - An overview of the most important commands is shown with
               help .
    
            - More information can be found on the webserver
               http://www.lpt.rwth-aachen.de .
    
            - Before leaving turn off monitors, close windows and lock doors.
    
    -------------------------------------------------------------------------------
    *** bashrc: package GNU unknown, skipping...
    *** bashrc: package X11 unknown, skipping...


    ich weiß nicht ob das hilft...
     
  5. fad.ass

    fad.ass Rheinischer Krummstiel

    Dabei seit:
    05.08.04
    Beiträge:
    377
    So, ich hab mal noch meine Firewall ausgemacht. Jetzt krieg ich wenigstens einen Error kann damit aber sonderlich wenig anfangen.

    Code:
    Xlib: connection to "134.130.124.179:0.0" refused by server
    Xlib: No protocol specified
    
    Error: can't open display.
    fluent: error: couldn't initialize interface.
    
    Gruß, und danke für die Mühe
     
  6. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Du kannst mal probieren, beim ssh-Aufruf statt der Option -X die Variante -Y zu verwenden. Hat mir zumindest schon bei ssh-Problemen geholfen.
     
  7. fad.ass

    fad.ass Rheinischer Krummstiel

    Dabei seit:
    05.08.04
    Beiträge:
    377

    Geht leider auch nicht.
     
  8. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Benutzt Du auf dem Mac xterm oder das Terminal? Bei letzterem müsstest Du wahrscheinlich vor dem ssh-login auf der Sun noch mit
    Code:
    export DISPLAY=:0.0
    die Verbindung Terminal<->X11 herstellen.
     
  9. fad.ass

    fad.ass Rheinischer Krummstiel

    Dabei seit:
    05.08.04
    Beiträge:
    377
    Also ich benutze xterm, da brauch ich das ja nicht mehr
     
  10. slartibartfast

    slartibartfast Schöner von Nordhausen

    Dabei seit:
    10.05.05
    Beiträge:
    323
    also, du musst, um Verbindungen an deinen X-Server zuzulassen folgendes machen:

    - Firewall ausschalten (oder den X-Port zulassen)
    - X11 starten
    - im xterm ausführen
    Code:
    xhost +<server>
    xhost + #alternativ, um Verbindungen von allen Rechnern erlauben
    - dann im xterm die ssh-Verbindung starten

    geht's so?


    Grüße
    slartibartfast
     
    Alfisto, stk und fad.ass gefällt das.
  11. fad.ass

    fad.ass Rheinischer Krummstiel

    Dabei seit:
    05.08.04
    Beiträge:
    377
    jau, geht. vielen dank!
     
  12. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.896
    'xhost' ist vollkommen veraltet und ein unkalkulierbares Sicherheitsproblem.
    Wenn, dann schon 'xauth', aber auch das ist Geschichte.

    Der empfohlene Weg ist das Tunneln über eine ssh-Verbindung:

    ssh -X -l loginname hostname

    Man lese:
    http://developer.apple.com/opensource/tools/runningX11.html
     
  13. DukeNuke2

    DukeNuke2 Wagnerapfel

    Dabei seit:
    17.01.06
    Beiträge:
    1.559
    das hat er doch versucht und es hat nicht geklappt. was mich aber auch wundert.... liegt das vllt an der sshd konfig am server?
     
  14. kauan

    kauan Stina Lohmann

    Dabei seit:
    31.12.05
    Beiträge:
    1.043
    Uebrigens hilft bei solchen Fehlern oft ein:
    Code:
    ssh -vvv user@host
     
  15. fad.ass

    fad.ass Rheinischer Krummstiel

    Dabei seit:
    05.08.04
    Beiträge:
    377
    das hab ich probiert, aber das funktioniert nicht.
    Ich bleib bei der unsicheren Variante, die funkioniert. Und im Institutsnetz bin ich auch relativ sicher. Hoffe ich zumindest.

    Gruß und danke an alle die geholfen haben.
     
  16. kauan

    kauan Stina Lohmann

    Dabei seit:
    31.12.05
    Beiträge:
    1.043
    Damit soll es auch gar nicht funktionieren, aber es handelt sich dabei um den Verbose-Modus. Es werden also alle Statusmeldungen ausgegeben. Dadurch sollte man den Fehler feststellen koennen.
     

Diese Seite empfehlen