1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Subclipse vergisst Passwort

Dieses Thema im Forum "OS X-Developer" wurde erstellt von Roadrunner1975, 16.01.09.

  1. Roadrunner1975

    Dabei seit:
    30.06.07
    Beiträge:
    48
    Hallo zusammen,

    ich habe mir schon die Finger wund gesucht und keine Lösung gefunden. Vielleicht kann mir hier jemand helfen.

    Ich verwende Eclipse Ganymed mit Sublipse als SVS Plugin. Allerdings habe ich hier das Problem, dass ich jedes mal meinen Benutzernamen und das Passwort eingeben muss. Dies ist irgendwie sehr nervig. Ich sage dem Plugin jedes mal, dass er die Daten speichern soll. Aber irgendwie scheint das nicht zu funktionieren.

    Wie kann ich es schaffen, dass sich das Plugin meine Daten merkt, damit ich nicht jedes mal alles von vorn eingeben muss.

    Danke für Eure Unterstützung.
     
  2. Roadrunner1975

    Dabei seit:
    30.06.07
    Beiträge:
    48
    Scheinbar hat keiner weiter dieses Problem

    Ich habe nun schon auf die aktuelleste Eclipse Version 3.5 und die aktuellste Subclipse Version aktualisiert, allerdings habe ich dieses Problem immer noch. Ich habe auch keine Lösung hierfür gefunden, sondern muss immer wieder Benutzernamen und Passwort eingeben.

    Vielleicht hat doch noch jemand eine Lösung parat.

    Danke Danke
     
  3. skappley

    skappley Oberösterreichischer Brünerling

    Dabei seit:
    09.06.07
    Beiträge:
    720
    Hallo,

    soweit ich weiß speichert sich Subversion die Zugangsdaten zu einem Repository in seinen Einstellungen (irgendwo in deinem Homeverzeichnis unter ~/.subversion/auth). Im Config-File (~/.subversion/config) gibt es Parameter, die festlegen ob Passwörter gespeichert werden sollen oder nicht ("store-passwords", "store-auth-creds"). Per Default werden Zugangsdaten zwar gespeichert, vielleicht sind diese Einstellungen bei dir aus irgendeinem Grund aber geändert worden.

    Ansonsten kannst du noch ausprobieren ob Subversion im Terminal ohne Eingabe von Zugangsdaten funktioniert. Ich verwende Subversion hauptsächlich vom Terminal aus (Zugangsdaten werden bei mir gespeichert, kann also einfach auf die Repositories zugreifen).

    Subclipse habe ich ebenfalls installiert, verwende es aber nur selten. Wenn ich es verwende, funktioniert der Zugriff zumindest auch ohne extra Zugangsdaten eingeben zu müssen. Subclipse greift damit also auf die Zugangsdaten zu, die Subversion gespeichert hat. Ich denke nicht, dass das Subclipse Plugin selbst irgendwo Zugangsdaten speichert.
     
  4. Vjay

    Vjay Süssreinette (Aargauer Herrenapfel)

    Dabei seit:
    28.02.09
    Beiträge:
    403
    Hatte ich auch schon einmal. Was half, war den .svn Ordner in meinem Userverzeichnis zu löschen. Das Phänomen rührte daher, dass ich Eclipse wohl mal als su gestartet hatte und dann waren die svn Configfiles schreibgeschützt.
     
  5. Roadrunner1975

    Dabei seit:
    30.06.07
    Beiträge:
    48
    Hallo zusammen,

    Danke für Eure Hinweise. Allerdings hat nichts zur Lösung meines Problems beigetragen. Und einen .svn Ordner habe ich irgendwie vergeblich gesucht und nicht gefunden. Also muss ich immer noch nach der Lösung suchen und weiter meine Daten eingeben.

    Vielleicht fällt jemanden ja noch etwas ein.

    Danke und Sport Frei ;)
     

Diese Seite empfehlen