1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Standard Gateway und Suchdömäneneintrag löschen

Dieses Thema im Forum "Netzwerk" wurde erstellt von rc4370, 04.07.09.

  1. rc4370

    rc4370 Wöbers Rambur

    Dabei seit:
    09.03.09
    Beiträge:
    6.528
    hallo,

    in meinen w-lan einstellungen findre ich unter DNS zwei einträge. der eine ist der DNS-Server und im feld daneben als suchdomäne mein alter router.

    da sich mein netzwerk geändert hat, vermute ich, dass diese einträge für meine schlechte verbindung verantwortlich sind. die einträge sind hellgrau und lassen sich nicht löschen. weis jemand von euch, wie ich die weg bekomme?

    habe die umgebung schon verändert, gelöscht und neu erstellt. keine änderung.

    com.apple.airport.plist und com.apple.networkidentification.plist habe ich auch schon gelöscht. keine änderung.

    danke für eure tips.
     
  2. StephanG

    StephanG Normande

    Dabei seit:
    07.11.07
    Beiträge:
    582
    Hellgrau, wie wenn Admin Schloss gesperrt ist?
    Beziehst du deine IP vom DHCP Server?
     
  3. rc4370

    rc4370 Wöbers Rambur

    Dabei seit:
    09.03.09
    Beiträge:
    6.528
    ja, dhcp. ja, grau wie gesichert. ist aber nicht gesichert.
     
  4. StephanG

    StephanG Normande

    Dabei seit:
    07.11.07
    Beiträge:
    582
    DHCP hat Options die neben der normalen IP-Adresse für den Client auch noch Adressen für DNS und Router übertragen kann.

    Schau dir mal die Konfiguration deines DHCP Servers an, der schickt wahrscheinlich Option 3 (Router) und Option 6 (DNS) mit an den Client raus.

    Noch eine Möglichkeit wäre, dass dein Client diese Optionen explizit im DHCPDISCOVER anfragt. Sofern du die beiden Adressen tatsächlich vom DHCP Server bekommst (bin ich mir eigentlich ziemlich sicher), kannst du die auch nicht löschen. Da hilft dann nur ausschalten dieser Optionen oder manuelle Konfiguration der Umgebung.
     
  5. rc4370

    rc4370 Wöbers Rambur

    Dabei seit:
    09.03.09
    Beiträge:
    6.528
    ok, das verstehe ich. aber mich wundert, dass das meine alten netzwerk komponenten sind. die hab ich nichtmehr in betrieb. warum stehen also die alte ip des routers und der name (speedport.ip) des routers dort unlöschbar.
    denn durch diesen eintrag bekomme ich eine ip zugewiesen, die nicht im adressbereich des neuen routers liegt. komischerweise komme ich ins internet.

    jedoch muss ich 3-8 mal versuchen apfeltalk zu laden, bevor es klappt. die empfangsstärke des neuen w-lan ist sehr gut aber die verbindung sau langsam.
     
  6. StephanG

    StephanG Normande

    Dabei seit:
    07.11.07
    Beiträge:
    582
    Nur damit ich das richtig verstehe. Dein neuer Router dient dir als neuer DHCP Server und liegt in einem anderen Adress-Bereich als der alte, du bekommst aber trotzdem noch die IP des alten Routers als default gateway zugewiesen und das funktioniert trotzdem?

    Das ist tatsächlich etwas seltsam.

    Was sagt denn
    Code:
    netstat -r
    zu den Routen?
    Falls da was faul ist, kannst du die mit
    Code:
    sudo /sbin/route flush
    löschen.

    Du kannst auch mal schauen was
    Code:
    nslookup
    , dann
    Code:
    show
    sagt. Und das ggf. mit
    Code:
    server IP
    auf deine aktuelle Router IP ändern.

    Anschließend noch mal schauen was in /private/var/run/resolv.conf steht und prüfen ob ein SymLink darauf aus /etc/resolv.conf verweist.

    Mehr fällt mir jetzt spontan auch nicht ein.
     
    rc4370 gefällt das.
  7. rc4370

    rc4370 Wöbers Rambur

    Dabei seit:
    09.03.09
    Beiträge:
    6.528
    werde mich gleich damit beschäftigen. muss zugeben, mit dem terminal bin ich noch nicht so vertraut. aber was noch nicht ist.......
     
  8. rc4370

    rc4370 Wöbers Rambur

    Dabei seit:
    09.03.09
    Beiträge:
    6.528
    so, habe das mal gemacht wie beschrieben. hier das ergebniss:


    Internet:
    Destination Gateway Flags Refs Use Netif Expire
    default speedport.ip UGSc 9 0 en1
    127 localhost UCS 0 0 lo0
    localhost localhost UH 1 6 lo0
    169.254 link#5 UCS 0 0 en1
    192.168.2 link#5 UCS 1 0 en1
    speedport.ip 0:1a:2a:3c:eb:13 UHLW 21 68 en1 1200
    192.168.2.148 localhost UHS 0 0 lo0

    Internet6:
    Destination Gateway Flags Netif Expire
    localhost link#1 UHL lo0
    fe80::%lo0 localhost Uc lo0
    localhost link#1 UHL lo0
    fe80::%en1 link#5 UC en1
    Ralf-Cartus-MacBoo 0:23:6c:8a:7e:bd UHL lo0
    ff01:: localhost U lo0
    ff02:: localhost UC lo0
    ff02:: link#5 UC en1
    Ralf-Cartus-MacBook:~ ralfcartus$ nslookup
    > show
    ;; Warning: Message parser reports malformed message packet.
    Server: 192.168.2.1
    Address: 192.168.2.1#53

    Non-authoritative answer:
    Name: show
    Address: 80.156.86.78
    Name: show
    Address: 62.157.140.133
    >
     
  9. StephanG

    StephanG Normande

    Dabei seit:
    07.11.07
    Beiträge:
    582
    Ist denn die 192.168.2.1 die Adresse deines neuen Routers oder noch die des alten?

    Falls es die alte ist, dann nimm dir mal die /private/var/run/resolve.conf vor und editier sie per Hand. Dort sollte die IP des aktuellen Routers rein.

    Warum nun speedport.ip in der Routing Tabelle steht, verstehe ich allerdings auch nicht ganz. Du könntest mal einen Ping auf speedport.ip loslassen und schauen auf welche IP der Name aufgelöst wird. Ein Blick in die /etc/hosts würde da auch helfen, ggf. dort raus löschen.

    Hast du mal die Routing Tabelle geflusht? Steht danach noch immer der speedport.ip drin?
     
  10. rc4370

    rc4370 Wöbers Rambur

    Dabei seit:
    09.03.09
    Beiträge:
    6.528
    erstmal danke stephan für deine hilfe. habe das problem gelöst. ich habe einfach in beide felder fantasie ip`s eingetragen. dadurch wurden alle löschbar.
     

Diese Seite empfehlen