1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Ständig Firewall-Abfragen bei Datei-Dialogen

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Bratesel, 15.11.09.

  1. Bratesel

    Bratesel Alkmene

    Dabei seit:
    13.04.09
    Beiträge:
    35
    Hallo.

    Seit Mac OS 10.6 erscheint bei einem Dateidialog, z.B. Datei Speichern im Firefox oder Safari, der Dialog, ob das Programm eingehende Verbindungen akzeptieren soll. Der Dialog verschwindet nach rund 1 Sekunde automatisch und hat mich daher nicht gestört.

    Seit dem Update auf 10.6.2 erscheint der Dialog aber immer und immer wieder... Klicke ich im Speichern-Dialog sofort auf Speichern, erscheint die Firewall-Abfrage noch 5 oder 6 Mal, immer für 1 Sekunde, und setzt sich vor das aktive Programm. Schließe ich den Speichern-Dialog nicht sofort, weil ich z.B. noch den richtigen Ordner suche, erscheint der die Firewall immer wieder... ohne Ende.

    Es spielt dabei übrigens keine Rolle, ob in den Firewall-Einstellungen das Programm mit "immer erlauben" oder "immer verbieten" eingetragen ist. Auch "Signierte Software automatisch erlauben..." hat keine Wirkung auf das Problem.

    Kann mir da jemand helfen?

    Danke schonmal!

    Sebastian
     
  2. iChrigi

    iChrigi Angelner Borsdorfer

    Dabei seit:
    26.03.08
    Beiträge:
    628
    Deaktiviere doch die Firewall. Im Kontrollfeld Sicherheit. Bei mir war sie standardmässig deaktiviert.
     
  3. Bratesel

    Bratesel Alkmene

    Dabei seit:
    13.04.09
    Beiträge:
    35
    :) Danke. Darauf bin ich auch schon gekommen.
    Da allerdings auch Freunde mein WLAN benutzen, möchte ich die Firewall lieber nicht deaktivieren.
    Ich dachte, es könnte eine Lösung für das Problem geben. Da ich im Forum sonst kein Thema dazu gefunden habe, scheint es ja bei anderen Nutzern zu funktionieren.
     
  4. maelcum

    maelcum Jonathan

    Dabei seit:
    03.10.08
    Beiträge:
    82
    Mal was versuchen...

    Hi Bratesel,


    ich hab ein ähnliches Problem und auf der Suche nach einer Lösung schon ein paar Stellschrauben gefunden, an denen Du mal drehen könntest. Das ist aber alles "auf eigene Gefahr" und nur dann zielführend, wenn Du Dich im Terminal passabel gut auskennst. Sollte dem nicht so sein, überspring diesen Post; wahrscheinlich führt er eh zu nix... ;)
    Die Befehle folgen der Beschreibung und sind eigentlich dazu gedacht, per copy/paste übernommen zu werden.


    Also:
    Die Einstellungen, ob eine App eingehende Verbindungen nochmal rückfragen muss, oder nicht, wird u.a. in der Datei /Library/Preferences/com.apple.alf.plist gespeichert.
    Die liegt - wie fast alle plists - erst mal nur binär vor, und muss erst mal lesbar gemacht werden.
    Nach dem Öffnen sieht man oben gleich den Eintrag <key>applications</key> (hier folgen wohl Apps) und dann auch gleich größere Blöcke die mit
    <dict>
    ...
    </dict>
    eingeschlossen sind.
    Darunter auch Safari und andere Anwendungen, die eine Erlaubnis haben, die Firewall zu passieren.
    Es kann passieren dass dieser Eintrag kaputt geht. Überschrieben wird er aber nicht.
    Man kann deshalb testweise mal den ganzen Block (also von <dict> bis </dict>) rauslöschen.
    Es passiert nicht viel. Das System fragt beim nächsten Mal, wo die App kommunizieren will, wieder nach und macht den Eintrag erneut. Im schlimmsten Fall ist alles wie vorher. Mit ein bisschen Glück wird der Eintrag aber korrekt neu geschrieben, und die Welt ist sonniger.
    Und wenn alle Stricke reissen, gibts ja noch die Sicherungskopie, die man sich als erstes anlegt...


    Befehle:
    Sicherheitskopie anlegen: sudo cp /Library/Preferences/com.apple.alf.plist /Library/Preferences/com.apple.alf.org
    Konvertieren: sudo plutil -convert xml1 /Library/Preferences/com.apple.alf.plist
    Öffnen: sudo open -e /Library/Preferences/com.apple.alf.plist
    Jetzt den entsprechenden Block für eine Anwendung löschen.
    Datei speichern und schließen.
    Testen.

    Falls Probleme auftreten mit folgendem Befehl die Sicherungskopie wiederherstellen:
    sudo cp /Library/Preferences/com.apple.alf.org /Library/Preferences/com.apple.alf.plist




    Das war eine Möglichkeit.
    Es gibt noch etwas Anderes, was man probieren könnte: Wenn ein Programm keine Signatur vom Hersteller mitbringt (der sich verbürgt, dass die Software keinen Schindluder treibt) dann fragt die OS X Firewall beim ersten Mal, wo das Programm kommunizieren will nach, ob das okay ist (den Dialog kennen wir ja zur Genüge) und bastelt sich dann selbst eine Signatur, die es dem Programm anhängt.
    Auch die geht manchmal kaputt bzw. wird invalidiert, taugt dann also nichts mehr. Nachdem das System eine kaputte Signatur nicht entfernt, sondern lieber nochmal nachfrägt (was nervt) kann man ja mal selbst die Signatur löschen, und gucken, ob das System eine neue bastelt und dann Ruhe gibt.
    Und das geht so.

    sudo rm -r /Applications/++PFAD_UND_NAME_DER_APP_ERGÄNZEN++.app/Contents/CodeResources
    sudo rm -r /Applications/++PFAD_UND_NAME_DER_APP_ERGÄNZEN++.app/Contents/_CodeSignature

    ++PFAD_UND_NAME_DER_APP_ERGÄNZEN++ muss ergänzt werden, zum Beispiel durch
    Safari, dann sähe der erste Befehl so aus:
    sudo rm -r /Applications/Safari.app/Contents/CodeResources

    Sinnvollerweise macht auch hier vorher ein Backup, falls irgendwas daneben geht.
    Am Beispiel von Safari geht das am einfachsten im Finder. Suchen, Duplizieren (Apfel-D).
    Im GAU-Fall das eine Safari löschen und die Safari Kopie nach Safari umbenennen.


    Ein ewig langer Post für zwei einfache Tests, aber vielleicht hilft es.
     
  5. Bratesel

    Bratesel Alkmene

    Dabei seit:
    13.04.09
    Beiträge:
    35
    Hi maelcum.

    Danke für die Anleitung. Ich habe allerdings tatsächlich nicht genug Ahnung vom Terminal, als dass ich das ausprobieren könnte.
    Aber vielleicht hilft der Tipp jemand anderem.

    Mittlerweile habe ich eine quasi Lösung gefunden... man muss in dem kurzen Moment, in dem eine der Meldungen erscheint, auf "Zulassen" klicken. Macht man das, erscheint die Meldung für das Programm nie wieder. Bei anderen Programmen macht man das ebenfalls und nach einiger Zeit hat man seine Ruhe.

    Dank an alle, die mich unterstützt haben.

    Sebastian
     
  6. LeMerlot

    LeMerlot Golden Delicious

    Dabei seit:
    05.02.10
    Beiträge:
    8
    Die Lösung?

    Firewall eingeschaltet lassen und DIE LÖSUNG befolgen.

    :cool:

    Enjoy!
    LeMerlot
     
  7. maelcum

    maelcum Jonathan

    Dabei seit:
    03.10.08
    Beiträge:
    82
    Ständig Firewall-Abfragen bei Datei-Dialogen [SOLVED]

    jaaa jaaa jaaaaa jaaaaa
    !!!!!!!!!!!!!!!!
    !!!!es funktioniert!!!!

    :-* :-* :-* :-* :-* :-* :-* :-* :-*

    DANKEEEE LeMerlot!
     
  8. LeMerlot

    LeMerlot Golden Delicious

    Dabei seit:
    05.02.10
    Beiträge:
    8
    So ging es auch mir nach Monaten der Qual... ;)

    Prima, wenn ich jetzt die Freude über die Lösung teilen konnte :)
    LeMerlot
     
  9. hurtzel

    hurtzel Golden Delicious

    Dabei seit:
    19.12.09
    Beiträge:
    7
    Virtuelle Maschine schuld

    Ich hatte das gleiche Problem und konnte es auf meine virtuellen Maschinen (VMware) zurückführen. Anscheinend synchronisieren diese ihre Zeit mit dem Betriebssystem. Aufgrund eines Programmierfehlers bezüglich Doppelkernprozessoren wird allerdings die Zeit falsch berechnet. Anscheinend wird die Zeit in beide Richtungen synchronisiert, jedenfalls war meine Systemzeit jedes mal verstellt, wenn ich mit einer VM gearbeitet habe. Teilweise war meine Systemzeit sogar auf ein Datum um 1980 zurückgesetzt (was Mac OS X als komisch erkennt und vorsichtshalber beim Start nachfragt, ob das auch wirklich sein kann). Diese falsche Systemzeit veranlasst die Firewall, ständig nachzufragen. Ich habe daraufhin mit folgenden Befehlen in der vmx-Datei der virtuellen Maschine das Problem gelöst:
    Code:
    tools.syncTime = "FALSE"
    time.synchronize.continue = "0"
    time.synchronize.restore = "0"
    time.synchronize.resume.disk = "0"
    time.synchronize.shrink = "0"
    time.synchronize.tools.startup = "0"
     
  10. Sequoia

    Sequoia Rheinischer Bohnapfel

    Dabei seit:
    03.12.08
    Beiträge:
    2.443
    @ LeMerlot:
    Ich wollte Deine Lösung auch anwenden, damit mich ChronoSync nicht immer wieder fragt, doch es kommt folgendes im Terminal bei raus o_O
    Den Anhang 62016 betrachten
     

Diese Seite empfehlen