1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

"ssh -X" mit MacOS

Dieses Thema im Forum "Filetransfer" wurde erstellt von wookenny, 27.05.08.

  1. wookenny

    wookenny Erdapfel

    Dabei seit:
    07.06.07
    Beiträge:
    4
    Hi,

    um per Mac OS angenehm programmieren zu können fehlt mir der Login auf ein Linuxrechner mit durchreichen der Fensterinhalte.

    Genauer:
    ich würde mich gerne auf einen Linuxrechner per "ssh -x" einloggen.(Auch wenn es langsam ist.)
    Nur so kann ich ein Programm ausführen, das den X Server nutzt, aber je nah Aufruf kein Fenster erzeugt.
    Von anderen Linuxsystemen klappt es mit dem Parameter -X. Unter MacOS leider nicht.
    Beim Aufruf des Programmes bekomme ich immer die Meldung "cannot connect to X server".
    Kann man das irgendwie Umgehen? Mit zusätzlicher Software vielleicht?

    Danke.
     
  2. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Du musst X11 starten und dann aus dem x-term heraus die Verbindung aufbauen. Danach sollte das klappen. Unter Leo ist das standardmäßig installiert (Programme->Dienstprogramme)
     
  3. wookenny

    wookenny Erdapfel

    Dabei seit:
    07.06.07
    Beiträge:
    4
    Vielen Dank.
    Ich hab gar nicht daran gedacht, es mit dem xterm von X11 zu probieren.
    Habs mit dem normalen Terminal probiert, da klappt das aber eben ohne X.
    Klappt jetzt (mit Tiger) sehr gut.
     
  4. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Setze mal in Deine ~/.profile oder ~/.bash_profile ein gepflegtes
    Code:
    export DISPLAY=:0
    hinein. Dann klappt's auch mit dem Terminal. Die Option -Y würde ich dem -X vorziehen, letzteres gibt manchmal Probleme und ist auch nicht so sicher.
     
  5. wookenny

    wookenny Erdapfel

    Dabei seit:
    07.06.07
    Beiträge:
    4
    Ich hab jetzt mal
    export DISPLAY=:0
    im Terminal getestet.

    Dann bekomme ich allerdings die Meldung
    No xauth data; using fake authentication data for X11 forwarding.
    und kann auch wieder keine Programme nutzen, die den X Server brauchen.


    Edit:
    Ok, hab jetzt festgestellt, das ich X11 starten muss un dann klappt auch die Verbindung über den Terminal.
     
  6. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Dann stimmt etwas mit der Reihenfolge nicht. X11 muss vor dem Öffnen des Terminals bereits gestartet sein, sonst funktioniert die Geschichte mit "export DISPLAY=:0" nicht. Bei mir habe ich deshalb X11 in den Startobjekten liegen.

    Edith sagt mir, dass Du das auch selbst schon gemerkt hast. :)
     
  7. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Leopard sollte eigentlich X11 automatisch starten wenn man im Terminal eine ssh -X bzw. ssh -Y Verbindung startet. In jedem Fall sollte man heutzutage -Y verwenden.
    Gruß Pepi
     

Diese Seite empfehlen