1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Snow Leo + fetchmail

Dieses Thema im Forum "macOS & OS X Server" wurde erstellt von o2do, 17.09.09.

  1. o2do

    o2do Idared

    Dabei seit:
    25.08.08
    Beiträge:
    27
    Hallo und schönen guten Abend.

    Hatten bis heute Leopard drauf und darauf Mailserver und fetchmail laufen.
    Nach dem update auf Snow Leopard nun folgende Fehlermeldungen in der
    log-Datei von fetchmail:

    fetchmail: 1 message for web289p16 at 195.xxx.xxx.25 (6326 octets).
    fetchmail: reading message web289p16@195.xxx.xxx.25:1 of 1 (6326 octets) (log message incomplete)fetchmail: SMTP error: 504 5.5.2 <195.xxx.xxx.255>: Helo command rejected: need fully-qualified hostname
    fetchmail: connection to localhost:smtp [::1/25] failed: Connection refused.
    fetchmail: connection to localhost:smtp [fe80::1%lo0/25] failed: Connection refused.
    fetchmail: mail from MAILER-DAEMON@xxxxserver.xxxx.lan bounced to xxxx@xxxxx.de
    fetchmail: can't even send to info!
    fetchmail: flushed

    Haben nichts umgestellt, Verbindung vom Client zum Mailserver steht. Nur weiß das fetchmail scheinbar nicht, wo er die Daten hinschieben soll bzw. welchen localhost er benutzen soll.
    Brauche schnelle Hilfe *waaaaaah*

    Grüße
     
  2. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Steht doch eh da was los ist. "Helo command rejected: need fully-qualified hostname". Der SMTP Server verweigert ohne FQDN das Senden, korrigiere Deine [tt]postfix[/tt] Konfiguration. ([tt]smtpd_sender_restrictions[/tt] bzw. [tt]mynetworks[/tt])
    Gruß Pepi
     
  3. o2do

    o2do Idared

    Dabei seit:
    25.08.08
    Beiträge:
    27
    Hallo,

    es geht ja lediglich um das Empfangen.
    Was und wo soll ich denn konfigurieren? Haben ja nichts umgestellt.

    Gruß
     
  4. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Dein [tt]fetchmail[/tt] will sich aber mit dem lokalen SMTP Server verbinden…

    Nichts umgestellt? Das komplette Betriebssystem auszutauschen nennst Du "nichts umgestellt"? Ich erspare mir jetzt jeden weiteren Kommentar dazu.
    Gruß Pepi
     
  5. o2do

    o2do Idared

    Dabei seit:
    25.08.08
    Beiträge:
    27
    Ich habe gesagt ich habe nichts bei der fetchmail confi umgestellt.
    Scheinbar hat auch das DNS Probleme. Hat jemand einen Tipp bezüglich
    der obigen Fehlermeldung, um diesen Fehler zu lösen?

    Gruß
     
  6. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Dann wird der Mac OS X Installer da was geändert haben. Fixe erstmal Dein DNS und überprüfe die [tt]fetchmail[/tt] Konfig ob die nicht auch geändert wurde.
    Gruß Pepi
     
  7. o2do

    o2do Idared

    Dabei seit:
    25.08.08
    Beiträge:
    27
    dns scheint wieder zu gehen. selber fehler aber immernoch. fetchmail config ist geprüft und genauso wie vorher. und nu?
     
  8. o2do

    o2do Idared

    Dabei seit:
    25.08.08
    Beiträge:
    27
    fetchmail: SMTP error: 504 5.5.2 <195.xxx.xxx.255>: Helo command rejected: need fully-qualified hostname

    mittlerweile auf die erro meldung beschränkt, sprich

    fetchmail: connection to localhost:smtp [::1/25] failed: Connection refused.
    fetchmail: connection to localhost:smtp [fe80::1%lo0/25] failed: Connection refused.

    ist nun nicht mehr da.
     
  9. o2do

    o2do Idared

    Dabei seit:
    25.08.08
    Beiträge:
    27
    jetzt nur noch:

    smtp connect to xxxxserver.xxxx.lan failed
     
  10. o2do

    o2do Idared

    Dabei seit:
    25.08.08
    Beiträge:
    27
    wir haben das problem in den griff bekommen. danke trotzdem für die hilfe.
    thread kann dann geschlossen werden. grüße
     
  11. flostere

    flostere Finkenwerder Herbstprinz

    Dabei seit:
    20.08.08
    Beiträge:
    466
    Und was war des Rätsels Lösung? Wäre nett wenn man den Rest der Community auch daran teilhaben lässt ;)
     
  12. o2do

    o2do Idared

    Dabei seit:
    25.08.08
    Beiträge:
    27
    wir haben in der .fetchmailrc lediglich die ip durch die url des webservers, wo unsere mails ankommen beim provider, ersetzt. dann ging es. mit ip funktionierte es unter leo noch, nun nicht mehr. keine ahnung.
     

Diese Seite empfehlen