1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

[SL] Mail.app Probleme nach Update

Dieses Thema im Forum "Mailprogramme" wurde erstellt von Granatapfel, 13.09.09.

  1. Granatapfel

    Granatapfel Granny Smith

    Dabei seit:
    14.11.08
    Beiträge:
    17
    Hallo Leute,

    ich habe ein merkwürdiges Mail.app-Problem seit dem Update von Leopard auf Snow Leopard.

    Im zweiten Benutzerkonto läuft Mail.app nicht rund. Nach dem Starten läuft neben dem Ordner "Gesendet" zunächst der "In Bearbeitung" Kreisel, dann erscheint dort das Symbol für die Überprüfung, wobei nur ein Tortenstück im Symbol zu sehen ist. Ich hoffe, jemand kann mit der Beschreibung etwas anfangen.

    1. Nun nutzt Mail.app die CPU stark aus (50-100%), vernünftiges Arbeiten ist nicht möglich.

    2. Beim Versuch Mail.app zu schließen, verschwindet zwar die GUI, aber der Prozess ist immer noch da und läuft Amok.

    Einzig unsanftes beenden hilft. Ist aber nicht so schön.


    Im ersten Benutzerkonto läuft alles ohne Probleme.


    Was ist bereits versucht habe:

    - mehrfach Zugriffsrechtereparatur, aber nichts, was mit Mail.app in Verbindung gebracht werden konnte, war defekt und wurde behoben

    - Inhalt im entsprechenden Gesendet-Ordern in Mail.app und im Finder gelöscht

    - sqlite3-vacuum-Hint ausgeführt

    - den Gesendet-Ordner aus Frust gelöscht, er wurde beim Mail.app Start wieder erstellt



    Sonst weiß ich auch nicht weiter. Falls niemandem etwas einfällt, werde ich wohl die Mails sichern, E-Mail-Konto neu erstellen und wieder rücksichern.

    Schöne Grüße

    und vielen Dank im Voraus für jede HIlfe!
     
  2. Granatapfel

    Granatapfel Granny Smith

    Dabei seit:
    14.11.08
    Beiträge:
    17
    Hat keiner eine Idee?
     
  3. j33n5

    j33n5 Horneburger Pfannkuchenapfel

    Dabei seit:
    18.12.06
    Beiträge:
    1.405
    Hast du irgendwelche Plug-Ins installiert? Du kannst auch mal „Envelope Index“ in „~/Library/Mail“ löschen. Das ist gründlicher als ein Vakuum.
     
  4. Granatapfel

    Granatapfel Granny Smith

    Dabei seit:
    14.11.08
    Beiträge:
    17
    Habe bereits alle Mail und Safari Plugins in diesem Benutzerkonto gelöscht. Über die Aktivitätsanzeige kann ich sehen, welche Dateien bei Mail mit in Benutzung sind, aber da taucht auch nichts auf, was man gewiss entfernen könnte.

    Index Datei gelöscht. Hilft nicht.

    Mail .plist gelöscht. Hilft nicht.

    Nun sehe ich, dass manche Mails doppelt auftauchen. :(
    Gut dass ich eine Sicherung gemacht habe.

    Jetzt habe ich zusätzlich festgestellt, dass unter Lokal > Outbox ein weiterer Bug zu finden ist. Wenn ich auf den Ordner klicke, wechselt der Mail.app Fenstertitel wild zwischen "Outbox" und "Nicht gefunden" hin und her.

    Ich vermute, dass da irgendwo etwas falsch verlinkt ist. Nur wo?
     
  5. j33n5

    j33n5 Horneburger Pfannkuchenapfel

    Dabei seit:
    18.12.06
    Beiträge:
    1.405
    Puh.. was verrät denn ein Blick in die Konsole?
     
  6. Granatapfel

    Granatapfel Granny Smith

    Dabei seit:
    14.11.08
    Beiträge:
    17
    Code:
    15.09.09 11:08:01	
    Mail[7295]	Error writing to /Users/Benutzer/Library/Mail/POP-benutzer@gmx.de@pop.gmx.net/.mboxCache.plist: 
    Error Domain=NSCocoaErrorDomain Code=513 UserInfo=0x1168955a0 
    "Sie haben nicht die Zugriffsrechte, um die Datei „.mboxCache.plist“ im Ordner „POP-benutzer@gmx.de@pop.gmx.net“ zu sichern." 
    Underlying Error=(Error Domain=NSPOSIXErrorDomain Code=13 
    "Der Vorgang konnte nicht abgeschlossen werden. Zugriff verweigert")
    
    Taucht gefühlte 1000 mal auf, während Mail.app den Mac schwitzen lässt.

    Ich schaue mal was ls -all ausgibt:
    Code:
    -rw-r--r--+  1 benutzer  staff  11654 15 Sep 11:41 .mboxCache.plist
    
    Scheint doch OK zu sein. Überprüfe nochmal die Zugriffsrechte im Finder. Vorher lasse ich auch versteckte Dateien anzeigen. Lesen & Schreiben ist dem Benutzer erlaubt, übertragen auf alle Unterobjekte.

    Test: Wieder ohne Erfolg.

    Google spuckt jetzt aber beim Stichwort „.mboxCache.plist“ einiges aus. Es wird geraten die ganzen „.mboxCache.plist“ zu entfernen und Mail.app neu zustarten.

    Test: Wieder das selbe.


    Stimmt etwas mit den Zugriffsrechten nicht? Der Finder sagt, dass der Benutzer auch Eigentümer des ganzen Mail-Verzeichnisses ist.


    Was nun?

    Hat jemand eine Idee, warum der mboxCache nicht schreibbar ist?
     
    #6 Granatapfel, 15.09.09
    Zuletzt bearbeitet: 15.09.09
  7. j33n5

    j33n5 Horneburger Pfannkuchenapfel

    Dabei seit:
    18.12.06
    Beiträge:
    1.405
    Zumindest nach dem Löschen sollte die Datei beschreibbar sein. Ich bin ratlos, sorry.
    Evtl. macht es Sinn, den gesamten Mail-Ordner mal auf den Desktop zu duplizieren, den alten zu löschen, Mail neu zu starten (Ordner wird neu angelegt), diesen neuen Ordner wieder zu löschen und anschließend den alten zurück zu kopieren.
     
  8. Granatapfel

    Granatapfel Granny Smith

    Dabei seit:
    14.11.08
    Beiträge:
    17
    Nun gut, ich habe das Problem jetzt gelöst.

    Den Mail-Ordner habe ich dupliziert und den alten Ordner gelöscht.

    Mail.app neu gestartet.

    Mail-Konto wurde nur erstellt. Wenigstens die Zugangsdaten waren gespeichert und sofort kamen neue Mails herein.


    Blieb nur die lästige Arbeit mit dem Kopieren der alten Mails. Hier ist letztes mal eine ganze Menge Arbeit angesagt.

    Nachdem ich alle Mails im Finder ausgewählt habe und ist das Messages-Verzeichnis gezogen habe, starte ich Mail.app und lasse das Postfach wiederherstellen. Das Problem dabei: Jetzt durfte ich 15 Minunten lang die ganze Liste der Mails durchgehen und doppelte, dreifache und nochmehrfache Mails löschen.

    Jetzt schnurrt Mail.app aber schön leise vor sich her.


    Vielen Dank für die Unterstützung!
     

Diese Seite empfehlen