• Apfeltalk ändert einen Teil seiner Allgemeinen Geschäftsbedingungen (AGB), die Werbung betreffend.
    Näheres könnt Ihr hier nachlesen: AGB-Änderung

Server Mounten via Automator

jensche

Wöbers Rambur
Mitglied seit
27.10.04
Beiträge
6.495
Bisher habe ich immer meine Server mit einem Apple Script gemountet.

Wie kann ich nun Server Mounten mit Automator.

hier das Skript (apple Script):
mount volume "afp://192.168.50.1/q" as user name "Jens Riedweg" with password ""
mount volume "afp://192.168.50.1/m" as user name "" with password ""
mount volume "afp://192.168.50.1/l" as user name "" with password ""
mount volume "afp://192.168.50.1/j" as user name "" with password ""
mount volume "afp://192.168.50.1/i" as user name "" with password ""
mount volume "afp://192.168.50.1/k" as user name "" with password ""
mount volume "afp://192.168.50.1/n" as user name "" with password ""
mount volume "afp://192.168.50.1/Vol_07" as user name "" with password ""
mount volume "afp://192.168.50.1/Vol_08" as user name "" with password ""

Ich weiss nicht wie ich das mit Automator lösen kann. Wer kann mir weiterhelfen? (kann doch nicht so schwierig sein)
 

jensche

Wöbers Rambur
Mitglied seit
27.10.04
Beiträge
6.495
jensche schrieb:
Bisher habe ich immer meine Server mit einem Apple Script gemountet.

Wie kann ich nun Server Mounten mit Automator.

hier das Skript (apple Script):
mount volume "afp://192.168.50.1/q" as user name "Jens Riedweg" with password ""
mount volume "afp://192.168.50.1/m" as user name "" with password ""
mount volume "afp://192.168.50.1/l" as user name "" with password ""
mount volume "afp://192.168.50.1/j" as user name "" with password ""
mount volume "afp://192.168.50.1/i" as user name "" with password ""
mount volume "afp://192.168.50.1/k" as user name "" with password ""
mount volume "afp://192.168.50.1/n" as user name "" with password ""
mount volume "afp://192.168.50.1/Vol_07" as user name "" with password ""
mount volume "afp://192.168.50.1/Vol_08" as user name "" with password ""

Ich weiss nicht wie ich das mit Automator lösen kann. Wer kann mir weiterhelfen? (kann doch nicht so schwierig sein)

Aus diesem Automator werde ich nicht schlau... habe die Pfade im Automator angeben, jedoch mountet dieser nicht alle Server welche ich angegeben habe. komisch.

was mache ich falsch
 

Anhänge:

he29

Golden Delicious
Mitglied seit
21.02.05
Beiträge
7
Versuch mal die HDD`s manuell zu mounten....dann von allen einen Alias erstellen....diese dann z.Bsp. in deinen "Dokumente" speichern und diese wiederum in den Automator zu schieben (mit "Angegebene Finder Objekte abfragen").

Das ganze noch als Programm speichern und in die Startobjekte kopieren.
 

jensche

Wöbers Rambur
Mitglied seit
27.10.04
Beiträge
6.495
was gibt es für eine Möglichkeit, das man zum Verbinden nicht bestätigen braucht?
 

he29

Golden Delicious
Mitglied seit
21.02.05
Beiträge
7
Keine Ahnung.....hat es denn jetzt funktioniert?
 

jensche

Wöbers Rambur
Mitglied seit
27.10.04
Beiträge
6.495
nööö....... das wäre wieder ein Argument für einen PC....
 

michis0806

Adams Apfel
Mitglied seit
27.02.04
Beiträge
511
Die Frage ist doch eigentlich warum du es nicht weiterhin mit AppleScript machst?
 

he29

Golden Delicious
Mitglied seit
21.02.05
Beiträge
7
jensche schrieb:
nööö....... das wäre wieder ein Argument für einen PC....

Na wenn du meinst.... :-c


Ich habe meine Netzwerk-HDD`s einfach gemountet und dann die gemounteten einfach in das Dock gezogen.

Wenn ich auf eine Platte zugreifen muss klicke ich einfach das Dock-Symbol an und fertig.
 

jensche

Wöbers Rambur
Mitglied seit
27.10.04
Beiträge
6.495
ja klar. aber ich muss eben immer bestätigen (verbinden heissts)
 

he29

Golden Delicious
Mitglied seit
21.02.05
Beiträge
7
jensche schrieb:
ja klar. aber ich muss eben immer bestätigen (verbinden heissts)

hmmm...komisch...das ist bei mir nicht.

Mit den Freigaben/Benutzer-log-ins auf dem Server ist alles in Ordnung?
 

jensche

Wöbers Rambur
Mitglied seit
27.10.04
Beiträge
6.495
kommt immer wieder bei mir. Egal, dann bleibts halt. Bei Win PC kommt das nicht, dann kann man via alias direkt verbinden.