1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

SeeBeyond / JCAPS ans Laufen bekommen jemand?

Dieses Thema im Forum "OS X-Developer" wurde erstellt von Skeeve, 20.12.07.

  1. Skeeve

    Skeeve Pomme d'or

    Dabei seit:
    26.10.05
    Beiträge:
    3.121
    Ich versuche gerade den JCAPS Enterprise Designer auf OS X 10.4.11 ans laufen zu bekommen. Der baut wohl auf einer uralten NetBeans Version auf. Das Zeug startet auch zuerst, bleibt aber dann mit einer NullPointer Exception hängen.

    Hat hier vielleicht jemand das schon mal ans Laufen bekommen und kann helfen?
     
  2. tjp

    tjp Baldwins roter Pepping

    Dabei seit:
    07.07.04
    Beiträge:
    3.255
    Warum nicht den Netbeans 5.5 Enterprise Release? Oder die neue Netbeans 6.0 Version mit dem Enterprise Zeugs? Allerdings läuft unter MacOS X generell kein UML Modeller. Vielleicht geht's mit dem OpenJDK, da das Aqua JDK von Apple leider einen herben Bug enthält. Aber das kann ich mangels Intel CPU nicht ausprobieren.
     
  3. Skeeve

    Skeeve Pomme d'or

    Dabei seit:
    26.10.05
    Beiträge:
    3.121
    Weil das alte Zeug beim JCAPS dabei ist und ich null Ahnung habe ob (und wie) ich dies (Plugins?) mit neuerem Netbeans zumm Kaufen bekomme. Ich hasse diese unausgereifte Sun Software...
     
  4. tjp

    tjp Baldwins roter Pepping

    Dabei seit:
    07.07.04
    Beiträge:
    3.255
    Normalerweise läuft SUN Software recht zuverlässig - auf zertifizierter Hardware und Software. MacOS X gehört definitiv nicht dazu.

    Netbeans und vieles von dem EE Zeugs ist frei und kostenlos erhältlich. Der SUN Java Application Server 9.x gibt es frei von SUN. Schau Dich einfach mal bei Netbeans um, das alte EE Release war 5.5 und es gibt die Tools wieder für 6.0. Ob das ausreichend ist, kann ich nicht sagen.

    Wenn das nichts hilft, mußt Du JCAPS auf einer zertifizierten Hardware/Software benutzen.
     
  5. Skeeve

    Skeeve Pomme d'or

    Dabei seit:
    26.10.05
    Beiträge:
    3.121
    Nur bis es läuft vergehen Stunden um Stunden mit Fehlersuche und patchen.


    Aha. Ich zitiere aus der README.html des Enterprise Designers:
     
  6. tjp

    tjp Baldwins roter Pepping

    Dabei seit:
    07.07.04
    Beiträge:
    3.255
    Kenne ich von Solaris aber anderen Produkten nicht.
    Auf der Webseite steht etwas anderes. Netbeans selbst läuft unter MacOS X, aber das ist nur ein Teil des Produkts. Es müssen garantiert einige Module installiert werden. Ob diese mit MacOS X kompatibel sind kann ich nicht sagen. Das Beispiel UML-Editor zeigt, daß einige Netbeans Komponenten nicht unter MacOS X laufen. Insofern ist der Hinweis mit den unterstützen Plattformen kein Scherz und sollte dem entsprechend beachtet werden.
     
    #6 tjp, 20.12.07
    Zuletzt bearbeitet: 21.12.07
  7. Skeeve

    Skeeve Pomme d'or

    Dabei seit:
    26.10.05
    Beiträge:
    3.121
    Blöde ist ja, daß es nochnichteinmal STARTET. Wenn ich das wenigstens schon mal hin bekäme.

    Wenn ich das repository in der ide.cfg hinzufüge (-J-Drepository.dir=http:/...) dann verschwindet schonmal due NullPointer Exception.

    Nun findet er aber eine MSG_WELCOME nicht:

    Annotation: Missing resource from class: java.util.PropertyResourceBundle
    Annotation: Key which was not found: MSG_WELCOME
    java.util.MissingResourceException: Can't find resource for bundle java.util.PropertyResourceBundle, key MSG_WELCOME
    at java.util.ResourceBundle.getObject(ResourceBundle.java:325)
    at java.util.ResourceBundle.getString(ResourceBundle.java:285)
    at org.openide.util.NbBundle.getMessage(NbBundle.java:399)
    at org.netbeans.core.windows.MainWindow.doShowWindow(Unknown Source)
    at org.netbeans.core.windows.MainWindow.access$300(Unknown Source)
    [catch] at org.netbeans.core.windows.MainWindow$4.run(Unknown Source)
    at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
    at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
    at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
     
  8. tjp

    tjp Baldwins roter Pepping

    Dabei seit:
    07.07.04
    Beiträge:
    3.255
    Mit etwas Suchen findet man den Hinweis, daß SUN Java Studio Enterprise auf Netbeans 5.0 aufsetzt. Das Java Enterprise Creator Paket ist nichts anders, als das ab Netbeans 5.5 erhältliche Visual Web Pack. Letzteres was der Grund warum ich mir wieder Netbeans installiert habe.

    Also, ich würde es erstmal mit dem offiziellen Netbeans 5.0 Release für MacOS X probieren und versuchen die speziellen Pakete zu installieren. Möglicherweise kommst Du so weiter, da Netbeans unterschiedliche Installer für die verschiedenen Plattformen hat.

    Ergänzung:
    Falls es funktioniert (das Nachinstallieren der JCAPS Module) würde ich erstmal Netbeans 5.5 Enterprise installieren und versuchen das in Kombination zu nutzen.
     
  9. Skeeve

    Skeeve Pomme d'or

    Dabei seit:
    26.10.05
    Beiträge:
    3.121
    Wenn ich wüßte, welche Pakete das sind, hätte ich das längst getan. Die kommen alle in einem. Vergleich mit Netbeans 3.4.1 ohne Zusatz ist nicht möglich, da es das Päkchen nciht mehr zum Download gibt

    3.4.1 ohne das branding.jar startet übrigens. Es ist nur diese eine dämliche Meldung die er, aus welchem Grund auch immer, auf Mac OS nicht findet.
     
  10. Skeeve

    Skeeve Pomme d'or

    Dabei seit:
    26.10.05
    Beiträge:
    3.121
    Nur zur Info: Ich versuche nun seit heute Morgen diesen verfluchten ;) eDesigner auf einer Original Sun T2000 (meine ich) zum laufen zu bekommen und erhalte 100% dieselben Fehler wie unter Mac OS X. Sowas frustriert.
     
  11. tjp

    tjp Baldwins roter Pepping

    Dabei seit:
    07.07.04
    Beiträge:
    3.255
    Das ist kein Wunder, denn auf einer T2000 läuft nicht die alte Software, die Du für dieses uralt Programm bräuchtest.
     
  12. Skeeve

    Skeeve Pomme d'or

    Dabei seit:
    26.10.05
    Beiträge:
    3.121
    Das ist aus einem anderen Grund kein Wunder. Und das habe ich mehr oder weniger durch Zufall herausgefunden. Wenn man nämlich den Sun Seiten traut, dann läuft der eDesigner auf Solaris, WinDOS und Linux. Pustekuchen! Im "eGate Integrator User’s Guide" (Part Number: 820-0952-10, Version 20070501192950) Heißt es auf Seite 47
    Das ist mal wieder eine dieser Situationen, die mir bei Sun zu oft unterkommen und die ich einfach hasse. Aber ich denke, da tun sich die großen UNIX-Kistenbauer nix. Nur habe ich mit den anderen nicht (mehr) zu tun.
     

Diese Seite empfehlen