1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Script ausführen funktioniert nicht

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von strauberry, 23.10.06.

  1. strauberry

    strauberry Braeburn

    Dabei seit:
    09.04.06
    Beiträge:
    45
    Hallo zusammen,

    ich brauche einen Compiler für Ada95 (ob das sinnvoll ist oder nicht :) brauche ihn leider)

    jetzt habe ich mir da ein Zip runtergeladen und in der Readme steht folgendes:

    "The quick way to install GNAT is to first run the script 'doinstall'
    contained in this directory..."

    Wenn ich jetzt aber das Terminal aufmache und in das Verzeichnis wechsle und dann einfach "doinstall" eintippe, erhalte ich immer "-bash: doinstall: command not found". Obwohl er da ist, wenn ich mit ls schaue. Wieso das?

    VIELEN DANK!

    strauberry
     
  2. stoebe

    stoebe Uelzener Rambour

    Dabei seit:
    23.12.05
    Beiträge:
    371
    Ins Verzeichnis wechseln und ./doinstall eingeben. Et voilà.


    Grüße,

    stoebe
     
  3. strauberry

    strauberry Braeburn

    Dabei seit:
    09.04.06
    Beiträge:
    45
    Aaaaaaaaaha :)Wunderbar, das hat funktioniert! Jetzt muss ich noch folgendes machen:

    GNAT GPL is now installed. To launch it, you must put
    /Users/christianstraube/Documents/Studium/ada/gnat/bin
    in front of your PATH environment variable. The following
    commands enable you to do this:
    PATH=/Users/christianstraube/Documents/Studium/ada/gnat/bin:$PATH; export PATH (Bourne shell)
    setenv PATH /Users/christianstraube/Documents/Studium/ada/gnat/bin:$PATH (C shell)

    Wie genau geht das und wo? Muss ich danach neu starten oder irgendwas neu laden?

    DANKE!
     
  4. stoebe

    stoebe Uelzener Rambour

    Dabei seit:
    23.12.05
    Beiträge:
    371
    Also, geh ins Terminal und schau erstmal, welche Shell du aktiviert hast:

    Code:
    echo $SHELL

    Falls die Ausgabe "/bin/bash" lautet, gibst du folgendes ein:

    Code:
    PATH=/Users/christianstraube/Documents/Studium/ada/gnat/bin:$PATH; export PATH

    Falls die Ausgabe "/bin/csh" lautet, gibst du folgendes ein:

    Code:
    setenv PATH /Users/christianstraube/Documents/Studium/ada/gnat/bin:$PATH

    Wobei ich mir sicher bin, dass der Teil für die Bourne-Shell für dich relevant sein sollte.


    Grüße,

    stoebe
     
  5. strauberry

    strauberry Braeburn

    Dabei seit:
    09.04.06
    Beiträge:
    45
    Ah super :) Das wird immer besser!

    Noch ein letztes problem, dann sollte es gehen:

    -bash: /Users/christianstraube/Documents/Studium/ada/gnat/bin/gnatmake: cannot execute binary file

    GANZ HERZLICHEN DANK!
     
  6. stoebe

    stoebe Uelzener Rambour

    Dabei seit:
    23.12.05
    Beiträge:
    371
    Puh, da fehlen mir ein paar Informationen? Worum handelt es sich bei dieser Datei?

    Versuch mal "chmod +x /Users/christianstraube/Documents/Studium/ada/gnat/bin/gnatmake"


    Grüße,

    stoebe
     

Diese Seite empfehlen