1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

samba startet nicht...

Dieses Thema im Forum "macOS & OS X Server" wurde erstellt von cybo, 17.09.06.

  1. cybo

    cybo Aargauer Weinapfel

    Dabei seit:
    23.05.06
    Beiträge:
    753
    Tag Leute,

    hoffe ihr könnt helfen. Habe auf einem mac mini einen OS X Server 10.4.7 als eigenständigen Server laufen, also kein LDAP o.ä.
    Ist ein reiner Dateiserver für mac und Windows Clients. Im Server Admin sind AFP und SMB gestartet.
    Nun das Problem: Bei jedem Serverneustart, wird der smb Dienst nicht mehr autom. gestartet, nur der AFP. Man muss den Windows Dienst immer manuell starten.
    In der hostconfig ist automount, smbserver und snmpserver auf -yes- gestellt, in der smb.conf kann ich auch keinen Fehler finden und die üblichen Sachen wie Rechte reparieren, FP überprüfen lassen etc. habe ich auch durch.

    Hat jemand Lösungsvorschläge oder aber evtl. ein Script, welches den smd Dienst startet, sobald Server Admin gestartet ist ?

    Bin für jede Hilfe dankbar, da ich noch nicht so konform mit OS X Server bin, dass mir noch etwas einfällt, was ich vergessen habe.

    Gruß
    cybo
     
  2. mathilda

    mathilda Leipziger Reinette

    Dabei seit:
    17.02.05
    Beiträge:
    1.787
    Hm, also wenn Du jetzt ein Linux hättest, würd ich sagen:
    Geh doch mal in /etc/rc2.d (oder welches Runlevel auch immer bei Dir automatisch startet) und setze einen symbolischen Link auf Deine Sambastartdatei.

    Oder ein Logon-Script? Mehr fällt mir leider nicht ein.
     
  3. janosch

    janosch Gast

    HI!

    Ich haben das selbe Problem. Gibt es eine Lösung dazu?
     
  4. Patrick

    Patrick Uelzener Rambour

    Dabei seit:
    01.05.04
    Beiträge:
    366
    Steht in den Logs während des Bootvorgangs was drin?
     
  5. Marcel Bresink

    Marcel Bresink Sonnenwirtsapfel

    Dabei seit:
    28.05.04
    Beiträge:
    2.413
    Es handelt sich um einen Bug in Mac OS X Server, der in der Tiger-Version leider vorhanden und immer noch nicht behoben ist. In den meisten Fällen liegt es an dem sehr unzuverlässig arbeitenden "launchd"-Dienst, der bestimmte Netzwerk-Features in einer ungünstigen Reihenfolge startet, wodurch andere Dienste "hängenbleiben".

    Es könnte auch daran liegen, dass beim Herunterfahren des Servers "irgendetwas" Ungewöhnliches passiert und so die Information, dass samba lief, nicht richtig abgespeichert wurde. Wie Patrick schon sagt, solltest Du als Erstes das Protokoll /var/log/system.log daraufhin überprüfen, ob irgendein konkretes Problem beim letzten Herunterfahren oder beim Neustart aufgezeichnet wurde.

    Wenn Du nichts findest, bleibt leider nicht viel, als auf 10.4.8 zu aktualisieren und auf Besserung in zukünftigen Versionen zu hoffen...
     
  6. cybo

    cybo Aargauer Weinapfel

    Dabei seit:
    23.05.06
    Beiträge:
    753

Diese Seite empfehlen