1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Safe Sleep Kernel Panic

Dieses Thema im Forum "macOS & OS X" wurde erstellt von thrillseeker, 14.06.07.

  1. thrillseeker

    thrillseeker Lord Grosvenor

    Dabei seit:
    06.10.04
    Beiträge:
    3.497
    Hallo Gemeinde,

    heute ist mir etwas passiert, dass man getrost als den alptraumhaftesten Fehler bezeichnen kann, der mir je an einem Mac untergekommen ist.

    Ich hatte mein PowerBook (G4, 1,67GHz, 1GB RAM) gestern Abend eingeschaltet gelassen, aber dummerweise den Netzstecker abgezogen. Wenn in so einem Fall die Batterie leer ist, geht das PowerBook automatisch in den "Safe Sleep" Modus, um den Speicherinhalt zu schützen. Man erkennt das daran, dass beim Aufwachen ein "grauer Schleier" über dem Bildschirminhalt liegt, und ein Statusbalken erscheint.

    Normalerweise läuft dieser Statusbalken komplett durch, und man kann dann an der Stelle weiterarbeiten, an der das PowerBook eingeschlafen war. Doch nicht bei mir! Bei ca. 50% des Status-Balkens erschien der Schrecken aller Macianer: eine Kernelpanik (deren zugehörige Fehlermeldung in der Mitte zerteilt war!)

    [​IMG]

    "Nicht so schlimm" dachte ich mir und drückte 5 Sekunden auf den Power-Knopf, um meinen Mac abzuschalten. Doch beim Neustart wiederholte sich der Vorgang. Anstatt normal zu booten, startete der Mac erneut aus dem "Safe Sleep" Modus und blieb erneut in einer Kernel Panic hängen :eek:

    Ein paar Versuche später war mir klar, dass ich mir etwas einfallen lassen müsste, wenn ich heute noch bei Apfeltalk vorbeischauen wollte. Also...

    • Apfel + alt + P + R beim Start gedrückt -- ohne Erfolg (der Mac wacht aus dem Safe-Sleep auf und bekommt eine Kernel Panic)
    • Apfel + alt + O + F beim Start gedrückt -- ohne Erfolg
    • Apfel + S beim Start gedrückt -- ohne Erfolg
    • alt beim Start gedrückt -- ohne Erfolg
    • Shift beim Start gedrückt -- ohne Erfolg
    • OS X DVD eingelegt und C beim Start gedrückt -- ohne Erfolg
    • Batterie rausgenommen und 5 Sekunden lang die Power-Taste gedrückt -- ohne Erfolg
    • Batterie für 30 Minuten herausgenommen, damit die Pufferbatterie den RAM nicht länger mit Strom versorgt (das kann sie angeblich nur für ca. 3 Minuten) -- ohne Erfolg

    Nach einer knappen Stunde stand mir der Schweiß auf der Stirn. Nur eine letzte Idee hatte ich noch. Ich nahm beide RAM-Riegel heraus und schaltete den Mac ein. Der bootete natürlich nicht, sondern gab nur einen Warnton aus. Ich legte beide RAM-Riegel wieder ein, und das Problem trat erneut auf. Also entfernte ich einen der zwei Riegel und startete den Mac...

    Heureka: Startsound! grauer Screen mit Apfel-Logo! Startbalken! Login-Fenster!

    Mein Problem ist gelöst - und ich komme mir ein bisschen vor wie ein antiker Krieger, der aus einem dunklen Labyrinth zurückkehrt und den abgeschlagenen Kopf des gefürchteten Drachen bei sich trägt :)
     
    #1 thrillseeker, 14.06.07
    Zuletzt bearbeitet: 14.06.07
  2. Atelis

    Atelis Akerö

    Dabei seit:
    01.03.07
    Beiträge:
    1.831
    eine frage: hast du den sicheren virtuellen speicher aktiviert?
     
  3. thrillseeker

    thrillseeker Lord Grosvenor

    Dabei seit:
    06.10.04
    Beiträge:
    3.497
    Das muss ich erstmal nachsehen...

    (klick, klick, klick)

    Ja, Du hast Recht: der sichere virtuelle Speicher ist aktiviert.
     
  4. space

    space Neuer Berner Rosenapfel

    Dabei seit:
    02.12.05
    Beiträge:
    1.950
    Hmm ja, dann war das wohl der Grund.
    Nachdem Atelis hier mal über Hibernate gepostet hatte, hatte ich mich mal etwas mit diesem Modus beschäftigt und auch gelesen, dass es da Komplikationen bei aktiviertem sicheren virtuellen Speicher geben kann.

    Ich nehme an, dass wohl dann der Hibernate-Modus nicht - oder nicht immer- korrekt umgestellt wird. Ist aber eine reine Vermutung …
    Würde mich interessieren, was da nun passiert ist.
    Und Du, thrillseeker könntest doch mal deinen aktuellen Hibernate-Modus auslesen, eventuell gibt das Aufschluss.

    Gruss

    Edit:
    Das wollte ich ja noch zitieren, auch wenn Du weiter oben geschrieben hattest, dass Du solch einen Start erfolglos probiert hattest:
     
    #4 space, 14.06.07
    Zuletzt bearbeitet: 14.06.07
    thrillseeker gefällt das.
  5. thrillseeker

    thrillseeker Lord Grosvenor

    Dabei seit:
    06.10.04
    Beiträge:
    3.497
    hibernatemode 3

    (default behavior on Powerbook HD and later computers. RAM is still powered on while sleeping. Wake up is fast. Safe sleep is enabled, so RAM contents are also dumped to disk before going to sleep)
     
  6. Atelis

    Atelis Akerö

    Dabei seit:
    01.03.07
    Beiträge:
    1.831
    was hast du noch für geräte an deinem pb angeschlossen? ich hatte nämlich auch mal ein problem mit dem hibernatemode (allerdings mit meinem intel imac), wo es am ende an meinem alten diskettenlaufwerk lag, was nur noch für notfälle angeschlossen war...

    brauchst du den sicheren virtuellen speicher unbedingt? sonst würd ich den abschalten...

    ich würde erstmal den firmware-code probieren...
     
  7. thrillseeker

    thrillseeker Lord Grosvenor

    Dabei seit:
    06.10.04
    Beiträge:
    3.497
    Ein dickes Dankeschön für Eure Beiträge!

    Bevor ich was verändere, will ich lieber noch einmal nachfragen: Wenn ich den oben genannten Beitrag richtig verstehe, dann wäre der richtige Hiberante-Modus für mein PowerBook dieser hier:

    Oder?



    Nein, eigentlich brauche ich ihn nicht... aber ich hab eine gewisse (und wahrscheinlich unbegründete) Hemmschwelle, eine einmal eingestellte Sicherheitsoption wieder zu deaktivieren.

    PS: externe Hardware hing nicht am PowerBook.
     
  8. space

    space Neuer Berner Rosenapfel

    Dabei seit:
    02.12.05
    Beiträge:
    1.950
    Ja, eigentlich wäre 7 der richtige…

    Gruss
     
  9. arc

    arc Leipziger Reinette

    Dabei seit:
    18.10.05
    Beiträge:
    1.787
    Ich meine mich zu erinnern, das es auch Probleme mit "File Vault" (das Du aller Wahrscheinlichkeit nach, wenn Du "Sicheren virtuellen Speicher" aktiviert hast, ebenso benutzt?) im Zusammenhang mit den Schlafmodi geben kann - bin aber nicht ganz sicher ob ich da nich gerade etwas durcheinanderwürfle.

    Aron
     
  10. thrillseeker

    thrillseeker Lord Grosvenor

    Dabei seit:
    06.10.04
    Beiträge:
    3.497
    FileVault ist bei mir deaktiviert, da ich sowieso keine hochsensiblen Daten in meinem Home-Verzeichnis habe.

    Jetzt könnte man natürlich fragen, warum ich dann den sicheren virtuellen Speicher aktiviert habe. Ich meine mich zu erinnern, dass man bei deaktiviertem sicheren virtuellen Speicher das aktuelle Benutzer-Passwort im Klartext aus dem Speicher auslesen konnte. Das erschien mir als ein Schwachpunkt - der sich aber erfreulicherweise mit Bordmitteln ausschalten lässt. Deshalb hab ich's aktiviert.
     
  11. Samoa1808

    Samoa1808 Gast

    Hallo, ich wollte nur eben berichten, dass ich kürzlich die gleiche Kernel Panic hatte.
    Der Bootvorgang nach dem Safesleep zeigte mir immer den versetzten grauen Bildschirm mit dem Hinweis, ich müsse meinen Computer neu starten. Das habe ich einige male gemacht, ohne erfolg.

    Die oben beschriebene Vorgehensweise ist offensichtlich die einzig wirkungsvolle.
    RAM ausbauen > Neustart > Beep abwaretn > ausschalten > RAM einbauen > Neustart > und alles ist wieder gut!!!

    Übrigens hatte ich das Problem unter Leopard auf einem Powerbook G4 1,67....
     

Diese Seite empfehlen