1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Safari speichert Passwörter nicht / Automatisches Ausfüllen funktioniert nicht

Dieses Thema im Forum "Browser" wurde erstellt von herfools, 11.06.09.

  1. herfools

    herfools Golden Delicious

    Dabei seit:
    09.05.09
    Beiträge:
    10
    Hallo miteinander,

    der Grundstein des Problems liegt wohl darin, dass ich nach einer Mail-Adressen-Änderung die betreffenden Passwörter nicht unter Safari -> Einstellungen -> Autom. Ausfüllen -> Benutzernamen und Kennwörter bearbeiten löschen konnte.
    Also fix ins Schlüsselbund reingeschaut und dort die betreffenden Einträge gelöscht (alte Passwörter sind wie gewünscht weg)

    Jetzt kommt zwar bei Passoworteingabe wieder die Abfrage ob ich das Passwort speichern möchte oder nicht, jedoch tut sich nichts. Egal ob später, nein oder ja geklickt wird, kein password wird gespeichert UND die abfrage kommt beim nächsten mal wieder.

    habe schon versucht über das schlüsselbund ranzugehen und dort einen neuen eintrag für betreffende seiten manuell zu erstellen, dort kommt jedoch die Fehlermeldung, dass ich nicht genügend zugriffsrechte habe um auf das schlüsselbund zuzugreifen (bin allerdings administrator).

    Vorschläge? ich bin mit meinem Latein am ende..
     
  2. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.757
    Lösche in ~/Library/Preferences die com.apple.safari.plist. und starte den Browser neu.
    Repariere den Schlüsselbund.
    Achte bei jenen Seiten die einen eigenen Button zum Speichern des Passwortes haben - meistens ohnehin dort, wo es eingetragen wird - dass du auch "immer speicher" oder "angemeldet bleiben" aktiviert hast.
    Und schau dir halt mit Cmd.I noch Mal die Rechte für Safari an.
    salome
     
  3. DaddyPrime

    DaddyPrime Angelner Borsdorfer

    Dabei seit:
    26.04.09
    Beiträge:
    616
    Einfach mal Safari neu installieren. Dann dürfte das ohne Probleme wieder funktionieren.
     
  4. herfools

    herfools Golden Delicious

    Dabei seit:
    09.05.09
    Beiträge:
    10
    schonmal besten dank für die tipps .. also:

    com.apple.safari.plist is gelöscht, hat nich groß was gebracht.

    schlüsselbund würde ich gerne reparieren.. aber ich weiß nich wie. es scheint so als hätte ich irgendwie nicht genügens zugriffsrechte, weil ich dem schlüsselbund nix hunzufügen kann .. nur wie kann ich das beheben?

    habe jetzt nen weg gefunden wie ich die passwörter manuell speichern kann .. habe ein neues schlüsselbund angelegt und die pw's manuell eingegeben und safari kann auch drauf zugreifen, nur muss ich erst einmal am anfang jeder safari session das passwort für eben jenes schlüsselbund eingeben was natürlich wieder lästig is.

    button zum speichern usw. is immer angeharkt.

    cmd + I rechte anschaun von safari?! sorry, sagt mir leider nix, in welchem fenster denn oder wo?!

    safari neu installieren hat übrigends auch nichts gebracht .. ich denke alles in allem is das hauptproblem das zugriffsrecht vom schlüsselbund!
     
  5. Remus

    Remus Wohlschmecker aus Vierlanden

    Dabei seit:
    17.10.07
    Beiträge:
    237
    Bei mir funktioniert das automatische Ausfüllen in Safari 4.0.1 auch nicht richtig. Und das Ganze bei einem völlig neu aufgesetzten 10.5.7 bei einem völlig neuen MacBook Pro 13".
    Zuallererst habe ich in den Einstellungen das automatische Ausfüllen aktiviert, aber bei keiner Seite fragt er mich bisher, ob das Passwort gespeichert werden soll. Hierbei geht es in erster Linie um Foren und LogIns bei Email-Seiten wie Hotmail. Hier bei Apfeltalk fragt mich Safari auch nicht danach.
    Hab dann mal versucht, die Daten manuell im Schlüsselbund einzutragen. Allerdings ist das wie Lotterie spielen. Bei hardwareluxx.de z.B. klappt es danach, hier bei Apfeltalk immer noch nicht. Hab auch schon einige der Tipps hier befolgt, aber ohne ein positiveres Ergebnis. o_O

    Soweit ich mich erinnere, hatte ich das Probleme vor langer Zeit auch schon bei meinem alten MB mit Safari 3 (auch unter Leopard). Hab das Problem dann irgendwie lösen können, dass Safari mich wirklich nach jedem Passwort gefragt hat. Aber ich hab keine Ahnung, wie ich das gemacht hatte.

    Falls jemandem noch etwas einfallen sollte, wäre ich sehr um einen Rat sehr dankbar. Aber es ist schon sehr merkwürdig, dass diese Funktion bei Safari nicht richtig zu funktionieren scheint. Beim Firefox klappt das weitaus zuverlässiger. :(
     
  6. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.757
    Komisch. Bei mir hat nämlich Safari 4 einfach alle gespeicherten PW von Safari 3 übernommen. Wo ich "immer angemeldet" war, bin ich's auch geblieben.
    salome
     
  7. persipanus

    persipanus Erdapfel

    Dabei seit:
    02.06.07
    Beiträge:
    4
    Kann keine Häkchen setzen zum Speichern von Passwörtern

    Hallo zusammen!

    Mein Problem ist, daß ich beim Safari 4.0 unter Safari/Einstellungen/Benutzernamen und Kennwörter... zum einen alte Passwörter bzw. Kennwörter gar nicht einsehen und zum anderen keine *Häkchen* setzen kann, da nichts zum Anklicken vorhanden ist. Mir werden lediglich als Optionen "Entfernen" "Alle entfernen" sowie "Fertig" angeboten. Demzufolge werde ich auch nicht gefragt, ob ich denn Kennwörter überhaupt speichern möchte.

    Das Öffnen des Schlüsselbundes hat auch nichts geholfen, da ich mir lediglich alles nur ansehen, aber nichts verändern kann bis auf das Löschen von gespeicherten Seiten und Benutzernamen.

    Hat jemand einen unkomplizierten Tip für nicht besonders kundige Normalnutzer?

    Danke!
     
  8. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.757
    Vielleicht hilft es die com.apple.Safari.plist und gleich auch com.appleSafari.RSS.plist aus deinem Preferences-Ordner (~Library/Preferences/) zu löschen. Safari neu starten.
    Wenn du noch andere kleine Ärgernisse mit anderen Apple.apps hast, kanst auch das Comboupdate von der Apple Supportsite holen und darüber spielen.
    Sonst fällt mir nichts ein.
    salome
     
  9. darkCarpet

    darkCarpet Halberstädter Jungfernapfel

    Dabei seit:
    02.08.08
    Beiträge:
    3.815
    Das Ausfüllen ist etwas Gefrickels ... Funktioniert nach richtiger Einstellung jedoch.

    Zunächst im Schlüsselbund den den Schlüsselbund "Anmeldung" schützen.

    Nun in Safari den Hacken beim Menüpunkt "Automatisch Ausfüllen" setzten.

    Nun eine Internetseite besuchen und Benutzernamen und Passwort eingeben und speichern lassen.

    Nun im Schlüsselbund, unter dem Menüpunkt "Anmeldung", den Eintrag bearbeiten und die Passwortidentifikation für diesen Eintrag aktivieren. (Dies muss man bei jedem Eintrag manuell einstellen!)
     
  10. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.757
    Wie bitte? Was muss man bei jedem Eintrag manuell einstellen? Ich öffne den Schlüsselbund nur, um zu putzen. Also alte Passwörter deren Ziele gar nicht mehr existieren zu löschen.
    Ich habe aber das Schloss links oben offe, sonst muss man nämlich bei allen möglcihen Aktion das Passwort eingeben.
    Allerdings ist mein Mac nie unbeaufsichtigt.
    salome
     
  11. darkCarpet

    darkCarpet Halberstädter Jungfernapfel

    Dabei seit:
    02.08.08
    Beiträge:
    3.815
    Mein Schloss ist zu.
     
  12. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.757
    Dann musst du bei allen möglichen Gelegenheiten das Passwort eingeben.
    Wenn dir das nicht zu lästig ist.
     
  13. herfools

    herfools Golden Delicious

    Dabei seit:
    09.05.09
    Beiträge:
    10
    da mein problem scheinbar das gleiche ist, wie das von "persipanus" hab ich es mal auf diesem wege probiert. allerdings: nichts.

    alles wie beschrieben gemacht, allerdings ist im schlüsselbund "anmeldung" nach dem vorgang kein neuer eintrag vorhanden .. OBWOHL ich das password für das schlüsselbund eingeben musste nachdem der standardmäßige dialog zum speichern von passwörtern in safari kam .. ich glaube das is der springenden punkt an der ganzen geschichte, aber komme nicht weiter..
     
  14. -nob-

    -nob- Alkmene

    Dabei seit:
    14.06.10
    Beiträge:
    34
    Der Thread ist zwar schon älter, aber nachdem ich auch einen Hänger hatte bin ich dem kurz nachgegangen. Ich hatte für eine Seite angegeben "Passworte nicht speichern", dieser Eintrag ließ sich in den Safari-Einstellungen nicht entfernen. Dieser Eintrag fand sich im Schlüsselbund bei den Kennworten, Eintrag gelöscht, Fehler beseitigt.

    Damit ist klar das Safari Eure Infos aus dem Schlüsselbund ausliest, ist eine selektive Korrektur nicht möglich würde ich einen ganz neuen Schlüsselbund anlegen.

    Gruß, nob
     
  15. Mac 2.2

    Mac 2.2 Clairgeau

    Dabei seit:
    10.06.10
    Beiträge:
    3.735
    Ich hol den Thread mal wieder hervor, denn ich habe seit letzter Zeit genau das gleiche Probleme. Bei mir hat Safari das für ein paar Seiten vergessen, sprich bei manchen Seiten funktioniert das Automatische Ausfüllen noch, aber bei der überwiegenden Mehrheit funktioniert es nicht mehr:( Habe die Plist-Datei schon gelöscht und den Schlüsselbund repariert, hat aber nichts gebracht. Woran liegt das denn? Verwende Safari 6.0.2 unter 10.8.2.
    Generell habe ich die Vermutung, dass Safari nicht alle Felder erkennt. Bestes Beispiel ist hier Apfeltalk: Im Firefox wird mir sofort angeboten Benutzername und Passwort zu speichern, in Safari habe ich noch nie die Meldung gesehen…
    Kennt jemand eine Lösung für das Problem?
     
  16. Mac 2.2

    Mac 2.2 Clairgeau

    Dabei seit:
    10.06.10
    Beiträge:
    3.735
    Update: Mittlerweile habe ich mal alle gespeicherten Passwörter gelöscht gehabt. Jetzt funktioniert es zumindest wieder bei paar Seiten, aber eben nicht überall. Mysteriös:D
     

Diese Seite empfehlen