1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Safari 3 startet nach Downgrade von Safari 4.0 und OSX-Reboot nicht mehr

Dieses Thema im Forum "Browser" wurde erstellt von schniiklas, 07.03.09.

  1. schniiklas

    schniiklas Schöner von Nordhausen

    Dabei seit:
    01.02.09
    Beiträge:
    320
    Nabend.

    Seit einen Reboot stürzt mein Safari immer wieder mit folgender Fehlermeldung ab.

    Code:
    Process:         Safari [206]
    Path:            /Applications/Safari.app/Contents/MacOS/Safari
    Identifier:      com.apple.Safari
    Version:         ??? (???)
    Build Info:      WebBrowser-55281600~1
    Code Type:       X86 (Native)
    Parent Process:  launchd [65]
    
    Date/Time:       2009-03-07 22:03:18.269 +0100
    OS Version:      Mac OS X 10.5.6 (9G55)
    Report Version:  6
    
    Exception Type:  EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread:  0
    
    Dyld Error Message:
      Symbol not found: __ZN3WTF19initializeThreadingEv
      Referenced from: /Applications/Safari.app/Contents/MacOS/Safari
      Expected in: /System/Library/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCore
    
    Kann mir jemand sagen woran es liegt und wie ich es beheben kenn?

    Danke im vorraus.
     
  2. Irgendein Held

    Irgendein Held Oberösterreichischer Brünerling

    Dabei seit:
    17.06.07
    Beiträge:
    714
    Du hast Safari Beta 4 wahrscheinlich grade installiert!? ;)

    Idee!
     
  3. schniiklas

    schniiklas Schöner von Nordhausen

    Dabei seit:
    01.02.09
    Beiträge:
    320
    Nein, Safari 3. Safari 4 startet einwanfrei, wenn ich dann wieder auf 3 downgrade startet Safari aber wieder nicht...
     
  4. karolherbst

    karolherbst Danziger Kant

    Dabei seit:
    11.05.07
    Beiträge:
    3.878
    jo, neustarten hilft. Plug-Ins deinstallieren bringt eher weniger, also bei mir ging alles
     
  5. Irgendein Held

    Irgendein Held Oberösterreichischer Brünerling

    Dabei seit:
    17.06.07
    Beiträge:
    714
    Wenn man fuer Safari 3 Plugins hat, die nicht Safari Beta 4 kompatible sind, dann bringt das schon etwas. ;)

    Das der Downgrade nicht funktioniert ist aergerlich, kann ich mir grad aber leider auch nicht erklaeren. Laut der Build-Info muesste es sich um Safari Beta 4 handeln, was da crashed.
     
  6. schniiklas

    schniiklas Schöner von Nordhausen

    Dabei seit:
    01.02.09
    Beiträge:
    320
    Ich habe bereits mehrere Male neugestartet - ohne Erfolg :(
     
  7. karolherbst

    karolherbst Danziger Kant

    Dabei seit:
    11.05.07
    Beiträge:
    3.878
    mhhh, wahrscheinlich funktioniert der downgrade nicht richtig, dann die optimale allzweck-Lösung: Combo-Update runterladen und installieren.
     
  8. schniiklas

    schniiklas Schöner von Nordhausen

    Dabei seit:
    01.02.09
    Beiträge:
    320
    Kannst du das bitte genauer erklären? :-[

    btw:Nur damit wir uns nicht falsch verstehen ;) Safari war ja schon gedowngradet auf Vers. 3 und lief auch mehrere Tage einwandfrei. Nur jetzt weigert er sich vehement zu starten...
     
  9. schniiklas

    schniiklas Schöner von Nordhausen

    Dabei seit:
    01.02.09
    Beiträge:
    320
    *push*

    Hab das Problem immer noch. Bin jetzt einige Tage mit Safari 4 gesurft ohne Probleme, gestern habe ich dann wieder probiert downzugraden - ohne Erfolg: selber Fehler...
     
  10. Doms

    Doms Stina Lohmann

    Dabei seit:
    05.03.08
    Beiträge:
    1.025
    hast du denn Safari 4 einfach aus dem Programme Ordner gelöscht oder es mithilfe des Uninstall entfernt. Letzteres wäre richtig.

    Vor der Deinstallation von Safari 4, solltest du dir vorher Safari 3 runterladen. Dann lädst du nochmal Safari 4 runter, dort gibts nämlich außer der Installationsdatei auch die Deinstallationsdatei. Letztere öffnest du. Nach dem erfolgreichen deinstallieren von Safari 4, installierst du Safari 3.
     
  11. schniiklas

    schniiklas Schöner von Nordhausen

    Dabei seit:
    01.02.09
    Beiträge:
    320
    Ich habe es bisher immer mit dem Uninstaller deinstalliert. Ich werde es nochmals probieren mit der Installation von S3 nach der Deinstallation von S4.
     
  12. schniiklas

    schniiklas Schöner von Nordhausen

    Dabei seit:
    01.02.09
    Beiträge:
    320
    Und wieder kommt ein Error:

    Code:
    Process:         Safari [248]
    Path:            /Applications/Safari.app/Contents/MacOS/Safari
    Identifier:      com.apple.Safari
    Version:         ??? (???)
    Build Info:      WebBrowser-55281600~1
    Code Type:       X86 (Native)
    Parent Process:  launchd [170]
    
    Date/Time:       2009-03-15 11:59:42.133 +0100
    OS Version:      Mac OS X 10.5.6 (9G55)
    Report Version:  6
    
    Exception Type:  EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread:  0
    
    Dyld Error Message:
      Symbol not found: __ZN3WTF19initializeThreadingEv
      Referenced from: /Applications/Safari.app/Contents/MacOS/Safari
      Expected in: /System/Library/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCore
    
    
    Kann es sein, dass es an Java liegt?

    Code:
    Expected in: /System/Library/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCore
    
     
  13. Irgendein Held

    Irgendein Held Oberösterreichischer Brünerling

    Dabei seit:
    17.06.07
    Beiträge:
    714
    An Java nicht, wenn evtl an JavaScript.
    Ganz sicher, dass du keine PlugIns mehr in /Library/InputManagers hast?
     
  14. schniiklas

    schniiklas Schöner von Nordhausen

    Dabei seit:
    01.02.09
    Beiträge:
    320
    Ja, dort ist alles leer. Habe dieselbe Prozedur eben nochmal gemacht mit leerem Ordner.
     

    Anhänge:

  15. Doms

    Doms Stina Lohmann

    Dabei seit:
    05.03.08
    Beiträge:
    1.025
    guck mal in /Library/Internet Plug-Ins und in "Home-Ordner"/Library/Internet Plug-Ins.
    vielleicht versteckt sich dort der Übeltäter.
     
    schniiklas gefällt das.
  16. schniiklas

    schniiklas Schöner von Nordhausen

    Dabei seit:
    01.02.09
    Beiträge:
    320
    Sieht das nach einem Übeltäter aus? :eek:

    [​IMG]
    http://img.skitch.com/20090315-8qj4x2gcba6ixrpr9efht512w5.jpg

    " "Home-Ordner"/Library/Internet Plug-Ins" existiert bei mir nicht.


    Danke für die bisherige Hilfe!
     
  17. Doms

    Doms Stina Lohmann

    Dabei seit:
    05.03.08
    Beiträge:
    1.025
    all diese Plug-Ins hab ich auch. Zieh doch mal "Flashplayer.xpt" aus dem Ordner, aber nicht löschen und probier dann ob Safari läuft. Wenns es läuft liegt's an der Datei, wenn es weiterhin nicht läuft kannst du die DAtei wieder in den Ordner verschieben.
     
  18. schniiklas

    schniiklas Schöner von Nordhausen

    Dabei seit:
    01.02.09
    Beiträge:
    320
    Immer noch derselbe Error im JavaScriptCore, auch wenn ich alle Dateien in dem Ordner herausschiebe...
     
  19. DBertelsbeck

    DBertelsbeck Tiefenblüte

    Dabei seit:
    20.04.04
    Beiträge:
    6.425
    Bei mir hat es geholfen, zweimalSafari 3.2.1 neu zu installieren.
    Das reine Deinstallieren hat nicht geholfen, obwohl 3.2.1 dann wieder da war.
    Ich hatte auch einen Fehler in java.
     
  20. schniiklas

    schniiklas Schöner von Nordhausen

    Dabei seit:
    01.02.09
    Beiträge:
    320
    Werde ich auch probieren, falls folgendes nicht funktioniert (hab ich eben gegoogelt):

    http://lifein0and1.com/2008/09/09/howto-fix-apples-webkit-and-javascriptcore-framework-error/
     

Diese Seite empfehlen