1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

PureFTPd charset-problematik

Dieses Thema im Forum "Filetransfer" wurde erstellt von raZUpaTO, 09.12.07.

  1. raZUpaTO

    raZUpaTO Gast

    hallo,

    ich hab heute erfolgreich auf 'nem 10.3er OSX-system PureFTPd mit dem PureFTPd Manager zum laufen gebracht (was ja auch nicht sooo schwer ist), so dass ich mittels dyndns.org per ftp auf eben dieses system zugreifen kann.

    alles läuft fein nur anscheinend ein problem: OSX nutzt wohl als dateisystemzeichensatz ein nicht standard-konformen utf-8 zeichensatz. hier und da liest man etwas von utf-8-mac ...

    leider scheint bspw. Filezilla (unter Win) jenen zeichensatz nicht zu kennen/richtig zu interpretieren. auch eine verzeichnis-listung in firefox führt zu reichlichem chaos bei ordnern/dateien mit umlauten usw.

    der ansatz dem ftp-client (bspw. Filezilla) utf-8-mac beizubringen ist wohl die schlechtere lösung, standardkonformes utf-8 sollte vom ftp-server kommen.

    was kann ich nun tun. ich habe ein wenig in den pureftpd-docs rumgelesen und da findet man ja einiges bzgl. charset-conversion. wie ich aber auch gelesen habe läuft beim pureftpd ja alles über kommandozeile und nicht über config-files und im pureftpd-manager habe ich keine option bzgl. charsets gefunden.

    bzgl. osx-commandozeile habe ich auch kaum ahnung (ein wenig linux - ok) ... könnt ihr mir 'n tipp geben - vielleicht auch 'ne alternative zu pureftpd (möglichst mit einfachem frontend)!

    wäre euch sehr dankbar!!!

    vg Alex
     
  2. raZUpaTO

    raZUpaTO Gast

    ok. hat sich schon erledigt ...

    habe im pureftpd manager doch noch eine zeile für zusätzliche kommandozeilen gefunden und als server-charset utf-8-mac und als client iso-8859-1 definiert ... damit scheinen alle probleme behoben.


    ob die server-charset-definition so überhaupt gültig ist weiss ich nicht, auf jedenfall - wie gesagt - keine probleme mehr ...
     

Diese Seite empfehlen