1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Probleme mit Eclipse (unter Java 6)

Dieses Thema im Forum "OS X-Developer" wurde erstellt von Scorpi, 30.04.07.

  1. Scorpi

    Scorpi Braeburn

    Dabei seit:
    05.11.06
    Beiträge:
    47
    Ich hoffe erstmal, dass ich für mein Problem auch den passenden Ort gefunden habe...

    Also folgendes:

    Für die Uni benötige ich die Kombination von Eclipse mit Java 6.. lange zeit hatte JAva 5 gereicht wodurch ich ohne probleme arbeiten konnte...

    Dank dieser Seite: http://www.die-informatiker.net/viewtopic.php?p=66410&sid=f22ad6e11863523b64db85efc34a5767

    war es dann auch nicht weiter schwer erstmal Java 6 allgemein auf dem Mac zu bekommen...

    Nun stehe ich aber vor dem Problem, dass ich irgendwie bei Eclipse nicht wirklich auf Java 6 umstellen kann... zwar kann ich den Compiler auf 6.0 stelllen.. jedoch habe ich die JVM 1.6.0 Bibliothek noch nich auf meinem Mac... und finde diese auch nirgends im i-net!!!

    Hoffe euch wird einigermaßen klar, was ich meine!!!

    schonmal danke für eure Bemühungen!!!
     
  2. dubb3000

    dubb3000 Braeburn

    Dabei seit:
    09.01.06
    Beiträge:
    47
    Hallo

    Soweit ich weiss, gibt es Java 6 noch nicht für Mac. (verbessert mich wenn ich falsch liege).

    Grüße

    P.S.:
    Ups...
    Hab dein Link übersehen. Es gibt noch keine offizielle Version für Mac.
     
  3. MatzeLoCal

    MatzeLoCal Rheinischer Bohnapfel

    Dabei seit:
    05.01.04
    Beiträge:
    2.421
    Java6 kommt erst mit Leopard... ob das überhaupt jemals unter Tiger laufen wird..???
    Für Java6 wirst Du im Moment also mindestens einen ADC Select (500 €) benötigen..


    Opps... es genügt der normale ADC account... ;)
     
  4. Scorpi

    Scorpi Braeburn

    Dabei seit:
    05.11.06
    Beiträge:
    47
    ja den normalen ady account hab ich auch..

    udn wie schon oben erwähnt hab ich alles ganz normal installier bekommen und halt auch sonst noch da sgemacht was Java 6 sonst noch überall einbindet..

    mein Problem bezieht sich eigentlich eben nur auf Eclipse!!!
     
  5. Scorpi

    Scorpi Braeburn

    Dabei seit:
    05.11.06
    Beiträge:
    47
    scheint sich wohl leider keiner damit näher auszukennen!?
     
  6. alaska

    alaska Jamba

    Dabei seit:
    06.08.04
    Beiträge:
    58
    Hi,

    die Installationsroutine ändert nichts den Links auf die aktuelle Version. Die bleiben auf dem offiziellen JDK 1.5.

    Was Du machen kannst (wenn Du die Links nicht per Hand ändern willst) ist die Reihenfolge der VM's ändern. Das kannst Du mit Programme/Dienstprogramme/Java/Java SE 6/Java Preferences

    HTH

    AL
     
  7. Scorpi

    Scorpi Braeburn

    Dabei seit:
    05.11.06
    Beiträge:
    47
    naja wenn ich das aber so mache wie du sagst bekomm ich das aber trotzdem mit dem 6.0 compiler ned zum laufen...

    meines erachtens muss ich echt irgendwie bei eclipse unter properties -> libraries -> edit -> alternate jre -> auf JVM 1.6.0 umstellen könne...

    so kann ich es zumindest auf meinem windows rechner.... das problem ist nur, dass ich eben dieses JVM 1.6.0 beim mac weder zur auswahl hab noch ne idee habe wo ich das herbekomme!?
     
  8. alaska

    alaska Jamba

    Dabei seit:
    06.08.04
    Beiträge:
    58
    Hi,

    ich glaube wir haben uns da wohl mistverstanden: ich meinte Du wolltest Eclipse unter JVM 6 starten. Du aber willst in Eclipse mit JVM 6 compilieren?

    Wenn das so ist, dann musst Du das JDK Eclipse bekannt machen. Also

    nach window->preferences->java->installed JREs gehen, dort auf Add... drücken, einen Namen vergeben (z.B. JVM 6 ;)) und bei JRE home directory

    /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home

    eintragen und mit ok bestätigen --> et viola Du kannst diese VM als Alternate im Projekt auswählen (oder aber auch als Standard definieren, wenn Du willst).

    HTH

    AL

    EDIT: um weitere Missverständnisse auszuräumen: Ich arbeite mit Eclipse 3.2.2. Was meinst Du genau mit properties -> libraries -> edit -> alternate jre?
     
  9. Scorpi

    Scorpi Braeburn

    Dabei seit:
    05.11.06
    Beiträge:
    47
    ich arbeite auch mit 3.2.2 ! und properties -> java ist das gleiche wie window -> preferences -> java (also wenn du rechtsklick auf die projekte machst ;)

    ansonsten hab ich inzwischen alles zum laufen bekommen.... mir wurde bereits auf ner anderen siete geholfe!!!

    aber danke für deine Bemühungen alska!!!
    denn hast mir diesmal auch den weg auch gezeigt den ich gebraucht hätte :)
     

Diese Seite empfehlen