1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Probleme mit Drucken auf Windowsfreigabe

Dieses Thema im Forum "Drucker & Scanner" wurde erstellt von thokl, 30.10.08.

  1. thokl

    thokl Alkmene

    Dabei seit:
    28.06.07
    Beiträge:
    33
    Hallo,

    ich habe mich heute ein wenig gespielt und wollte meinen Drucker, der auf einem Windowsrechner freigegeben ist, auch auf meinem MacBook nutzen.

    Der Drucker ist völlig normal freigegeben und kann mit smbclient -L <ip_windows_rechner> recht schön gesehen werden. Jetzt wollt ich den Drucker wie von der Hilfe vorgeschlagen einrichten, nur habe ich ihn im Reiter "Windows" nicht aufscheinen sehen.

    Mit Hilfe von Google bin ich dann auf die lokale Seite von CUPS (http://localhost:631) verwiesen worden. Mit einigem herumtüfteln und probieren meinte ich schlußendlich auf den richtigen Connect-String gekommen zu sein:
    smb://<windows_username>:<windows_kennword>@<windows_workgroup>/<ip_windows>/<freigabe>

    Geht unter CUPS einwandfrei. Nun scheint der Drucker zwar auch auf der normalen Benutzeroberfläche auf, drucken kann ich aber über die normalen Applikationen auch wieder nicht. Ich hab z.B. versucht, ein Mail auszudrucken. Wurde probiert, allerdings wurde der Auftrag gestoppt mit der Meldung "Identifizierung notwendig" (Meldung in Klammer).

    In CUPS habe ich den Auftrag gesehen, und habe da einfach mal auf "Auftrag freigeben" gedrückt. Siehe da: es wird gedruckt.

    Einerseits mal sicher eine gute temporäre Lösung, aber wie erreiche ich es, dass ich zukünftig drucken kann, ohne jedesmal die CUPS Administration zusätzlich belästigen zu müssen? Auf der normalen Benutzeroberfläche habe ich keinerlei Möglichkeit gefunden, einen Usernamen/Passwort zu spezifizieren.

    Gruß, Thomas
     
  2. thokl

    thokl Alkmene

    Dabei seit:
    28.06.07
    Beiträge:
    33
    Dürfte sich hier in Wohlgefallen aufgelöst haben. Musste den Rechner sowieso mal abschalten, weil ich neuen Speicher eingebaut habe (die Schrauben sind übrigens eine ziemliche Aufgabe aufzubekommen), und nach dem Reboot fragt mich nun CUPS immer brav nach Usernamen und Passwort. Jetzt geht es auch ohne Kunstkniff.

    Gruß, Thomas
     

Diese Seite empfehlen