1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Probleme beim installieren von GPG - 'make' schlägt fehl

Dieses Thema im Forum "Andere Software" wurde erstellt von wiseguy, 05.02.10.

  1. wiseguy

    wiseguy Riesenboiken

    Dabei seit:
    01.01.10
    Beiträge:
    292
    Hallo,

    ich brauche unbedingt wider GPG um meine verschlüsselten Mails wieder lesen zu können (ich hatte ja vorher nen Windows Rechner und da hatte ich GPG installiert).

    Dazu bin ich nach dieser Anleitung vorgegangen und bis zu dem Schritt gekommen, wo man 'make' ausführen muss.
    Dieser Schritt wird mit einem Fehler beendet. Da im Fehler 'libutil.a' vorkommt, dachte ich mir, dass es also damit etwas zu tum haben wird.

    Hier mal das Ende der Ausgabe durch make (ab da, wo das libutil.a vorkommt - jedenfalls hab ichs da erst gesehen):
    Code:
    rm -f libutil.a
    ar cru libutil.a logger.o fileutil.o miscutil.o strgutil.o ttyio.o argparse.o memory.o secmem.o errors.o iobuf.o dotlock.o http.o pka.o membuf.o cert.o convert.o estream-printf.o compat.o    assuan-buffer.o assuan-client.o assuan-errors.o assuan-logging.o assuan-socket-connect.o assuan-connect.o assuan-socket.o assuan-util.o  memrchr.o
    ranlib: archive member: libutil.a(compat.o) cputype (16777223) does not match previous archive members cputype (7) (all members must match)
    ranlib: archive member: libutil.a(assuan-errors.o) cputype (16777223) does not match previous archive members cputype (7) (all members must match)
    ranlib libutil.a
    ranlib: archive member: libutil.a(compat.o) cputype (16777223) does not match previous archive members cputype (7) (all members must match)
    ranlib: archive member: libutil.a(assuan-errors.o) cputype (16777223) does not match previous archive members cputype (7) (all members must match)
    make[2]: *** [libutil.a] Error 1
    make[1]: *** [all-recursive] Error 1
    make: *** [all] Error 2
    Kann mir jemand dabei helfen? Welche Informationen bräuchtet ihr um den Fehler bestimmen zu können?

    Ich hab Snow Leopard auf nem neuen MBP und die SystemTools und UNIX Dev Support aus dem xcode Paket von der Installations CD installiert.
     
  2. wiseguy

    wiseguy Riesenboiken

    Dabei seit:
    01.01.10
    Beiträge:
    292
    UPDATE:
    Das Problem hat sich erledigt: Ich hatte im ersten Durchgang nicht für i386 Compiliert und deshalb sind alle folge Versuche gescheitert.
    Nachdem ich das ganze Verzeichnis gelöscht habe und alles nochmal neu gemacht habe, hats auch einwandfrei geklappt. Jetzt funzt das GPG wieder - sehr schön ;)
     

Diese Seite empfehlen