1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem mit Netzwerk Einstellungen

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Conny, 20.10.08.

  1. Conny

    Conny Starking

    Dabei seit:
    13.01.08
    Beiträge:
    215
    Hallo Leute..

    ...da ist es, mein erstes, meiner Meinung nach ernsthaftes, Problem mit der Software.

    Hier das Problem: Ich komme nich mehr in die Netzwerk Einstellungen. Bekomme über dieses einploppende Fenster die Meldung das die Einstellungen von einem anderen Programm geändert wurden. Auf dem Fenster gibt es nur ein OK zum anklicken, wenn ich das tue kommt es sofort wieder. Dann kann ich nur über sofort beenden die Systemeinstellungen schließen. Neustart hat nichts gebraucht. Alle Updates sind geladen.

    Eine Ahnung was ich getan habe, habe ich jetzt so auch nicht.

    Ich nutze auf einem MacBook von April 2007 immer noch Tiger...

    Hoffe jemand kann mir helfen.

    (Info am Rande: Große Ahung habe ich nicht von Computern, würde mich aber auch nicht als totale Anfängerin bezeichnen.)
     
  2. Conny

    Conny Starking

    Dabei seit:
    13.01.08
    Beiträge:
    215
    OK...Google ist dein Freund...

    Ist das schon die Antwort auf mein Problem?

    Apple hat erst gestern das Security Update 2008-007 herausgebracht und schon melden vereinzelt Benutzer Probleme.

    So ist es häufiger bei Benutzern von Mac OS X 10.4 nach dem Update des Security Update ein Problem die Netzwerkeinstellungen zu ändern.
    So taucht dann immer die Meldung “Ihre Netzwerkeinstellungen wurden von einem anderen Programm geändert” auf.

    Um dieses Problem zu beheben, muss man in folgendes Verzeichnis gehen:

    “Name meiner Festplatte”/Library/Preferences/SystemConfiguration/
    Dort löscht man dann folgende Dateien:

    com.apple.nat.plist
    preferences.plist
    NetworkInterfaces.plist
    com.apple.airport.preferences.plist

    Nach diesem Vorgang sollten sich die Netzwerkeinstellungen wieder ändern lassen.


    >>>sollte ich das einfach machen? Kann ich dadurch andere Probleme verursachen? Habe noch nie solche sachen gelöscht.
     
  3. Conny

    Conny Starking

    Dabei seit:
    13.01.08
    Beiträge:
    215
    so...noch mehr dazu

    Das oben angesprochene Problem existiert bei vielen Usern (vor allem mit OS X 10.4.11) bereits seit letzten Security Update, davon zeugen unzählige Beiträge in Apple-Foren. Es mag zwar sein, das mit dem Löschen der angegeben Dateien meist das Problem behoben ist, mit dem Löschen der preferences.plist datei löscht man sich aber auch komplett alle! Netzwerkumgebungen. Eine weniger radikale Lösung ist in der Systemeinstellung unter Sicherheit das Kästchen: Kennwort verlangen für… anklicken. Solange dieses angeklickt bleibt, existiert das Problem nicht mehr. Apple hat sich übrigens bisher zu dem Problem nicht geäußert.

    Meine Umgebungen brauche ich aber, da ich teilweise über Modem mit mehreren Nummern ins Internet gehe und das über diese Umgebungen konfiguriert habe.

    Also habe ich unter Sicherheit dieses Häkchen gemacht. Aber was bedeutet das genau?
     
  4. Messerjokke79

    Messerjokke79 Eifeler Rambour

    Dabei seit:
    21.07.06
    Beiträge:
    600
    Erstmal will ich dir sagen wie stolz ich auf dich bin! Die meisten Kerle in deiner Situation hätten ihr Anliegen in SMS-Deutsch vorgetragen und einfach auf Antwort gewartet. BRAVO!

    Die angegebenen Dateien kannst du bedenkenlos löschen, sie werden einfach neu wieder hergestellt wenn du z.B. eine Einstellung änderst.

    Du kannst auch die preferences.plist z.B. auf den Schreibtisch verschieben und sehen ob das den Fehler behebt. Wenn's nicht daran lag kannst du die Datei vom Schreibtisch wieder in den Preferences-Ordner legen (vorhandene überschreiben) und die alten Einstellungen sind nach einem Neustart/Logout wieder da.
     
  5. Simpel

    Simpel Granny Smith

    Dabei seit:
    10.02.08
    Beiträge:
    12
    Dieser Haken beseitigt nicht das Problem sondern nur das Fenster. Sobald Du wieder was in den Netzwerkeinstellungen ändern mußt, mußt Du das Schloß öffnen und das Passwort eingeben und der Spaß geht wieder von vorne los. Ist also nur reine Makulatur. Doch es gibt eine Lösung, die das Problem an der Wurzel packt. Durch das Securityupdate 2008-007 wurde die Verwaltung der PPP-Passwörter verändert und dadurch entsteht das Chaos. Man kann natürlich in /Library/Preferences/SystemConfiguration die com.apple.airport.preferences.plist und preferences.plist löschen und durch Neustart neu schreiben lassen, damit sind dann aber auch alle Netzwerkeinstellungen flöten. Wenn man mehrere Umgebungen hat ist das keine Lösung.

    Ich habe nun scheinbar das Problem für mich gelöst.
    Sobald man es schafft nach "OK" im obersten Pulldown-Menü auf "Umgebungen bearbeiten" zu gehen ist der Nervtext erstmal verschwunden (solange bis die Systemeinstellungen wieder geschlossen werden).
    Dann sollte man sich die Umgebungen genau anschauen. Alle die alt sind und die man nicht mehr braucht löschen! Bei allen anderen Umgebungen für "Ethernet", "Bluetooth" und "Internes Modem" genau überprüfen ob per PPP ein Passwort eingetragen wurde. Wenn ja, die Umgebung merken (oder aufschreiben).
    Nun habe ich mir im Schlüsselbund für die besagten Umgebungen die Passwörter angeschaut und aufgeschrieben.
    Zurück zu den Umgebungen (hoffentlich offen gelassen sonst taucht der Text wieder auf) und bei jeder per PPP vergebenen Einstellung das Passwort erneut eingeben. Netconf fragt dann nach, ob es das Schlüsselbund benutzen darf und man bestätigt mit "Einmal" ("Immer" ist ja ausgegraut). Für jedes dieser Passwörter legt das Schlüsselbund einen neuen PPP-Schlüssel unter "System" an.
    Wenn alle (wirklich alle) Umgebungen mit den neuen (alten) Passwörtern versorgt sind kann man die Systemeinstellung schließen und neu starten.
    Seitdem ist bei mir Ruhe!

    Das zweite Problem - das sich das WLAN nicht mehr automatisch an den bevorzugten Netzwerken anmeldet beschreibe ich in einem neuen Thema.

    Gruß, Simpel
     
    #5 Simpel, 05.12.08
    Zuletzt bearbeitet: 05.12.08
  6. beatmasterx

    beatmasterx Granny Smith

    Dabei seit:
    30.07.07
    Beiträge:
    12
    Jeden Tag

    Also ich habe auch das selbe Problem. Zwar habe ich der o. g. Hilfe das Problem mit der Systemsteuerung lösen können, aber immer wenn ich erneut online gehen will, macht der Rechner Probleme.

    Ich muss jedes Mal die plist-Dateien löschen, Neustart aktivieren und dann meine Internetverbindungen neu eingeben.

    Von meinem Haus-Netzwerk ganz zu schweigen, das richte ich im Moment nicht jedes Mal neu ein.

    Bin für jede Hilfe dankbar.

    der beatmaster
     
  7. Messerjokke79

    Messerjokke79 Eifeler Rambour

    Dabei seit:
    21.07.06
    Beiträge:
    600
    leg mal einen neuen user mit admin-rechten an. treten bei dem dann auch solche probleme auf?
     
  8. beatmasterx

    beatmasterx Granny Smith

    Dabei seit:
    30.07.07
    Beiträge:
    12
    es ist ganz schön nervig

    also abwarten half nicht.

    Ich habe jetzt einen weiteren Benutzer angelegt, mit dem habe ich das selbe Problem...

    ich weiss nicht mehr weiter.....

    J
     
  9. beatmasterx

    beatmasterx Granny Smith

    Dabei seit:
    30.07.07
    Beiträge:
    12
    immer noch

    nur so zur Info,

    das Problem habe ich immer noch.

    Ich muss jedes Mal, wenn ich online gehen will, mein Passwort neu eingeben.

    Obwohl es natürlich das selbe ist, wie das gespeicherte, funktioniert es nur, wenn ich es erneut eingeben.

    ???

    bin wohl total meschugge....

    J
     
  10. Messerjokke79

    Messerjokke79 Eifeler Rambour

    Dabei seit:
    21.07.06
    Beiträge:
    600
    Hast du mal das Passwort aus dem Schlüsselbund gelöscht? Mach ein Backup deines Schlüsselbunds und lösche den von der Platte. Dann sollte OS X einen neuen anlegen. Wenn das auch nicht geht, dann würde ich das ganze System neu machen - ohne die alten Systemeinstellungen zu übernehmen.
     

Diese Seite empfehlen