1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem: Files nicht mehr lesbar

Dieses Thema im Forum "macOS & OS X" wurde erstellt von gaumas, 01.02.06.

  1. gaumas

    gaumas Tydemans Early Worcester

    Dabei seit:
    14.01.05
    Beiträge:
    391
    Hallo zusammen

    Bei geschehen seltsame und sehr nervige Sachen...
    Speziell bei .html, .php und .fla Files kommt es im Moment sehr häuffig vor, dass ich die Files überhaupt nicht mehr öffnen kann oder der Inhalt der Files so aussieht, wie das Pic im Anhang.

    Hat das schon mal jemand gesehen??? Ich bin echt am verzweifeln - bin grad an meiner Dipl. Arbeit. Habe zwar x Backups, aber der Fehler tritt bei allen "gebackupten" Files auf....
     

    Anhänge:

  2. G5_Dual

    G5_Dual Melrose

    Dabei seit:
    31.05.04
    Beiträge:
    2.476
    Hast du an den Schriften rumgespielt und welche verschoben, gelöscht?
     
  3. gaumas

    gaumas Tydemans Early Worcester

    Dabei seit:
    14.01.05
    Beiträge:
    391
    Nein - mit den Fonts hab' ich nichts gemacht.
     
  4. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.904
    Backups verändern sich nicht einfach von allein.

    Wie sehen denn zB betroffene HTML Dateien aus, wenn du sie mit TextEdit öffnest und dabei "Formatierungsbefehle ignorieren" anwendest?
     
  5. gococo

    gococo Gast

    Ich denke, dass die Dateien in einer falschen Kodierung gesichert oder geöffnet wurden. Versuche sie mal mit einem Editor wie z.B. BBEdit, Smultron oder Textmate zu öffnen und dabei eine neue Codierung zu wählen.
     
  6. gaumas

    gaumas Tydemans Early Worcester

    Dabei seit:
    14.01.05
    Beiträge:
    391
    ...dann sieht das so aus:

    ñë"®›í÷ZqG⁄f®4”qπosWÈ%∆∫1¸}y?ıà´≈a√À†KÁãa|í®xØ85
    .d&3ë…‡¸Z7èÏn=„b?ˇ«ÕÚ©˝‡
     
  7. iks

    iks Gast

    Ich bin erstaunt! -- vielleicht machst Du mal ein Terminal auf und fragst Darwin per Kommando
    Code:
    file <dateiname>
    um Hilfe.

    cya
    IKS
     
  8. gaumas

    gaumas Tydemans Early Worcester

    Dabei seit:
    14.01.05
    Beiträge:
    391
    ... die Texte kann ich weder in BBEdit noch in SubEthaEdit umcodieren -> Fehlermeldung, dass die Umcodierung nicht möglich ist.

    Jetzt bin ich echt kurz vorm Umkippen.... ich hoffe das Backup im Büro ist ok.
    Ich arbeite im Büro mit PC - das sollte ja auch kein Problem darstellen oder? Könnte es auch an der externen USB Platte liegen (FAT32)..??
     
  9. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.904
    Versuche mal wie das aussieht, wenn du einen "Sicheren Systemstart" hingelegt hast.
    (Booten mit gedrückter Shifttaste. Sofort beim Einschalten drücken und gedrückt halten, bis das "Spinning Wheel" sich dreht.)
     
  10. gaumas

    gaumas Tydemans Early Worcester

    Dabei seit:
    14.01.05
    Beiträge:
    391
    Danke auch für diese Hilfeleistung - hat keine Veränderung gebracht. Ich hab' die Files jetzt noch auf einem Dell-Notebook angeschaut - die sind also definitiv im Eimer. Ich frag' mich echt, wie das passieren konnte - zumal ich einige dieser Files schon länger nicht mehr editiert habe und sie ursprünglich noch ok waren.
     
  11. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.904
    Dell. USB. FAT32.
    Mehra sog i net.
     
  12. gaumas

    gaumas Tydemans Early Worcester

    Dabei seit:
    14.01.05
    Beiträge:
    391
    Mac, DualG5, hsf+ und eine 1Terra FW800 Platte.
    Die hat's bei mir gestern auch zerschossen :)) Soooo einseitig sind dann die Probleme auch nicht ;)
     
  13. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.904
    Lass mich raten: LaCie.
     
  14. Daisy

    Daisy Uelzener Rambour

    Dabei seit:
    14.01.06
    Beiträge:
    366
    Hi gaumas,

    so schnell würd ich nicht aufgeben. Kannst du nicht mal ein Muster zur Verfügung stellen? Ich denke, das würde deine Chancen verbessern, dass jemand rausfindet, was mit deinen Files schiefgelaufen ist.

    Grüße,

    Daisy
     
  15. gaumas

    gaumas Tydemans Early Worcester

    Dabei seit:
    14.01.05
    Beiträge:
    391
    Ta taaaaa 20 Punkte - ist eine Lacie :)

    Klar - ich kann gerne mal ein File zur Verfügung stellen......
     

    Anhänge:

  16. Daisy

    Daisy Uelzener Rambour

    Dabei seit:
    14.01.06
    Beiträge:
    366
    Moin,

    sonderbares Phänomen. Mein Flash öffnet dein Dokument nicht - kann aber daran liegen, dass meine Version zu alt ist (Geht das bei dir auf und du siehst die Scripte als Sonderzeichen oder öffnet es bei dir auch nicht?). Ich habe mir das .fla dann in BBEdit angeschaut - da sehen erst mal alle Actionscript-Bestandteile etc. normal aus - also alles lesbar ohne 'Sonderzeichensalat".
    Bei genauerer Betrachtung (Hexdump) - ist mir aber folgendes aufgefallen (Lösung habe ich allerdings keine - vielleicht kann jemand anders damit was anfangen?):

    während in deinem .fla die Zeile 'while (Number ...) so ausschaut ...

    Code:
    ...
    000017c0  00 20 00 22 00 31 00 22  00 3b 00 0d 00 20 00 77  |. .".1.".;... .w|
    000017d0  00 68 00 69 00 6c 00 65  00 20 00 28 00 4e 00 75  |.h.i.l.e. .(.N.u|
    000017e0  00 6d 00 62 00 65 00 72  00 28 00 78 00 29 00 3c  |.m.b.e.r.(.x.).<|
    ...
    
    ... sieht das in einem von mir testhalber angelegen .fla so aus:

    Code:
    ...
    00000c90  3d 20 22 31 22 3b 0a 20  77 68 69 6c 65 20 28 4e  |= "1";. while (N|
    00000ca0  75 6d 62 65 72 29 00 00  00 00 00 00 00 00 00 00  |umber)..........|
    ...
    
    Bei dir wird also jedes Zeichen durch zwei Bytes dargestellt, bei meinem .fla nur durch eines.
    (Bei mir ASCII - bei dir Unicode??). Hat also doch vielleicht was mit dem Text-Encoding zu tun, dein Prob.


    Grüße,

    Daisy
     

Diese Seite empfehlen