1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem beim Vernetzen von Mac OS X (10.4.8) und Win XP SP2

Dieses Thema im Forum "macOS & OS X" wurde erstellt von emsfeld, 17.11.06.

  1. emsfeld

    emsfeld Gast

    Hallo Leute

    bin grad total am Verzweifeln und würde am liebsten MacBook und PC beide an die Wand schmeissen. Deswegen...rettet meine Computer und schickt mir eure Lösungsvorschläge, bitte!

    Problem:

    Ich versuche mein Macbook Pro und Toshiba Satellite PC (Notebook) per Crossoverkabel direkt zu vernetzen, ist also kein Hub oder Router dazwischen. Dazu gehe ich folgendermassen vor:

    - Weise PC und Mac IPs zu. Beim Mac: 192.168.0.1 und PC: 192.168.0.2 welche auf der gleichen Subnetmaske, 255.255.255.0 liegen.

    -File sharing ist bei beiden aktiviert. Häkchen wurden dementsprechend bei beiden Systemen gesetzt (Windows File Sharing beim Mac, File and Printer Sharing for Microsoft Networks beim PC).

    - Gleiche Arbeitsgruppe zugewiesen, MSHOME in meinem Fall

    - Habe bei beiden Systemen Passwoerter fuer die User Accounts gesetzt da das anscheinend des öfteren ein Grund ist weshalb die Verbindung nicht zu Stande kommt. Beide Accounts haben Administratorrechte.

    Meine Ethernet Internetverbindung auf dem PC heisst LAN. Sobald ich die IPs auf beiden Rechner zuweise aendert sich der Status bei LAN von 'Limited or no connectivity' zu 'Connected'. Ich hab von Networking nicht viel Ahnung, nehme aber mal an dass Packete gesendet und empfangen werden koennen.

    Auf jeden Fall gehe ich dann bei meinem Mac auf Go->Connect to Servers... und tippe smb://192.168.0.2. Hat nicht gefunzt. Versuchte dann: smb://192.168.0.2/PCname. Funzt auch nicht. Hab folgende Kombinationen zusätzlich versucht:

    smb://arbeitsgruppe/pcname

    smb://arbeitsgruppe;pcname

    Klappt alles nicht. Als Fehlermeldung bekomme ich grundsätzlich:

    "The Finder cannot complete the operation because some data in "smb://192.168.0.2" could not be read or written. (Error code -36)."

    Hab auch mal versucht von beiden an beide zu pingen. Fehlanzeige! Destination host unreachable.

    Was mir jedoch noch aufgefallen ist, ist folgendes:

    Solange die Netzwerkverbindung durch das Crossoverkabel steht und ich im Finder auf Network->Arbeitsgruppe gehe, kann ich den Server bzw den Namen von meinem PC nicht sehen. Ziehe ich nun den Stecker beim PC raus, so dass keine physische Verbindung mehr besteht, erscheint auf einmal beim Mac in Network->Arbeitsgruppe der Name meines PCs. HÄÄÄÄÄ? Kann mir das mal einer erklären? Wenn ich dann das Kabel wieder einstecke beim PC verschwindet der Name wieder. Checks überhaupt nicht, kann mir aber nicht vorstellen dass ich der einzige mit diesem Problem bin.

    Ich bitte um eure Lösungsvorschläge!

    Gruß emsfeld
     
  2. emsfeld

    emsfeld Gast

    Ach ja, ich vergass zu erwähnen dass meine Firewalls ausgeschaltet sind.
     
  3. Terminal

    Terminal Gast

    192.168.0.1 ist eine IP die Routern und anderen Management-Netzwerkgeräten vorbehalten ist. Ein Rechner sollte diese nicht verwenden, ausser er ist selbst der Router.

    Für deine Zwecke die du genannt hast, geht das aber nicht daraus hervor. Deshalb empfehle ich dir die IP-Adressen 192.168.2.2 und 192.168.2.3 und die Subnetzmaske 255.255.255.0 zu verwenden.
     
  4. nomos

    nomos Harberts Renette

    Dabei seit:
    22.12.03
    Beiträge:
    7.035
    Das ist völlig wumpe, welche IP der Router hat. Wir konfigurieren die Router immer auf.254

    Wichtig ist, dass die Clients alle die richtige Nummer des Routers eingetragen haben.

    Carsten
     
    #4 nomos, 17.11.06
    Zuletzt bearbeitet: 17.11.06
  5. gloob

    gloob Wilstedter Apfel

    Dabei seit:
    31.01.05
    Beiträge:
    1.915
    FALSCH

    des is total ferze (egal) ob da ne 0 oder ne 2 oder sonst was steht.
    Gibt auch Router die verwenden hinten die 2. Hauptsache is bei beiden Rechnern gleich.

    Aber ansosnten konnte ich bei deinem Vorgehen leider keinen Fehler finden.
     
  6. afrobay

    afrobay Macoun

    Dabei seit:
    25.07.04
    Beiträge:
    118
    hmm, kann jetzt bei deinem text nicht lesen, ob du auf dem pc was freigegeben hast. rechtsklick freigabe. hmm, ansonsten scheint mir da nix falsch zu sein. was du noch machen kannst, ist die rechner anpingen. geht auf beiden seiten: ping 192.168.0.2. so siehst du am besten, ob sie physikalisch verbunden sind...
     
  7. TomTom125

    TomTom125 Gast

    Ping

    wenn der Ping nicht funktioniert - ist entweder eine Fehlkonfiguration oder etwas kaputt - probier mal anderes Kabel aus - ansonsten probier mal ob sie sich selber anpingen können - quasi auf dem Mac 192.168.0.1 und auf dem PC 192.168.0.2 - wenn das funktioniert heisst es quasi dass der Rechner seine eigene Adresse findet - dann kann es fast nur am Kabel liegen.

    Gruß
     
  8. plaetzchen

    plaetzchen Kaiserapfel

    Dabei seit:
    21.10.05
    Beiträge:
    1.729
    Sonst solltest du auch am PC unterm Arbeitsplatz-Ansicht-Ordneroptionen die "Vereinfachte Dateifreigabe" ausmachen.
     
  9. tek

    tek Gast

    hallo - seit dem osx update 10.4.8 habe ich exakt das gleiche problem beim zusammenhängen von win xp und dem mac. ich verwende für das zusammenhängen der computer kein crossover-kabel sondern habe ein ganz normales ethernet netzwerk. es ist ja bekannt, dass bei diesem update einige netzwerkprobleme aufgetreten sind. lustigerweise kann mein mac-mini der im gleichen netz hängt und eine ältere OS version hat ohne probleme auf den pc zugreifen.

    wenn ich bei meinem Dual G5 mit os 10.4.8 versuche den PC via Terminal zu pingen, kommt permission denied. vom mac-mini aus gehts ohne probleme.ich dachte zuerst es liege am pc und habe den gleich formatiert und neu-installiert. anscheinend ist das problem auf mac-seite... meine nächste hoffnung ist das runterladen vom combo-update paket, das soll verschiedene probleme lösen...
     
  10. Snakeviech

    Snakeviech Stechapfel

    Dabei seit:
    07.05.04
    Beiträge:
    161
    Moin,

    smb://192.168.0.2 ist als Eingabe korrekt. Wie schon angemerkt wurde muss allerdings bei deinem Win-PC mindenstes 1 Ordner freigegeben sein - eventuell dieser dann auch mit den korrekten Rechte versehen!

    Was auch wichtig ist, das du ein paar Minuten nach dem "Aufbau" des Netzwerkes wartest. Bei mir verstrichen schon einmal gut 5min bis der PC den Mac unter der Netzwerkumgebung auffand.

    Ich hoffe mit abgeschalteter Firewall hast du auch an die windows-boardeigene gedacht.

    Greetz

    Viech
     
  11. schatzspatz

    schatzspatz Ingrid Marie

    Dabei seit:
    02.03.06
    Beiträge:
    265
    Kann mich meinen Vorredner nur anschließen und sagen, dass ich es genauso mache. Aber wichtig ist, das du einen Ordner unter win freigibst. Ich habe zusätzlich noch einen "2.Benutzer" unter win angelegt, der auf diesem Ordner Schreib- und Leserechte hat. Gehe ich dann in OSX auf "Mit Server verbinden...", dann nutze ich diesen speziellen Benutzer zum Anmelden. Manchmal muss ich aber unter win das Passwort für den Benutzer neu angeben, da win wieder was durcheinander gehauen hat. Aber dann läuft es auch.
    Beim Verbindungsaufbau sollest du auch nicht nur den Win-Rechner angeben, sondern auch direkt den Ordner, den du unter win freigegeben hast. Das sieht bei mir z.b. so aus: smb://chieftec/daten_schatzspatz -- dabei ist chieftec der computername (kann auch die ip sein) und der freigegebene Ordner dann "daten_schatzspatz". Lasse ich die Ordnerangabe weg, bekomme ich den gleichen Fehler wie du.

    Hoffe es hilft.
     

Diese Seite empfehlen