1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem bei der Installation eines Programmes im Terminal und Fink

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von Viwaldi, 23.08.05.

  1. Viwaldi

    Viwaldi Gast

    Hallo zusammen,
    ich hab da ein Problem: ich möchte ein Programm installieren und wenn ich ./configure ausführe, sagt mir das Terminal nach vielen Tests:


    Checking user defined options...

    checking if --enable-debug option was specified... no
    checking if --enable-plugins option was specified... yes by default
    checking for libpcap... yes
    checking for pcap_datalink_val_to_description in -lpcap... yes
    checking for libnet... yes
    checking for libnet_adv_free_packet in -lnet... yes
    checking for openssl... yes
    checking for libpcre... no
    checking for iconv... yes
    checking for library containing iconv... no
    checking for iconv in -lc... no
    checking for iconv in -liconv... no
    checking for libiconv in -liconv... yes
    checking for libncurses... yes
    checking if --enable-gtk option was specified... checking for pkg-config... /sw
    bin/pkg-config
    checking pkg-config is at least version 0.9.0... yes
    yes
    checking for pkg-config... /sw/bin/pkg-config
    checking for GTK_CFLAGS...
    checking for GTK_LIBS...
    Package gtk+-2.0 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `gtk+-2.0.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'gtk+-2.0' found
    configure: error: Package requirements (gtk+-2.0 >= 2.0.0 pango >= 1.0 atk >= 1
    0) were not met.
    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively you may set the GTK_CFLAGS and GTK_LIBS environment variables
    to avoid the need to call pkg-config. See the pkg-config man page for
    more details.




    So das nun zum Terminal. Es fehlt anscheinend gtk2. Fink zeigt mir jedoch an, das gtk2 (Version: 2.4.9-8), pango(Version: 1.2.1-25) und atk(Version: 1.6.1-3) aktuell sind. Naja, ich habs dennoch versuch zu installieren und dann kam das hier:

    Reading Package Lists...
    Building Dependency Tree...
    Sorry, gtk+2 is already the newest version.
    You might want to run `apt-get -f install' to correct these:
    Sorry, but the following packages have unmet dependencies:
    xfree86-shlibs: Conflicts: xfree86-base-threaded-shlibs
    Conflicts: system-xfree86 but 2:4.3-2 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


    Was sind bitte Unmet dependencies??? Was soll ich machen,dass ich mein ursprüngliches Programm zum laufen kriege. Naja ich hoffe es kann mir einer von euch helfen.


    Vielen Dank schon mal für eure Mühen im Vorraus.
     

Diese Seite empfehlen