1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Powerbook per Script aufwecken

Dieses Thema im Forum "OS X-Developer" wurde erstellt von Lausebengel, 01.03.08.

  1. Lausebengel

    Lausebengel Granny Smith

    Dabei seit:
    01.03.08
    Beiträge:
    15
    Hallo zusammen!

    Ich hab ein blödes Problem. Mein Powerbook Titanium 550 MHz geht immer wieder, einfach so, in den Ruhezustand. (im system.log steht dann nur kernel[0]: System Sleep)

    Ich kann dann das Powerbook entweder durch drücken des Ein/Aus Schalters oder bewegen der USB Maus aufwecken.

    Das Powerbook dient als Webradio und "digitaler Photorahmen" und da ist die plötzliche Abschaltung immer störend....

    Kann man es vielleicht durch ein Skript verbessern?
    Ich dachte daran, dass das Skript z.b. alle 10 Sek den Befehl zum Aufwachen an den Kernel schickt. Egal ob das PB schläft oder nicht. Und wenn das Skript dann auch noch im Ruhezustand laufen würde wäre es ja perfekt.
    PB geht in Ruhezustand -> Skript gibt nach max. 10s den Befehl zu aufwachen -> PB wieder an

    Sorry, aber noch habe ich null Ahnung von Appleskript. Bin erst dabei auf MAC zu wechseln.


    DANKE schon mal für eure Hilfe!!!
     
  2. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Wie sehen denn die Systemeinstellungen->"Energie sparen" aus? Ist der Ruhezustand des Computers dort deaktiviert?

    P.S.: Willkommen bei Apfeltalk! :)
     
  3. Lausebengel

    Lausebengel Granny Smith

    Dabei seit:
    01.03.08
    Beiträge:
    15
    Hi!

    Ja, der ist dort komplett deaktiviert.
    PS: Das PB geht aber auch einfach in den Ruhezustand während ich damit z.b. eine E-Mail schreibe...
    Umstieg auf Leopard brachte auch nix (nur viel Arbeit um es zum Installieren zu bringen). Habe das PB auch mal komplett auseinandergebaut und wieder zusammengesetzt, in der Hoffnung dass irgendwas etwas lose sein könnte -> NO...
    Die Anleitungen zum deaktivieren des (möglicherweise defekten) Temperatursenosors brachten auch nix. (ich denke der hat gar keinen, oder?)

    Langsam denke ich es ist entweder das Logic Board, die PMU Batterie oder der Sensor des TFTs...
    Aber nachdem mir das langsam zu stressig wird dachte ich könnte es vielleicht mit dem Skript umgehen.
     
  4. Derivat

    Derivat Niederhelfenschwiler Beeriapfel

    Dabei seit:
    08.02.08
    Beiträge:
    853
    klingt nach der Hauptplatine...
    Mach mal nen SMC-reset.
     
  5. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Geht das PB auch in den Ruhezustand, wenn das Netzteil angeschlossen ist?
    Wenn das PB schläft, läuft weder Kernel noch Script-bares. ;)
     
  6. Lausebengel

    Lausebengel Granny Smith

    Dabei seit:
    01.03.08
    Beiträge:
    15
    @Derivat:
    was ist SMC?

    @quarx:
    Ja, auch wenn das Netzteil dran ist.
    "Wenn das PB schläft, läuft weder Kernel noch Script-bares." ok, dann hat sich das schon mal erledigt. schade!
     
  7. Derivat

    Derivat Niederhelfenschwiler Beeriapfel

    Dabei seit:
    08.02.08
    Beiträge:
    853
    da du ein powerbook hast, heißt das PMU (Power Management Unit). genaueres findest du hier.
     
  8. Lausebengel

    Lausebengel Granny Smith

    Dabei seit:
    01.03.08
    Beiträge:
    15
    @Derivat:

    hat leider nichts gebracht. nach 10 min ging das PB wieder in den Ruhezustand :(
     
  9. Derivat

    Derivat Niederhelfenschwiler Beeriapfel

    Dabei seit:
    08.02.08
    Beiträge:
    853
    hmmm, dann scheint dein powerbook wohl reif für einen werkstattbesuch zu sein... ich hab nach wie vor eine defekte hauptplatine in verdacht. o_O
     
  10. Lausebengel

    Lausebengel Granny Smith

    Dabei seit:
    01.03.08
    Beiträge:
    15
    fürchte auch dass es das LogicBoard ist.
    was mir nur komisch vorkommt ist, dass wenn ich von der Leopard DVD starte das PB NICHT in den Ruhezustand geht. Auch beim Apple Hardware Test nicht (und der findet auch nix)
     
  11. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Kannst Du mal bitte den Inhalt der Datei /Library/Preferences/SystemConfiguration/com.apple.AutoWake.plist posten?
     
  12. Lausebengel

    Lausebengel Granny Smith

    Dabei seit:
    01.03.08
    Beiträge:
    15
    klar:

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>WARNING</key>
    <string>Do not edit this file by hand. It must remain in sorted-by-date order.</string>
    <key>wakepoweron</key>
    <array/>
    </dict>
    </plist>


    wofür ist diese Datei?
     
  13. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Darin würde gespeichert, wann Dein Mac über den Systemeinstellungen->Energie sparen->Zeitplan automatisch in den Ruhezustand geht bzw. aus ihm aufwacht.
     
  14. space

    space Neuer Berner Rosenapfel

    Dabei seit:
    02.12.05
    Beiträge:
    1.950
    Hmm … wenn das auf verschiedenen Betriebssystemen auftritt, so scheint ein Hardwarefehler wahrscheinlich.
    Auch wenn der Hardwaretest keine Ergebnisse gebracht hat, so kann es durchaus an einem RAM Modul liegen. Wenn Du da mal was tauschen könntest, hätte man Gewissheit.

    Bei Powerbook und Schlafproblemen musste ich an einen Post denken, den ich mal gelesen hatte… und nach einer Google-Suche ("Powerbook falling asleep without warning" ) habe ich ihn tatsächlich gefunden:

     
  15. Lausebengel

    Lausebengel Granny Smith

    Dabei seit:
    01.03.08
    Beiträge:
    15
    falls es jemanden interessiert, folgendes habe ich noch ausprobiert:

    im "nur Akku", "Akku und Netzteil", "nur Netzteil" Betrieb getestet -> Fehler immer da
    - PMU reset -> Fehler noch da
    - mit Apple Hardwaretest CD gebootet. Trotz mehrerer Testläufe nichts gefunden...
    - original Apple Arbeitsspeicher eingebaut -> Fehler noch da
    - original Festplatte eingebaut -> Fehler noch da
    - LogicBoard getauscht -> Fehler noch da
    - PRAM-Batterie vom LogicBoard abgehängt und gearbeitet -> Fehler noch da
    - DVD-Laufwerk abgehängt und gearbeitet -> Fehler noch da

    Lösung: nach Berlin zur Begutachtung geschickt (vorher meine Versuche mitgeteilt; ich wollt's einfach wissen):

    -> Es war (laut Reparaturbericht) der Sensor der sagt ob das Display geschlossen ist oder nicht !!!!!!!!!!!!
    Kosten inkl. Hin- und Rückversand 60 Euro

    ES GEHT JETZT 1A!!!
     

Diese Seite empfehlen